Help - Search - Members - Calendar
Full Version: Format Sd In Ext2
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Cxx0 General discussions
mrolympia
Hi please can someone help me?

I now own a C860 and I'm running pdaXrom beta 1 on it with a 1GB SD card.
I have formatted the SD card through WinXP to FAT16 and when I try to install programs to it coming up with a permissions problem.
Someone told me that it needs to be ext2 to install programs on it but then windows won't be able to read the card which I need.

I am new to Linux and can someone give me instructions on how to format the SD card either on the Zaurus or on Suse.

Also is there a way to do 2 partitions on the SD card one ext2 and the other one Fat?

Cheers

Mr O
Jon_J
Here's a link about partitioning CF/SD cards:
http://www.oesf.org/index.php?title=Multip..._a_CF_/_SD_card

It's kinda old, but should work. I haven't tried it yet though.
mrolympia
Thanks for the quick respose however I'm getting an error when trying to umount /dev/mmcda cannot be found. I have checked the dev folder and there is a mmcd and a disk0 within that folder. I've tried umount /dev/mmcd but still no joy.

I'm running pdaXrom, I think this is for openzaurus.

Please can someone tell me where I'm going wrong?


mr O
InSearchOf
do a umount /dev/mmcda1
mrolympia
tried that one too, saying not found
this is what I'm doing

cd /root
umount /dev/mmcda1
umount: /dev/mmcda1

also tried
cd /
umount /dev/mmcda1
umount: /dev/mmcda1

Tried mmcda, mmcda1
when I do
cd/
umount /dev/mmcd it says not mounted
so I go the to next stage
fdisk /dev/mmcd and that says - You will not be able to write the partition table.
unable to read /dev/mmcd

I get a unable to open /dev/mmcda and /dev/mmcda1

I'm very new to Linux please help
Jon_J
I'm also a linux newbie.
I may be wrong, but I think you may need to 'su' to become root before doing anything with mounting.
I formatted a SD card as ext2 in Cacko awhile back
Try these 2 links
http://www.oesf.org/forums/index.php?showtopic=17725&hl=ext2

and formatting for newbies
http://www.oesf.org/index.php?title=Step-b...ing_for_newbies
lardman
You must unmount either the partition or the mount point, so either of these will work (and you only need to use one):

umount /dev/mmcda1
umount /mnt/card

I don't use pdaXrom, so check the output of 'mount' to see that you're unmounting the right thing.

If you want to create partitions then use the instructions linked above. Note that to create partitions you must pass the device, not the partition (or mount point), to fdisk, so:

fdisk /dev/mmcda

(note that there's no 1 on the end).

To format in your current state (first and only partition) do:

mkfs.ext2 /dev/mmcda1

(swap the 1 for a 2 once you've made two partitions, etc.)


Si
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.