Got a new Zaurus C1000 last week and have a very strange problem.

First I installed OZ (worked) then I tried pdaXrom with the new bootloader (worked) then I wanted to try out the oz hentges rom. Cause of the new bootloader I had to do a nand restore but the nand backup I made did not work and gave a format error so I used the backup from trisoft. Since then no kernel can be written onto the device. I modified the updater.sh script to show the errors and I get input/output errors when writing the kernel to the device. Then I did some experiments with the result that when I first completely erase /dev/mtd1 I can write to the flash, but when the /dev/mtd1 partition is completely full input/output errors occur. I then modified the updater.sh script to make a backup of /dev/mtd1 write it back from 0x0 to 0x660000, write the kernel and then write the remaining backup from 0x660000 to 0x680000. This worked and I had a working zaurus.
I am not satisfied with this method (and I can never sell the c1000 with this problem to anyone...) and like to know why it does not work normally? Can it have something to do with the 4 bad blocks I have in the boot partition ? Is there a way to resize the boot partition ? Why did it work with the original rom ?


Thanks for any help.
MrGRiN

P.S.:I tried various sd and 1 cf card for the nand restore with no success. I also tried the nand backup from conics, again no success.