Help - Search - Members - Calendar
Full Version: Compile Woes, Continued!
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Linux Applications
snowfarthing
Since last asked this questionhttp://www.oesf.org/forums/index.php?showtopic=20052, I've been able to successfully install those packages I've listed, as well as make and a few others. Unfortunately, when I try to compile hello.cpp I get a whole slew (pages and pages) of errors; and when I try to run any configure script, it still can't find the compiler.

What am I still missing?

Also, I'm curious: would this process be easier using BitBake? I don't have access to BitBake right now, so I'm stuck with compiling directly on the Zaurus. but it would be useful to know.

Finally, I apologize for starting this new thread: the old one went off-topic and died! (I appreciated the new topic though, since it answered another question I had.)
melee
QUOTE(snowfarthing @ Jul 7 2006, 02:08 PM)
run any configure script, it still can't find the compiler.
*


Hi,

Think a step by step approach called for.

Your output from hello.cpp shows your compiler can't find the most basic header files.

The only header you need for a rudimentary hello.c is stdio.h eg:-

#include <stdio.h>

int main (int argc, char *argv[])
{
printf("Hello, world\n");
}


The compilation commandline can be as simple as:-

arm-gcc(or whatever yours is called) hello.c -o hello

It will expect stdio.h to be in /usr/include

If the above does not compile, your installation is truely screwed up.

Put the highlighted code above in a file called hello.c and try to compile using the highlighted commandline from within that directory and come back with the results.

If that works will need to see what you are trying to compile and what the Makefile contains.

regards

Melee
snowfarthing
I tried to compile both hello.cpp and hello.c; as explained, but neither of them worked. So, at the time, my compiling environment was rather screwed up.

Since then, however, my environment has become really screwed up! I tried installing LaTeX, but kept running into "medium full" errors. It took me a while to realize that this was because all the symbolic links to these files completely filled system memory. This started causing Opie to behave in erratic ways.

So I decided to reinstall everything from scratch, this time using 64-0 image (hoping that it wouldn't keep anything in system memory) and even trying to install Opie on an SD card instead of memory. Because the computers I have access to right now cannot recognize my SD card (one formatted as FAT) and Rock Ridge extensions (don't ask me why; given that these run Windows XP I would have thought so), I'm rather limited as to what I can do.

To further complicate matters, something happened to my ext2 SD card: two directories are now text-files. I suspect that something became corrupted; and as the files I lost are really important, I don't want to do anything with the SD card until I can fsck it (which will probably be at least one and a half to two and a half weeks, since I'm currently at conference and my father-in-law is visiting).

So, in the meantime, I'll be taking a break from my Zaurus. Afterward, I'll seriously tackle the two problems:

First, how do I set up a make environment on my Zaurus?

Second, how do I use BitBake, and what are its limitations? In particular, will I be able to compile anything that I can compile under a normal Linux box?
koen
CODE
    
ipkg install libc6-dev gcc gcc-symlinks g++ g++symlinks make binutils binutils-symlinks libtool coreutils


or

http://www.openembedded.org/wiki/GettingStarted
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.