Help - Search - Members - Calendar
Full Version: ipkg & add/remove software not recognizing all .ipk file
OESF Portables Forum > Everything Else > Archived Forums > Zaurus General Forums > General Support and Discussion > Software
I have an SL-5500 with Sharp 3.10 ROM.

Software installation is currently selectively broken.

I downloaded various versions of the IRK package & put them on my CF card. When I try to install them,none of the IRK's appear on the list of available packges,while plenty of other packages show up. When I try to install from the command line, I get the error

mkdir: Cannot create directory `//home/tmp/ipkg/irk-sl5600': Permission denied

The output of ipkg then suggests that I run "ipkg update" which then attempts to connect to, which is a site definitely not associated with Sharp.

What the heck is going on? Has some package from replaced my ipkg app? :evil: This particular version of ipkg seems to be somewhat incompetent, if it is trying to create a directory with two prepended slashes.

Now here's the interesting thing... I had already installed and then uninstalled one of the IRK packages. I think my ipkg has been replaced or damaged somehow.

Any insight will be appreciated.
You probably need to be root to install from the command line. I don't know about the double slashes.

There are different ipk formats (ar and tar.gz), Sharp only supports tar.gz.

One of the things that I noticed (finally) was that installing IPK's from a card (either SD or CF) wasn't always successful. But when I copied that same file to the Z's internal memory and then attempted the install, I was 100% successful....go figure!
I've experienced a similar problem: the kismet ipk I D/L'd from the ZSI is selectively ignored (not even in the list of installable packages) by "Add/Remove Software." I've tried it on the SD card as well as internal flash, but while very other .ipk in the Install_Files directory is recognised and listed, it is not.

My Sharp 1.32 ROM didn't seem to include a console-based ipkg installer, so I D/L'd the one from the ZUG feed and installed it. (When I did, the GUI installer gave me the semi-English message that I think means unresolved dependencies, but the ipkg app itself seems to run fine.) When asked to install the kiskmet .ipk, it appears to run, outputs no message, but neither does it appear to install the package...what's going on?
I get the error 

mkdir: Cannot create directory `//home/tmp/ipkg/irk-sl5600': Permission denied

I had the same problem (today, when trying installing slrn).
As root, the message was that ipkg was unable to decompress properly the tgz file...
There are different ipk formats (ar and tar.gz), Sharp only supports tar.gz.

in fact, I am getting zcat: unzip_5.24_arm.ipk: noy in gzip format
zcat: stdin: unexpected end-of-file
ipkg_install_file: ERROR unpackaging control.tar.gz from unzip_5.24_arm.ipk

Is there a workaround for this? (currently, I can zip but I am unable to unzip :-(
Getting zcat error too with ipkg install zsafe_2.1.3_arm.ipk.

Successfull workaround:

tar -xvf zsafe_2.1.3_arm.ipk on my linux box (SuSe 9.1).

Then rebuilding the package with: tar -zcvf zsafe_2.1.3._arm.ipk ./debian-binary ./data.tar.gz ./control.tar.gz
New builded package should have same name as the old one.

C760 Cacko ROM
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.