Help - Search - Members - Calendar
Full Version: C3000 Microdrive Replaced With A Cf Card
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 Hardware
atmanian
Hi All,

Have replaced the Microdrive with a Transcend 8GB CF card.
Start C3000 to B D mode, config the partitions and mkfs are all
OK. Install Openzaurus 3.5.4.1 are OK.
But the OZ boots with kernel panic. It shows that
"Unable to mount root fs on unknown-block(0,0)."
I have tried to install the sharp original rom and it failed to boot too.
What can I do next?

Thanks,
Atman
ernestus
i am not an expert but you may try this: try to partition the card before putting it in the machine.
if it does not work, then the card ID is not recognized by the kernel as a storage device, then the solution is a little more complicated.

Good luck!
E
ernestus
sorry, dumb answer. Yes, maybe the kernel does not recognize it as a storage device. Did the zaurus recognize the card when you put it in the external CF connector?
chuckr
It's a long time since you posted this, but maybe you have it working now? I can't get the 8 Gb Seagate 68022CF to be recognized as a dirve in the expernal CF slot. I can use a external CF usb doodad, and when it's connected to my linux box, it seems to be fine, but not when connectd to the Zaurus ... can you tell me what fidks setup you finally used? Maybe include a printout of your fidks output?

Thanks
Blake
Does anyone have any ideas on this? I just swapped in a 16gb A-Data CF card and got this error. I cringe at the idea of toying with those ribbon cables again.

Did those of you who did this successfully format the card before installing? Are we missing something important?

#cardctl ident

product info: "", "", ""
manfid: 0x004f, 0x0000
function: 4 (fixed disk)

If anyone knows of a kernel that will detect this card properly, that would be awesome.

I think I'll take a crack at doing it myself.
deluxe
QUOTE(chuckr @ Sep 23 2006, 09:12 PM) *
It's a long time since you posted this, but maybe you have it working now? I can't get the 8 Gb Seagate 68022CF to be recognized as a dirve in the expernal CF slot. I can use a external CF usb doodad, and when it's connected to my linux box, it seems to be fine, but not when connectd to the Zaurus ... can you tell me what fidks setup you finally used? Maybe include a printout of your fidks output?

Thanks



My Seagate 8 gb CF also doesn't get recognized by my c1000 when connected to the USB port. It's fine in the CF slot, also in any other pc connected any way at all.
I just gave up, since I was only wanting to do it this way when the CF slot was filled with a WiFi card.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.