Help - Search - Members - Calendar
Full Version: Pwm/pi Won't Work On Oz 3.5.3
OESF Forums > General Forums > General Support and Discussion > Software
sibble-comp-oesf
Okay, just installed PWM/Pi from the OZ3.5.3 feeds on my SL-5500, running it from the gui gives me an hour glass and then nothing. Running it from the cli gives me this error

pwmpi: symbol lookup error: pwmpi: undefined symbol: _ZN9KListViewC2EP7QWidgetPK


Any ideas on what's causing that, or how to fix it. Didn't find anything useful on the forum about this error nor via google.
Hrw
install it from feed?
sibble-comp-oesf
QUOTE(Hrw @ Jul 13 2006, 04:52 AM)
install it from feed?
*


I did iinstall it from the feed, the following url to be exact

http://ewi546.ewi.utwente.nl/mirror/www.op....5.3/feed/opie/

are you refering to something else?
koen
QUOTE(sibble-comp-oesf @ Jul 13 2006, 03:15 PM)
QUOTE(Hrw @ Jul 13 2006, 04:52 AM)
install it from feed?
*


I did iinstall it from the feed, the following url to be exact

http://ewi546.ewi.utwente.nl/mirror/www.op....5.3/feed/opie/

are you refering to something else?
*



Yes, remove feeds from earlier versions and just type 'ipkg install <whatever you want>'. Using feeds other than the 3.5.4(.x) ones is unsupported.
sibble-comp-oesf
So you're saying the 3.5.3 feeds no longer work with OZ3.5.3? and as a consequence, items from the 3.5.4 feed WILL work with OZ3.5.3?
lardman
No, that shouldn't be true.

Are you sure you're running OZ 3.5.3? Have you upgraded anything?


Si
sibble-comp-oesf
QUOTE(lardman @ Jul 13 2006, 08:59 AM)
No, that shouldn't be true.

Are you sure you're running OZ 3.5.3? Have you upgraded anything?


Si
*


100% certain, I've had 3.5.3 on this unit since July or August 2005.

I have a second SL-5500 I plan to setup 3.5.4 on, but my 3.5.3 unit has been working quite nicely, I'm not about to break that anytime soon.
sibble-comp-oesf
QUOTE(sibble-comp-oesf @ Jul 13 2006, 08:33 AM)
So you're saying the 3.5.3 feeds no longer work with OZ3.5.3? and as a consequence, items from the 3.5.4 feed WILL work with OZ3.5.3?
*



Well gave it a try and installed the 3.5.4 feed version of pwmpi, it didn't work, library conflicts

# wget http://ewi546.ewi.utwente.nl/mirror/www.op....2.5-r0_arm.ipk
Connecting to ewi546.ewi.utwente.nl[130.89.145.130]:80
pwmpi_2.2.5-r0_arm.i 100% |*****************************| 392 KB 00:00 ETA
# ipkg install pwmpi_2.2.5-r0_arm.ipk
Upgrading pwmpi on root from 2.0.6-r0 to 2.2.5-r0...
Nothing to be done
An error ocurred, return value: 1.
Collected errors:
ERROR: Cannot satisfy the following dependencies for pwmpi:
libmicrokdelibs (>= 2.2.5) libqpe1 (>= 1.2.1) libstdc++6 (>= 3.4.4) libc6 (>= 2.3.5+cvs20050627) libgcc1 (>= 3.4.4)


#ipkg list_installed | grep microkdelibs
kmicrokdelibs - 2.2.5_OZ_gcc3xx -
libmicrokdelibs - 2.1.1-r0 - KDE Pim/PI library - microkde

# ipkg list_installed | grep libqpe1
libqpe1 - 1.2.0-r2 -

# ipkg list_installed | grep libstdc++6
libstdc++6 - 3.4.3-r10 - The GNU cc and gcc C compilers.

# ipkg list_installed | grep libc6
libc6 - 2.3.2+cvs20040726-r15 - GNU C Library

# ipkg list_installed | grep libgcc1
libgcc1 - 3.4.3-r10 - The GNU cc and gcc C compilers.
koen
QUOTE(sibble-comp-oesf @ Jul 13 2006, 05:22 PM)
QUOTE(sibble-comp-oesf @ Jul 13 2006, 08:33 AM)
So you're saying the 3.5.3 feeds no longer work with OZ3.5.3? and as a consequence, items from the 3.5.4 feed WILL work with OZ3.5.3?
*



Well gave it a try and installed the 3.5.4 feed version of pwmpi, it didn't work, library conflicts

# wget http://ewi546.ewi.utwente.nl/mirror/www.op....2.5-r0_arm.ipk
Connecting to ewi546.ewi.utwente.nl[130.89.145.130]:80
pwmpi_2.2.5-r0_arm.i 100% |*****************************| 392 KB 00:00 ETA
# ipkg install pwmpi_2.2.5-r0_arm.ipk
Upgrading pwmpi on root from 2.0.6-r0 to 2.2.5-r0...
Nothing to be done
An error ocurred, return value: 1.
Collected errors:
ERROR: Cannot satisfy the following dependencies for pwmpi:
libmicrokdelibs (>= 2.2.5) libqpe1 (>= 1.2.1) libstdc++6 (>= 3.4.4) libc6 (>= 2.3.5+cvs20050627) libgcc1 (>= 3.4.4)


#ipkg list_installed | grep microkdelibs
kmicrokdelibs - 2.2.5_OZ_gcc3xx -
libmicrokdelibs - 2.1.1-r0 - KDE Pim/PI library - microkde

# ipkg list_installed | grep libqpe1
libqpe1 - 1.2.0-r2 -

# ipkg list_installed | grep libstdc++6
libstdc++6 - 3.4.3-r10 - The GNU cc and gcc C compilers.

# ipkg list_installed | grep libc6
libc6 - 2.3.2+cvs20040726-r15 - GNU C Library

# ipkg list_installed | grep libgcc1
libgcc1 - 3.4.3-r10 - The GNU cc and gcc C compilers.
*



Never, EVER install single packages, unless you are absolutely sure that's going to work. Having said that: add the 3.5.4 feed base and opie and do 'ipkg update ; ipkg install pwmpi'
sibble-comp-oesf
Say what? I've never heard that or seen that before. It seems to be pretty common practice on the forums here.

I mean the worst that should generally happen is the single package won't work.

Okay, well I'm crossing my fingers that this won't blow up my unit :-(

Okay, so only change my source for base and opie and leave the other sources at the 3.5.3 ones then?
sibble-comp-oesf
End result

# ipkg update
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op...g/official/unst
able/3.5.3/upgrades//Packages
Updated list of available packages in /usr/lib/ipkg/lists/upgrades
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op...g/official/unst
able/3.5.4/feed/base//Packages
Updated list of available packages in /usr/lib/ipkg/lists/base
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op...g/official/unst
able/3.5.3/feed/libs//Packages
Updated list of available packages in /usr/lib/ipkg/lists/libs
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op...g/official/unst
able/3.5.3/feed/console/Packages
Updated list of available packages in /usr/lib/ipkg/lists/console
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op...g/official/unst
able/3.5.3/feed/devel//Packages
Updated list of available packages in /usr/lib/ipkg/lists/devel
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op...g/official/unst
able/3.5.4/feed/opie//Packages
Updated list of available packages in /usr/lib/ipkg/lists/opie

# ipkg install pwmpi
Upgrading pwmpi on root from 2.0.6-r0 to 2.2.5-r0...
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op...g/official/unst
able/3.5.4/feed/opie//pwmpi_2.2.5-r0_arm.ipk
Upgrading libmicrokdelibs on root from 2.1.1-r0 to 2.2.5-r0...
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op...g/official/unst
able/3.5.4/feed/opie//libmicrokdelibs_2.2.5-r0_arm.ipk
An error ocurred, return value: 1.
Collected errors:
Package libmicrokdelibs wants to install file /opt/QtPalmtop/lib/libmicrokde.so
But that file is already provided by package kmicrokdelibs
sibble-comp-oesf
Decided to take a chance ;-)

# ipkg -force-overwrite install pwmpi
Upgrading pwmpi on root from 2.0.6-r0 to 2.2.5-r0...
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op....2.5-r0_arm.ipk
Upgrading libmicrokdelibs on root from 2.1.1-r0 to 2.2.5-r0...
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op....2.5-r0_arm.ipk
Upgrading libz1 on root from 1.2.2-r5 to 1.2.3-r0...
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op....2.3-r0_arm.ipk
Upgrading libgcc1 on root from 3.4.3-r10 to 3.4.4-r3...
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op....4.4-r3_arm.ipk
Upgrading libc6 on root from 2.3.2+cvs20040726-r15 to 2.3.5+cvs20050627-r0...
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op...0627-r0_arm.ipk
Upgrading libqpe1 on root from 1.2.0-r2 to 1.2.1-r0...
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op...1-r0_collie.ipk
Upgrading libstdc++6 on root from 3.4.3-r10 to 3.4.4-r3...
Downloading http://ewi546.ewi.utwente.nl/mirror/www.op....4.4-r3_arm.ipk
Configuring libc6
ldconfig: /usr/lib/libpcap.so.0.7 is not a symbolic link

ldconfig: /usr/lib/libglib-1.2.so.0 is not a symbolic link

Configuring libgcc1
ldconfig: /usr/lib/libpcap.so.0.7 is not a symbolic link

ldconfig: /usr/lib/libglib-1.2.so.0 is not a symbolic link

Configuring libmicrokdelibs
ldconfig: /usr/lib/libpcap.so.0.7 is not a symbolic link

ldconfig: /usr/lib/libglib-1.2.so.0 is not a symbolic link

Configuring libqpe1
ldconfig: /usr/lib/libpcap.so.0.7 is not a symbolic link

ldconfig: /usr/lib/libglib-1.2.so.0 is not a symbolic link

Configuring libstdc++6
ldconfig: /usr/lib/libpcap.so.0.7 is not a symbolic link

ldconfig: /usr/lib/libglib-1.2.so.0 is not a symbolic link

Configuring libz1
ldconfig: /usr/lib/libpcap.so.0.7 is not a symbolic link

ldconfig: /usr/lib/libglib-1.2.so.0 is not a symbolic link

Configuring pwmpi
Collected errors:
Warning: remove /port.png failed: No such file or directory
sibble-comp-oesf
Well so far so good, other than bootup time taking a bit longer, pwmpi is working and kapi and kopi are both still working fine.

A few other apps I've tried also seem to be okay.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.