Help - Search - Members - Calendar
Full Version: Apache With Php
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > 6000 - Tosa
james_nak
For the life of me I cannot get php running. From the gui installer, I get an ipkg error that something is wrong. From the console it installs but no php. When a php page is loaded Opera wants to download it. I've tried about every .ipk file. I know it works as I have seen it work on my 5600.
Any help or hints on what to look for would be appreciated.

thanks
totaln00b
What's the ipkg error that you get?

Is this with the package that includes both apache and php from http://www.choup.net/linux/pda/apache-1.3....2.3_0.1_arm.ipk?

Are you certain that apache is working?

Sometimes you need to alter the httpd.conf file in apache to ensure that php files are dealt with correctly but if you use the combined package then I assume that has been done for you.

Jo
james_nak
Jo, thanks for your reply. Unfortunately the error is not descriptive but on says in effect that "Sorry, Ipkg has an error installing."

And yes, I am sure that I am using the package with php. In fact, I had downloaded that very package from choup.

I know that Apache is running because I can see the start screen with http://127.0.0.1 and also the server error when trying to run Perl, which I haven't loaded. All this of course after issuing an "www/bin/httpd start" command.

I've checked the config file and it looks like it should work only that I'm pretty sure the php exe files are not there.

If anyone knows where they are supposed to be located (I believe in Applications) that might be a start.

Thanks in advance.
zmiq2
Hi James,

for your words I understand that apache is working fine, but does not interpret php scripts.

You should verify your httpd.conf file to make sure that you:
1) load the php apache module
2) make all .php files be interpreted

Read php documentation about what changes need to be done to httpd.conf

HTH
james_nak
OK, I'l give it a go. The strange thing is that I never had to do this kind of tweaking before; it just worked. Anyone else ever had this problem?

Thanks for the help.
Ferret-Simpson
Only once, I formatted the Zaurus and installed Apache/PHP BEFORE any other package.

No problems yet!
james_nak
Me thinks there is something to that.

Thanks.
zmiq2
So I had an apache at hand, so here are the entries that should exist in your httpd.conf to make sure .php files are being sent to the interpreter:

LoadModule php4_module libexec/libphp4.so
AddType application/x-httpd-php .php

HTH
james_nak
Thanks! I will check that out immediately.

James
Ferret-Simpson
Well, if it's not installing right. . .

Try doing it from konsole or Qterminal.

ipkg install packagename. . .or something similar. . .
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.