Help - Search - Members - Calendar
Full Version: Cf Bluetooth Pairing With Different Phones
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Fatty
I have C1000/C3100 with Socket CF BT (Rev K) and beta1/3.

They ALL work out of box with my SE Z800 and Nokia 6222.

They don't work with my smartphones O2mini (WM2003), Mio A700 (WM5), Motorola A1200 (Linux) with 'Can't find DUN'.

Anyone has the same issue or workaround?
Fatty
No one succeed in pairing with WM smartphone?
louigi600
Can you detect the devices with "hcitool scan" you should get something like this (I only have a nokia 6230):
# hciconfig hci0
# hcid
# hcitool scan
Scanning ...
00:0E:ED:64:A8:F1 Nokia
#

What happens if you do this by hand:
# rfcomm connect rfcomm0 <YOUR PHONE MAC ADDRESS>

Here is a script I use in environments where I have full controll ... (but I have not yet tried it on pdaXrom). It will require bluez stack to have any chance of working ... but pdaXrom apperars to use bluez stack.

#########cut here
#!/bin/sh
NAME=$(basename $0)

usage ()
{ echo "Bluetooth management script"
echo "Sinopsys:"
echo "$NAME <start|stop|status|connect|scan>"
}

start_bluez ()
{ #neaded modules: bluez hci_usb rfcomm l2cap
hciconfig hci0 up || echo "Failed activating hci0"
hcid || echo "Failed activating hcid"
}

stop_bluez ()
{ killall rfcomm > /dev/null 2>&1
killall -9 hcid > /dev/null 2>&1
hciconfig hci0 down
#removing these modules seems to crash newre kernels
# l2cap hci_usb rfcomm bluez
}

stat_bluez ()
{ hciconfig
hcitool con
[ $(ps -ef |grep -v grep |grep -c hcid) -ge 1 ] && echo "hcid running" || echo "hcid not running"
}

conn_bluez ()
{
MACS=$(hcitool scan | grep ":" | awk '{print $1","$2","$3" "}')
ANS=1
if [ $(echo $MACS | wc -w) -gt 1 ]
then
i=1
for MAC in $MACS
do
echo "$i $(echo $MAC | tr "," " ")"
i=$(expr $i + 1)
done
echo -n "Select device [1] "
read ANS
[ "$ANS" = "" ] && ANS=1
[ $ANS -ge $i ] && ANS=1
else
echo -n "connecting to $(echo $MACS | tr "," " ") ..."
sleep 2
echo
fi
MAC=$(echo $MACS | awk -v a=$ANS '{print $a}' | awk -F, '{print $1}')
[ ! -c /dev/rfcomm0 ] && mknod /dev/rfcomm0 c 216 0
[ $(lsmod |grep -c "^rfcomm") -ne 1 ] && modprobe rfcomm
rfcomm connect rfcomm0 $MAC &
}

case $1 in
start) start_bluez ;;
stop) stop_bluez ;;
status) stat_bluez ;;
scan) hcitool scan ;;
connect|conn) conn_bluez ;;
*) usage
exit 1 ;;
esac

###########cut here

Regards
David
Fatty
Thanks for your suggestion. I've bought another smartphone Nokia N80 and have little progress but still failed to connect via pppd. Here's the story.

hcitool scan found my phone. So I followed your suggestion, at the console, fired up:

rfcomm connect rfcomm0 <MAC ADDRESS>

and it reported: Connected /dev/rfcomm() to blah blah blah
Press CTRL-C for hangup.

I also noticed my phone's bluetooth signed connected. I assumed the Z and my phone are connected.

I then started pppdialer and press connect. It showed:

abort on (NO CARRIER)
abort on (NO DIALTONE)
abount on (Busy)
send (ATZ^M)
expect (OK)
warning: read() on stdin returned 0
Failed
Can't restore terminal parameters.
Input/output error

Connect script failed

My pppd profile look like this:

connect '/usr/sbin/chat -s -v ABORT "NO CARRIER" ABORT "NO DIALTONE" ABORT "BUSY" "" "ATZ" OK ATDT*99# CONNECT'
crtscts blah blah blah

Is it the profile issue or the bluetooth connection is indeed bad? Please help.
Fatty
I set up the Z to work with my Nokia 6222 (a normal phone) with pppconfig and pppdialer, and can go as far as 'send atdt*99#' which got no carrier. Of course, the phone can't connect via GPRS.

I then edit the /etc/bluetooth/rfcomm.conf and put in my N80 MAC and tried again with the pppdialer, and can now connected to the net!
zeigerpuppy
I have a similar setup with C3100, Socket CF BT (Rev K) pdaXrom beta3.
My phone is a sony ericsson k600i

The two pair well via bluetooth and calls are established by the string *99***2#
Everything fine so far.

However, I have been having a problem lately that when transfers are going quite fast
(up to 100k/sec with 3G connection), the connection sometimes drops out
This also crashes sylpheed sad.gif

I did not notice this problem with the Cacko Rom
Has anyone had a similar problem
Any advice on how to debug this?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.