Help - Search - Members - Calendar
Full Version: SDL 1.2.7 compiled for Qtopia.OPIE
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > User Request for Applications
Anonymous
I'm not sure if it's my compiler but my compile for SDL 1.2.7 stable just won't work, I get SDL Parachute Deplyed when I start any SDL app which is then followed by a Segmentation Fault. I'd really like to get this up and running. If anyone's got a working compile of this library, care to share it, as well as tell me what you did to compile it.

I'm running OZ 3.2, and I'm compilling with the 2.95.2 cross compiler on gentoo linux, in case that's important.
Mickeyl
Show us your compile and link flags. Do you use the main() provided by libSDLmain.a ?
Anonymous
>>>>Deplyed when I start any SDL app which is then followed by a Segmentation Fault..

Sometimes with some programs has left "segmentation fault" and is due to problems with lower memory.
I have solved this, adding an swap CFmemory

Regards.
Anonymous
Doh, my compile flags. The arm-linux-gcc is still going to use the flags in my make.conf... Me being a gentoo guy have aloot of optimization flags in there.

I didn't even think, thanks, I'll remove those and have a go again.

Hmmm... what -O should I use? I'll try with 2 first...
Anonymous
Ok, ignore the previous post...

I tried compilling the exact way the SDL author discribes in the readme.Qtopia file (inside the SDL source code archive) and it yeilds a 1.3 MB file, I know it shouldn' be this large and shows that my compile isn't going right somewhere.

Has anyone else tried compilling SDL (with the arm-linux-gcc 2.95.x)?
Anonymous
I compiled it successfully and got a 1.4M library out with gcc-2.95.
SDL apps run, but the video is screwed up, I see three copies of the zfceu output. Sigh.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.