Help - Search - Members - Calendar
Full Version: Qpegps 9.2.3.3
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > OpenZaurus/Opie/Qtopia
lazd
Just wondering if anyone has compiled qpegps 9.2.3.3 (source at http://sourceforge.net/project/showfiles.p...ckage_id=51026) for openzaurus 3.5.4 yet, or has plans to in the future. I currently run 9.2.3 fine, but 9.2.3.3 has much needed features and bug fixes. Why wouldn't qpegps 9.2.3.3 be included in 3.5.4? It was released in February of 06' it seems.

On the qpegps site, they provide binarys that are only compatible through runcompat, which I read corrupts and crashes like none other (see http://www.oesf.org/forums/index.php?showt...2&#entry129302) so I haven't tried to install it (although running the binary from the IPK mentioned above produces a standard compat error looking for _20t.darkCyan, something I saw corrected in other applications under 3.5.3 with the compat libs).

Would it be much work? I've only compiled things on desktop linux boxes that already had gcc and everything ready to go, but if it's not that bad to get the zaurus compiling apps, I would do it and try to make an ipk if someone would point me in the right direction.

Thanks
lardman
QUOTE
Why wouldn't qpegps 9.2.3.3 be included in 3.5.4? It was released in February of 06' it seems.


No reason except that no-one has bothered to add it (as they didn't need it).

It may be as simple as altering the .bb file to point to the new source. Give it a go and see whether it works.

qpegps is in the OE metadata already. I don't know its status.


Si
Mickeyl
I'm a bit hesitant to update qpegps because of their stubborness to catch up with gpsd.
lazd
Yeah, I could see that. I guess I'll install the development related packages and try to compile the newest version. Any help would be appreciated.
Stilgar
qpegps have, on their sf downloads page, a link to a version of gpsd compiled with softcore (from somewhere during 2003). That version would work with qpegps under OZ.
That said, I will be glad that they'll move on to the new gpsd, but still - I'd like to see the new version compiled to OZ, even with this inconvenience..
hvontres
QUOTE(lazd @ Aug 10 2006, 04:28 PM)
Just wondering if anyone has compiled qpegps 9.2.3.3  (source at http://sourceforge.net/project/showfiles.p...ckage_id=51026) for openzaurus 3.5.4 yet, or has plans to in the future. I currently run 9.2.3 fine, but 9.2.3.3 has much needed features and bug fixes. Why wouldn't qpegps 9.2.3.3 be included in 3.5.4? It was released in February of 06' it seems.

On the qpegps site, they provide binarys that are only compatible through runcompat, which I read corrupts and crashes like none other (see http://www.oesf.org/forums/index.php?showt...2&#entry129302) so I haven't tried to install it (although running the binary from the IPK mentioned above produces a standard compat error looking for _20t.darkCyan, something I saw corrected in other applications under 3.5.3 with the compat libs).

Would it be much work? I've only compiled things on desktop linux boxes that already had gcc and everything ready to go, but if it's not that bad to get the zaurus compiling apps, I would do it and try to make an ipk if someone would point me in the right direction.

Thanks
*


You might want to check out this thread as well:

Updating Qpegps - New Gpsd And More, Qpegps with gpsd 2.3X and other stuff
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.