Help - Search - Members - Calendar
Full Version: Could Not Open Default Font 'fixed'
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Dobby
I've been playing around with XFCE and it's really sweet. Initially I installed it and the packages from Chero's contrib and it was working fine. Then I grabbed all files from the offical xfce feed and installed them all. Now I get this error:

CODE
# startxfce4
Loading /etc/sysconfig/keyboard/kernal.map

Fatal server error:
could not open default font 'fixed'
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
    after 0 requests (0 known processed) with 0 events remaining.
#


I've also since installed onto the HDD as I ran out of space.

BTW is it possible to easily uninstall a load of packages (for example all the xfce packages)? So I can try again and just install a few.

I'm guesing I need some font package but I can't seem to find the right one.
InSearchOf
yes... package manager... uncheck all the packages you want gone... and run it... (click gear)

are you running beta3 or 4?

Late
Dobby
beta3. Ah thanks, just realised I can still use matchbox so went into that and removed them all with the package manager.

BTW I'm confused. I thought XFCE and ROX were both WMs. What is ROX then?
InSearchOf
Rox is a WM, XFCE is a WM... Rox has a pinboard that it uses... in conjunction with its panel menu... but when we launch Rox we only use the pinboard...

Just like the default setup... Openbox(I think) is the panel menu and matchbox is the desktop... and beta4 FBpanel(FluxBox I believe) is the panel menu... and matchbox the desktop...

Late
Chero
QUOTE(Dobby @ Aug 11 2006, 10:41 AM)
I've been playing around with XFCE and it's really sweet. Initially I installed it and the packages from Chero's contrib and it was working fine. Then I grabbed all files from the offical xfce feed and installed them all. Now I get this error:

CODE
# startxfce4
Loading /etc/sysconfig/keyboard/kernal.map

Fatal server error:
could not open default font 'fixed'
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
    after 0 requests (0 known processed) with 0 events remaining.
#


I've also since installed onto the HDD as I ran out of space.

BTW is it possible to easily uninstall a load of packages (for example all the xfce packages)? So I can try again and just install a few.

I'm guesing I need some font package but I can't seem to find the right one.
*


don't install "xlibs" from my feed, that causes the problem

Could someone running beta3 (or 4) test the xfce package over here : http://users.telenet.be/zaurususer/ipkgs/e...fce4-4.4-beta2/

Chero.
Dobby
Ah thanks Chero biggrin.gif

Sure I'll give it go...
InSearchOf
QUOTE
Could someone running beta3 (or 4) test the xfce package over here : http://users.telenet.be/zaurususer/ipkgs/e...fce4-4.4-beta2

I will when I get home from work..

Chero, why did you get rid of the orignal XFCE packages?

Late
Dobby
Do I need any other packages (other than libxml2 and libiconv which are still installed).

Will simply uninstalling xlibs solve the problem or is it more serious than that?
Dobby
uninstalling xlibs did not solve the problem so I reflashed and installed the new beta of XFCE. All I can say is...

WOW!!!!

Looks fantastic. Seems to perform reasonably well too. Is there anything in particular you want me to test?

Should probably start another thread (unless there is one already!)
Chero
QUOTE(InSearchOf @ Aug 11 2006, 01:31 PM)
QUOTE
Could someone running beta3 (or 4) test the xfce package over here : http://users.telenet.be/zaurususer/ipkgs/e...fce4-4.4-beta2

I will when I get home from work..

Chero, why did you get rid of the orignal XFCE packages?

Late
*



I didn't, they are just not online right now, I needed space for something else.

Just informing :
- The original panel plugins are not compatible with this beta.
- The ones that are still online are (parent dir).
- I received updated code for most plugins, so they will likely follow soon.
- Scoutme tested this on a c860 running beta1 but no go.

I'm working on the new thunar(beta2) right now, but it requires some additional perl-modules. Thunar beta1 is still online (parent dir), it requires libexo.

Have fun,
Chero.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.