Help - Search - Members - Calendar
Full Version: Beta4 - Dead C760
OESF Portables Forum > Model Specific Forums > Sharp Zaurus > Zaurus - pdaXrom
I tried to install beta4 on my C760. During the install, I got an error message saying it coudnlt write anymore on the device after the 2nd reboot. The install them attempted to reboot but nothing happened. I turned the C760 off by removing battery and power supply but now I can restart it neither with OK + Power or M + D + Power.

Any suggestions?
Try this:
take out the battery and leave it out for a while
pred D+M (while still no battery
while still pressing D+M plug in the power chord

This worked for me in a similar situation.
I tried that but still nothing. When I plug in the power supply, I dont even get the chargin light to go on!
Try Fn + D + M
I had the same problem (no D+M, no charging light, no response at all). I was able to solve the problem using the low level updater method (C+D) as described by Sash in the U-BOOT/Emergency system installation and upgrade instructions. Afterwards I was able to get the D+M menu, and even succesfully installed beta4 on a C760.
Hi Sash, Hi others,

I tried to flash u-boot and Beta 4 ... but I have problems with my CF (1GB / 96 MB) or SD (1GB / 512MB / 256MB) Cards ... I format them with FAT16 (with or without partiontable) but flashing gives me only blinking yellow and green leds :-(

NANDFlash erase and restore/backup is working well ... read many posts in forum but could not get any solution :-(

Any solutions?

Try... it:
1- unplug recharger
2- remove batt...
3- Hold D+M
4- replug recharger
Fn + D + M worked.

I was able to install beta4 by following the below instructions:

First installation - new bootloader

1) Good idea make NAND backup before
2) Format CF or SD card (MMC unworking for me) with FAT16
3) Extract bootloader and emergency files to card. There must be, u-boot.bin, emergenc.img
4) Extract rootfs and kernel files to this or another CF or SD card, there must be: rootfs.img kernel.img
5) Run diagnostic menu (D+M) and run NAND Flash Erase from Extra Menu.
6) Turn OFF your zaurus. Unplug power adapter, eject battery.
7) Insert SD or CF card with extarcted files (if you insert both CF and SD, updating fails)
8) Press and hold "C" and "D" keys and plug power adapter (battery must be ejected!).
9) Green LED must light on for ~20 sec.
10) If both LEDs flashing, that mean bad CF or SD, or non FAT16.
11) When Green LED off, unplug power adaptor.

Bootup emergency system
1) Insert SD or CF card with pdaXrom
2) Press and hold OK button and plug power cable
3) Wait for 10 sec and leave OK button
4) Screen on and emergency system will booting
5) After booting, it will detect SD or CF card and run script
7) After flashing, it will reboot and pdaXrom will booting - time for battery insert:)

The system runs fine now but if I turn off my Zaurus I cannot get it to turn back on. I have reboot it (by removing the battery and power)
Hi patzoul,

Yes I know these instructions ... but I think I have problems with CF SD card format.

My problem is that making NAND backup / restore is working with 1 GB card, but flashing upgrade with it it doea not work ... giving me only blinking yellow/green leds :-(

I verified files and zip with md5 ... ok

Did you use FAT16 with (partition id 6 for FAT16 with 2 FATs default) or without partition (huge floppy device id) ... using main device like /dev/sda or /dev/sda1

Flashing older ROM work fine for me, last test with Beta2 but no new u-boot ... flashing with pressing Ok while switching PowerOn

For flashing the u-boot or pdaxrom ... in which position is your battery switch ... normal operation (on) or reset (off)?

I tried different thing , but nothing is working ... only NAND backup / restore :-(

The first time I tried with a 1GB SD card (not partitioned) but had problems although I'm hoping unrelated. The 2nd time I tried with a 128MB SD card (not partitioned) and removed the CF card.

I'm aiming to switch to the 1GB SD card once my beta4 install seems to be working fine.
Hi patzoul,

Bad news for me ... my power plug in Z has some contacting problems ... I have to return my c860 for repair or open it by myself *thinkingaboutit*

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.