Help - Search - Members - Calendar
Full Version: Solution For Zoom In Other Wm's Than Matchbox
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
MONVMENTVM
Hello,

After installing icewm on beta3 (C3100) I played around with the brightness and zoom buttons (fn+1/2/3/4). I found a quick solution which didn't work as expected:
I edited the "keys" file of icewm with an editor (or you can do it with iceked too) which looked like that:

QUOTE
key "Ctrl+1" xrandr -s 0
key "Ctrl+2" xrandr -s 1
key "Ctrl+3" setfl -
key "Ctrl+4" setfl +


As you can see I have to set everything with ctrl instead of fn. So this is the compromise we have to take for now which can surely be solved later easily.

Anyway here was the problem I had first: setting the brightness works perfectly but zooming in and out does not properly in other WMs than matchbox.
Here someone described the problem with kde, which is basically the same which I had with icewm: http://www.oesf.org/forums/index.php?act=S...ndpost&p=112298

So the Problem is that xrandr wants to set the screen to 480x640 or 240x320, which matchbox understands but other WMs not. As it is landscape they want 640x480 or 320x240.
So xrandr -s 0 sets the screen to portrait mode (480x640) but other WMs show it in landscape. That means that if you have the taskbar on the down side of the screen it will disappear as it is about 640 pixels down but screen only has 480 in height which it can show. And the windows will be only 480 pixels broad where you have 640 pixels to view.

So I took a look at the options of xrandr and played around with them.
For example "-x" mirrors the screen in x-axis and "-y" in y-axis. If you use both with the previous xrandr command the screen will be exactly upside down.... but with one big difference: It is not portrait mode anymore!
OK but what should we do with the screen upside down? A simple answer: inverting it!
xrandr has another option for orientation which is "-o" and some useable arguments, like "inverted" wink.gif.
So for invertating the screen just use "-o inverted".

here are the full commands:
xrandr -s 0 -x -y -o inverted (for zooming out: 640x480)
xrandr -s 1 -x -y -o inverted (for zooming in: 320x240)

Just add them to a shortcut now and it is ready.

The next step is to use the fn-key instead of ctrl, but I am short of time now. If someone finds a quick answer, please tell me. (btw. setting "-kb" into the defaultserverargs in the startx script doesnt work in icewm)


Stay Well

MONVMENTVM
desertrat
QUOTE(MONVMENTVM @ Aug 12 2006, 01:27 PM)
(btw. setting "-kb" into the defaultserverargs in the startx script doesnt work in icewm)

How do you mean it doesn't work? I have
CODE
defaultserverargs=" -screen 480x640@270 -kb"
in my startx script and it works fine:

http://www.oesf.org/forums/index.php?showt...ndpost&p=129622

-- cheers
MONVMENTVM
for me in beta3 with icewm it doesn't work.

I had this before: defaultserverargs=" -nolisten tcp -kb -screen 480x640@270"
but now I have set it to what you have but still it doesn't work with the fn button.

Could you maybe give me your startx script to look at it?

Btw. I assume that setting the brightness with fn+3/4 works without any problems... but does zooming out (fn+1) and zooming in (fn+2) work as it does in matchbox? Because I think that there will be the problem that I described up above (that it is able to zoom but icewm thinking that 240x320/480x640 means 240/480 pixels broad and 320/640 pixels high. But it should be 320/640 pixels broad and 240/480 high! matchbox seems to understand this but other WMs not. They want for a normal screen a normal resolution of 640x480 not 480x640, but xrandr is not able to set 640x480. But as I also described the solution is to mirror the screen in both axis and then inverting the screen with the options "... -x -y -o inverted" for xrandr).

Hope that people can understand my thoughts wink.gif

Stay well
desertrat
QUOTE(MONVMENTVM @ Aug 13 2006, 11:03 PM)
for me in beta3 with icewm it doesn't work.

OK, I see what you mean ...

QUOTE
Btw. I assume that setting the brightness with fn+3/4 works without any problems... but does zooming out (fn+1) and zooming in (fn+2) work as it does in matchbox?

I don't think those hotkeys are set by default in icewm. Also so far I haven't managed to get icewm to recognise modifier keys other than the usual Shift, Ctrl & Alt (ie no Fn). So for brightness I have them mapped to Ctrl+Alt+n and Ctrl+Alt+m. As for zooming I don't use it at all so never bothered with it smile.gif

-- cheers
MONVMENTVM
OK but I think that it shouldn't be such a big problem to get fn to work. I will look at it when I have some more time.

Anyway zooming in and out is very useful for playing games or watching movies that are running at 320x240.
In matchbox the command would be:
QUOTE
xrandr -s 1 (or xrandr -s 240x320)


In other window managers this will give you a 240 pixel wide and 320 pixel high screen, instead of 320 pixels wide and 240 pixels high.
So you need a:
QUOTE
xrandr -s 1 -x -y -o inverted


I don't know why everything on the zaurus is set to 480x640, because it is not correct. It should be 640x480 in landscape. Maybe it is because of matchbox beeing a pda-window manager and most pdas beeing in portrait mode, where a resolution of 480x640 is correct. So I think that they set for the clamshell zaurii also portrait as default mode as beeing easier for matchbox and then simply turning the screen to landscape when needed.
But I assume that most of the people use landscape mode most of the time on the clamshell models.

Anyway the problem is solved now wink.gif

Stay well
adf
QUOTE(MONVMENTVM @ Aug 14 2006, 09:37 AM)
OK but I think that it shouldn't be such a big problem to get fn to work. I will look at it when I have some more time.

Anyway zooming in and out is very useful for playing games or watching movies that are running at 320x240.
In matchbox the command would be:
QUOTE
xrandr -s 1 (or xrandr -s 240x320)


In other window managers this will give you a 240 pixel wide and 320 pixel high screen, instead of 320 pixels wide and 240 pixels high.
So you need a:
QUOTE
xrandr -s 1 -x -y -o inverted


I don't know why everything on the zaurus is set to 480x640, because it is not correct. It should be 640x480 in landscape. Maybe it is because of matchbox beeing a pda-window manager and most pdas beeing in portrait mode, where a resolution of 480x640 is correct. So I think that they set for the clamshell zaurii also portrait as default mode as beeing easier for matchbox and then simply turning the screen to landscape when needed.
But I assume that most of the people use landscape mode most of the time on the clamshell models.

Anyway the problem is solved now wink.gif

Stay well
*


no such lock with default + rox. any ideas?
MONVMENTVM
What exactly do you mean?
adf
I added a rox pinboard to the default destop. no xoom with the buttons or xrandr -s 1.
tried xrandr -s 1 -x -y -o inveeted..no change tried specifying the res after or instead of the -x and -y. sill no chamne. if icewm is working...then maybe rox isn't the problem?

edit: the solution is right on loji's page. It is a simple matter of editing startx
MONVMENTVM
Ahh you mean with matchbox? Yes the solution solution for beta3 ist on loji's page.

This guide is for people using other window managers than matchbox (like KDE,xfce, icewm, fluxbox...)
adf
QUOTE(MONVMENTVM @ Sep 6 2006, 09:16 AM)
Ahh you mean with matchbox? Yes the solution solution for beta3 ist on loji's page.

This guide is for people using other window managers than matchbox (like KDE,xfce, icewm, fluxbox...)
*

got confused about what exactly was mananging my windows with Rox + default. I'm better now smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.