Help - Search - Members - Calendar
Full Version: Bitbake 1.4.4 Required? - Solved
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Open Embedded
ant
Ok, that's my first try:

[arklinux@dhcppc0 build]$ bitbake nano
NOTE: Using cache in '/home/arklinux/stuff/build/tmp/cache'
NOTE: Parsing finished. 0 cached, 2605 parsed, 35 skipped, 0 masked.
ERROR: Openembedded's config sanity checker detected a potential misconfiguration.
Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
Bitbake version 1.4.4 is required and version 1.4.3 was found
[arklinux@dhcppc0 build]$

Should I ask for an updated package? Thought the equired release was 1.4.2...
lardman
hrw tells me that bitbake 1.4.4 is required for the oz354x branch. I see it's in the same subversion repository as 1.4.2, so you should be able to grab it with svn.


Si
Hrw
BitBake 1.4.4 and 1.6.0 was released few days ago. Both versions can be used with .oz354x branch.

1.4.4 fixed some problems and 1.6.0 has some new features (faster parser for example).

I use 1.6-svn which now is 1.6.1 versioned.
fooman
The instructions for getting the latest version of bitbake on the OpenEmbedded wiki have changed. They now say:

svn co svn://svn.berlios.de/bitbake/tags/`svn ls svn://svn.berlios.de/bitbake/tags |tail -n 1` bitbake

They used to include the specific version number, so bitbake is definitely going through frequent revision.
ant
QUOTE(fooman @ Aug 18 2006, 04:32 PM)
The instructions for getting the latest version of bitbake on the OpenEmbedded wiki have changed.  They now say:

svn co svn://svn.berlios.de/bitbake/tags/`svn ls svn://svn.berlios.de/bitbake/tags |tail -n 1` bitbake

They used to include the specific version number, so bitbake is definitely going through frequent revision.
*


Doing this I could not upgrade bitbake...it just thinks my 1.4.3 is the latest...
Perhaps because I "installed" it with apt-get...and now have /usr/bitbake..

I'll have to wait the arklinux bitbake 1.6 package...the mantainer already knows about this issues(he's actually using oe building for some HP).
Greg2
QUOTE(ant @ Aug 19 2006, 05:07 AM)
Doing this I could not upgrade bitbake...it just thinks my 1.4.3 is the latest...
Perhaps because I "installed" it with apt-get...and now have /usr/bitbake..

You could 'remove' the old bitbake version with apt-get and use svn to install the required version, then set your $PATH accordingly.
ant
QUOTE(Greg2 @ Aug 19 2006, 04:29 PM)
QUOTE(ant @ Aug 19 2006, 05:07 AM)
Doing this I could not upgrade bitbake...it just thinks my 1.4.3 is the latest...
Perhaps because I "installed" it with apt-get...and now have /usr/bitbake..

You could 'remove' the old bitbake version with apt-get and use svn to install the required version, then set your $PATH accordingly.
*



Immediately done. THX.

But ...what is supposed layout?

/stuff/bitbake

TIA

ant

EDIT:
I just couldn't understand the world "SIBLING" ... now I know it means akindof "brother" ... thus /stuff/bitbake
ant
Happy end !

[arklinux@dhcppc0 build]$ bitbake --version
BitBake Build Tool Core version 1.6.0, bitbake version 1.6.0
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.