Help - Search - Members - Calendar
Full Version: 860 And Libsdl
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Cxx0 General discussions
mock1010
I can't seem to get any version of libsdl to work with my zaurus 860.

I've tried:
libsdl_1.2.5-slzaurus20031121_arm.ipk
libSDL_1.2.6cvs-1_arm.ipk
libsdl_1.2.5-slzaurus20031201_arm.ipk
zaurus-libsdl_1.2.5_arm.ipk
libsdl_1.2.5_arm.ipk
libSDL_1.2.5cvs-1_arm.ipk
libsdl_1.2.5-slzaurus20030704_arm.ipk
libSDL_1.2.6-zports_c7x0-1_arm.ipk
libSDL_1.2.6-zports-5_arm.ipk
libsdl_1.2.5-slzaurus20041025-j_arm.ipk
libsdl_1.2.5_slzaurus20050410_arm.ipk


Though some only affect half the screen, ALL of them display nothing but a black screen.
I've tried rebooting after each install, reflashing with the base 860 rom, installing cacko rom, but all have the same effect: a black screen (except for Crimson Fields, which simply crashes).


Is there something I'm missing here?
stupkid
QUOTE(mock1010 @ Aug 22 2006, 12:01 AM)
Though some only affect half the screen, ALL of them display nothing but a black screen.
*

I'm running Cacko 1.23 with libsdl_1.2.5-slzaurus20031201_arm.ipk installed and don't really have any problems. snes9x runs very well as does znester, scummvm, and exult, and openTTD. ScummVM has some funkiness when you first launch it with it not repainting, but that is not much of an issue.

Are you installing from the network using the installation app (best way to use the feed IMHO) or downloading packages and installing them individually?
mock1010
I'm downloading individually since I don't have network connectivity to the zaurus.

The thing is, it used to work once upon a time, although the viewport to the game was always too small and it ran pretty slow. I left it alone for awhile, then tried upgrading to cacko, and now even the old libsdl packages don't work anymore, even when I do a NAND restore.

The games do work, because I get sound and I can press buttons to start the game. It's just that the screen doesn't display anything.
stupkid
QUOTE(mock1010 @ Aug 22 2006, 10:06 AM)
The thing is, it used to work once upon a time, although the viewport to the game was always too small and it ran pretty slow.  I left it alone for awhile, then tried upgrading to cacko, and now even the old libsdl packages don't work anymore, even when I do a NAND restore.
*
The screen being small is because you should run most games in QVGA mode. That is the "Display with Magnified screen" option on the icon when you click and hold.

Sounds like you might have a hardware issue if you have done a NAND restore back to working image and it no longer works.

On Cacko 1.23, if you install these packages in this order:

http://www.bryandeluca.com/cacko/feed/eon-...c_1.0-1_arm.ipk
http://www.bryandeluca.com/cacko/feed/eon-...l_1.0-1_arm.ipk
http://www.bryandeluca.com/cacko/feed/eonc...g_1.3-1_arm.ipk
http://www.bryandeluca.com/cacko/feed/bust...o_1.2-1_arm.ipk

and run Bust'em does it work?
mock1010
Yeah, that works perfectly!

Unfortunately snes9x can't find libSDL-1.2.so.0 now sad.gif

Update:

I downloaded libsdl_1.2.5-slzaurus20041025-j_arm.ipk and tried running snes9x again (both libsdl and snes9x from the bryandeluca.com/cacko/feed dir), and it spits out some diagnostics, tries to display (screen goes white), then comes back to the console and displays "Display size = 480x640" a second time and exits.

Is there some kind of debug mode available so I can see what is going wrong?


QUOTE
$ snes9x Super-Mario-World.smc.gz
Display size = 480x640
Rate: 22050, Buffer size: 4096, 16-bit: yes, Stereo: yes, Encoded: no
Display size = 480x640
keyhelper_SDL.xml loaded
detected machine is 'Sharp SL-C860'
QT_GetRotation: Read spec from '/tmp/qtembedded-zaurus/QtEmbedded-0.spec'
spec is 'Transformed:Rot270:Vga:0'
Rot=3, Qvga=0
QT_SetVideoMode: SL-C700 Style is Input style
Your Kernel is Special Kernel
FBVideoMode: 640x480
Direct paint mode
QT_SetVideoMode: argSize=480x640
QT_SetVideoMode: qteSize=640x480
QT_SetVideoMode: fbSize=640x480
QT_SetVideoMode: qteRotation=0
QT_SetVideoMode: userRotation=-1
QT_SetVideoMode: sdlRotation=1
QT_SetVideoMode: qteKeyRotation=0
QT_SetVideoMode: sdlKeyRotation=1
Display size = 480x640
$
stupkid
QUOTE(mock1010 @ Aug 22 2006, 11:39 PM)
Yeah, that works perfectly!
*
Cool! Your hardware is fine then. Eon games libsdl is in a different directory and is only used by the Eon games.
QUOTE(mock1010 @ Aug 22 2006, 11:39 PM)
Unfortunately snes9x can't find libSDL-1.2.so.0 now sad.gif
*
That's expected. Sounds like you have the correct libsdl installed now though. Now install ZEmufe:

http://www.bryandeluca.com/cacko/feed/zemu...1-3ex-3_arm.ipk

Launch Zemufe and use the file browser in Zemufe to browse to your roms. Give them a click and you should be good to go.
mock1010
Ok, I downloaded zemufe and installed it.
I start it up, select "Super-Mario-World.smc", then it displays "Please Wait" sideways, then it displays "Please Wait" rightside up, then it goes back to the file browser.


If I try to start snes9x from the console I get:

snes9x: error while loading shared libraries: libSDL-1.2.so.0: cannot load shared object file: No such file or directory


When I look through the filesystem, it turns out that eon-sdl installed the libraries into /home/QtPalmtop/lib/eongames/

So I tried creating a symlink from /home/QtPalmtop/lib, but then I get this error:

Could not initialize SDL(SDL not built with video support)
snes9x: error while loading shared libraries: snes9x: undefined symbol: SDL_FreeSurface
stupkid
QUOTE(mock1010 @ Aug 23 2006, 01:53 PM)
When I look through the filesystem, it turns out that eon-sdl installed the libraries into /home/QtPalmtop/lib/eongames/

So I tried creating a symlink from /home/QtPalmtop/lib, but then I get this error:

Could not initialize SDL(SDL not built with video support)
snes9x: error while loading shared libraries: snes9x: undefined symbol: SDL_FreeSurface
*

Right. Like I said above the Eon libsdl is only good for the eon games. I thought that you had installed the libsdl_1.2.5-slzaurus20031201_arm.ipk from the feed. So, delete that link you created to the Eon libsdl. Remove any other packages of libsdl (other than the eon-libsdl). Then install these packages:

http://www.bryandeluca.com/cacko/feed/libs...0031201_arm.ipk
http://www.bryandeluca.com/cacko/feed/libS...ports-1_arm.ipk

That should be all you are missing at this point.
mock1010
The links were wrong, but I managed to find copies elsewhere.

It works great now! Thanks alot!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.