Help - Search - Members - Calendar
Full Version: Building With Gcc4.1
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Open Embedded
ant
Hi,
here we are again with nano compilation (after a sunny weekend!)...

What about the issue with localedef? GCC4 ?

NOTE: package glibc-2.3.5+cvs20050627-r3: task do_package: started
NOTE: preparing tree for binary locale generation
NOTE: generating locale es_NI (UTF-8)
NOTE: Task failed: localedef returned an error.
NOTE: package glibc-2.3.5+cvs20050627-r3: task do_package: failed
ERROR: TaskFailed event exception, aborting
NOTE: package glibc-2.3.5+cvs20050627: failed
ERROR: Build of nano failed
[arklinux@dhcppc0 build]$

I found this post (similar problem) : http://www.handhelds.org/hypermail/jhe/0/0085.html

and finally this: http://bugs.openembedded.org/show_bug.cgi?id=729

The issue appears SOLVED / FIXED by Koen.

I've tried with ENABLE_BINARY_LOCALE_GENERATION = "0" in local.conf but the build breaks at the same point...

Suggestions?

TIA

ant
Hrw
you need gcc3 on host
ant
QUOTE(Hrw @ Aug 22 2006, 12:47 PM)
you need gcc3 on host
*


Thx Hrw,
I'm a bit confused...I was reading here

http://www.handhelds.org/hypermail/oe/70/7014.html

and now I have only this setting in my local.conf:
ASSUME_PROVIDED += "qemu-native"


I was under the impression I could keep GCC4.1...

ant
ant
Hi guys,

just to let you know with OpenSuse 10.1 the glibc finally did compile with GCC4.1.
I've built nano, bc, bzip2, gzip and today will start something heavier.

I just put > ASSUME_PROVIDED += "qemu-native" < in the local.conf

Work in progress...

Updates:
coreutils-native-5.1.3.bb refused to compile under GCC4.1: I installed 5.30 from .dev branch (and recompiled coreutils-5.30). Both compiled w/out errors.

intltool-native refused to compile requiring XML::Parser (already compiled). I solved compiling "binutils" before retrying, but probably the real trick was installing "expat-compat", the old expat1 (now opensuse ships expat2).

At the moment the build breaks because of missing "libgsm". Doh!
ant
OK, oz354x gpe-image successfully built with the GCC4.1 toolchain on host.

Now let me test the images and some packages...

UPDATE:
the images are working! At least gpe-image for SL-C860.

I see the size of the files is a bit different:

initrd.bin is 19,054,608 bytes (was 21,479,440 bytes)
zImage.bin 1,194,524 bytes (was 1,181,648 bytes)

probably newer kernel and different version in the snapshot I have...


Ant
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.