Help - Search - Members - Calendar
Full Version: Bluetooth To Xp
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
andrewwoods
I have a bluetooth CF card which I can use to link to my Motorola phone and connect to the web via Vodafone.

I now want to connect to my office desktop PC, which is running XP. I have bought a USB bluetooth card for the desktop and installed it.

I cannot get a link between the Zaurus and the PC. I have tried initiating a link at the PC end, but it comes up asking for a passcode and there is no equivalent prompt on the Z, so no connection.

I have tried using PAND on the Z, but it just returns, with no reaction on the PC, and with no errors etc on the Z.

Each machine can see the other when I scan, but I cannot get them to talk.

Has anybody got anything like this working? Any ideas?

Kit in use:
Z: Beta3, 860, Anycom Blue-CF LSE-139
PC: Dell optiplex, XP, Mikomi BT USB

Thank you
Andrew
Da_Blitz
have a look in /etc/bluetooth/pass for the pass to use

for the bluetooth daemon to use that text file as a password file you may have to edit the hcid.conf file and change "security *" to "security auto"

if running in an X envirement add dbus_pin_helper to the options section and start ethier bluepin or bluez-pin, this will pop up a window asking for the passphrase when needed however you have to have the security setting on "user" rather than auto
andrewwoods
Thanks

I have made some progress.

I have found the --nodetach option to PAND which is running it in the foreground and therefore showing my error message.

I am getting this error:

Connect to 00:0E:...:76 failed. Protocol error(71).


I can start pand as the master (GN) and connect to it from XP, but not the other way round.

Any ideas?

Thank you
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.