Help - Search - Members - Calendar
Full Version: Xfce Panel Problems
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
zi99y
Hi folks, I have been beavering away trying to get XFCE working just right on my C3200, but have been having major troubles from the outset.

It all started after installing using Chero's guide on his site (very nice, thank you chero), started the gui and all looked fine until I noticed the lack of the xfce panel - the blank task bar at the top was the only thing on the screen. Not a very nice greeting!

I then removed all xfce packages and reinstalled just the base xfce package but this time to the root ( / ) instead of my internal disk. This time the panel appeared and all was good.... until I went ahead and installed chero's recommended packages - nothing fancy - and next time I started X the panel was gone again.

At this point, running xfce4-panel from the terminal gave errors about missing libxfcegui4.so.4 - so I installed the libxfcegui4 package and then it complained of libxfce4util - which I duly installed. Next error was something about icons so I installed xfce4-icon-theme which then allowed me to start the panel.

Now I have a panel, it seems not to be the original one I had, as I have no way of adding the xfce menu icon, and the add item menu just looks totally different. Also in the xfce panel settings page, none of the options have any effect!! So it looks like this panel is disconnected from the usual xfce one.

Also I can't add the disk mounter, or the pdaxrom menu etc etc. and it's just not working as it should - any ideas folks?
zi99y
Ok more trouble - next time I quit back to the shell and tried to start xfce again, it flashed up the gui and dumped me back at the prompt complaining about libxfce4mcs, I installed this immediately and it then started up ok - but the panel was gone again!!

It complained about hicolor icons, so I then installed hicolor (starting to notice a pattern forming here... :s), and then the panel would start again when I launched xfce4-panel.

But now, all my changes had been destroyed - the fonts had gone big etc. and the taskbar at the top wouldn't work at all - just stays blank - and most of the xfce settings screens have dissappeared..

Ok I've wasted too many hours here, I might try for one last remove & install of xfce.

Any ideas here are welcome - maybe I just f---ed up somewhere along the line ohmy.gif
desertrat
I know Chero wouldn't like me saying this smile.gif, but I've had more than my fair share of disappearing panels in xfce, that's why I use icewm now, it's fast & stable and has not given me any problems so far (have been using it for months now). The only feature I miss from xfce is the multi-clipboard applet.

-- cheers
Darth_Sith
If panel disappear, delete .cache directory and restart xfce.
karlto
Personally I like xfce but yes, the panel is the one major issue. I just don't use it - use fbpanel instead which is nice and simple (I believe I got the idea from Chero...)
zi99y
Well, I gave up on xfce, it looked really nice but decided it was just too unstable. When exiting X11 there were various errors on the screen, and it's noticably more memory hungry.

I tried Enlightenment which was quite nice, if a little insufficient - I don't want to make new shortcuts for all my apps etc. and my nice openbox keyboard mappings all dissappeared, so I have decided to just head back to Openbox - I decided having everything functioning nicely is more important than the eye candy smile.gif

Having said that, I'll be happy to try again if a fix for this arises.
InSearchOf
This is why i still used the older ipks.... i have no problems with dissappearing panels or any of the issues other run into...

Late
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.