Help - Search - Members - Calendar
Full Version: Help! Hosed By Bt!
OESF Portables Forum > Everything Else > Archived Forums > Zaurus General Forums > General Support and Discussion > Security and Networking
Ok, I bought a Dlink DBT-120 bluetooth dongle for my C1000 - Sharp ROM. I figured out to install the 2.4.20 bluez files. I figured out how to get it to talk to the Linksys USBBT100 I bought for my Linux box. I got PAN working and on the internet. I managed to push by OBEX from the Z to desktop once (haven't figured out the other direction). I installed the bluetooth gui tools - would scan but never got the OBEX working. The tools installed the network applet mods. I tried setting up a DUN connection several ways, never worked. So, set up Samba to work over the PAN connection, and had the Z and my desktop logged into each other's shares.

Then, it all came crashing down. The Z locked up. I had to push the button in the battery well. It would only show the first boot screen, then:

mknod: /dev/rfcomm25: Read-only file system
mknod: /dev/rfcomm26: Read-only file system
mknod: /dev/rfcomm27: Read-only file system
mknod: /dev/rfcomm28: Read-only file system
mknod: /dev/rfcomm29: Read-only file system
mknod: /dev/rfcomm30: Read-only file system
mknod: /dev/rfcomm31: Read-only file system
open_sock(): No such file or directory
Can't open serial port: No such file or directory
Can't initialize device: No such file or directory

It flickered a lot, and I assume rfcomms 1-24 scrolled off. Then, it paused, before flickering again and printing:

INIT Id "ln" respawning too fast: disabled for 5 minutes

And it would just pause, then flicker and repeat the last message.

I managed to use the D + B boot to boot into the limited mode. I looked at the inittab, and it was modified 2 hours earlier. There was an inittab.orig. I ran diff on them and found one line difference:

the new file has:
ud:345:respawn:/sbin/getty 9600 tty1
the old file has
ud:345:once:/sbin/getty -l /etc/update/update -n 9600 tty1

I'm not sure if this is caused by the D + B, or might be related to the problem. I'm suspicious of the bluetooth software, as that was all I had changed today and the error messages of rfcomm seem related.

If someone has an idea of what may be borked, I'd like to fix it rather than blowing away all my data.
I have seen this when I mount/suspend/reboot, when I have been using BestCrypt, if someone can point to a solution I will integrate it into Bestcrypt Scripts. I think it locks a filesystem and doesnt allow a proper remount to R/W, just a guess
bam, that sounds like a good possibility. I managed to figure out how to boot the flash storage partitions and get into the /etc directory and take bluetooth out of the rc.d directories. No more bluetooth errors, but now I get:

INIT: version 2.78 booting
mount: Mounting none on /dev/pts failed: No such file or directory
/etc/rc.d/rc.sysinit: /var/run/utmp: No such file or directory
chgrp: /var/run/utmp: No such file or directory
chmod: /var/run/utmp: No such file or directory
INIT Entering runlevel: 5
sdmgr[107]: No such file or directory
sdmgr[106]: No such file or directory

Which may indicate that the init process isn't able to write to create necessary files at boot. I'm not too familiar with the linux init system, but I'll keep poking around.
save yourself the tourble and reflash the device

anything else will just give you a headache
OK, since I have to have the Z for business, I just copied what I could and did a factory reset. It works. Thanks.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.