Help - Search - Members - Calendar
Full Version: Strange Php Parse Errors
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > Linux Applications
tnfiddler
I've installed apache+php, mysql, and phpmyadmin. phpmyadmin works. apache works. So, I started in on my own php pages. It seems that any control structure involving squiggly brackets {} gives a parse error. It seems that everything else I've tried works.

For example:

<?php

for ($index = 0; $index < 5; $index++) {
echo "count";
}

?>

gives a parse error, but when I delete the brackets I get:

countcountcoutcountcount

like I would expect.

I am entering the brackets from the popup keyboard, but they display correctly. Is this some odd Zaurus thing? Is it some characterset thing?
tnfiddler
Ok, I figured it out, with a little help. The {}s on the default keymap of the Z are different from my desktop's brackets. The hex code id 9B and 9D instead of 7B and 7D (if I remember correctly.) Installing the keyhelper stuff from meanie's site and using the Fn-O and Fn-P brackets types the correct brackets.
bolbit
how do you manage to install mysql on the sharp rom ???
I tried the mysql 3.22 and 3.23 (even a v 4 from pdaxrom), but there were errors during installation and mysql don't want to launch ..
I'm using cacko 1.23 on a C1000.
baallrog
a such installation will not kill your memory due to the limited numbers of write ???
tnfiddler
Bolbit: I installed MySQL 3.22.32-2, I can't remember if I had to tweak something to get it to work, try searching the forums. I don't know about Cacko.

Baallrog: Yeah, I'm a little concerned about the flash RAM, apparently one can move the MySQL data directory to a card with symbolic links. You can also start MySQL with a command line option to use a specific data directory. One of those is the next step. This isn't production, and I'm not doing heavy writing/mods, so I'm not too worried.

I am more concerned with the apache htdocs directory, where I am modifying the documents a lot. I tried to symlink it to the SD card, even set permissions and ownership, but it didn't work. Still working on that.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.