Help - Search - Members - Calendar
Full Version: Sparklan Wl672
OESF Forums > General Forums > General Support and Discussion > Security and Networking
yongwun
Just got my C1K, was very happy with it after long using a PocketPC.

I have a Sparklan WL672 and was happily using it with the original Sharp Rom.

Later I flash my C1K to Cacko ... now my SparkLan WL672 does not work any more.

The card is recognize as a Intersil Prims2 with a "!" sign.

I suspect the pcmcia.conf is not correct.

Anyone could provide me with a right setting or a pcmcia.conf that can work with the card ?

Thanks !
Cyberdoc1971
Funny thing, I did the same thing after I outgrew my Toshiba e805 and had the same Wi-Fi card. I use the Cacko 1.23 (full) for my C3100, and I tried to use the WL-672 with no luck. I dont think there is a driver for it on the Zaurus under Cacko. Something I haven't tried yet, is that you may give Driverguide.com a try. Everything there is free, and they have drivers for about everything.
Hrw
show 'cardctl ident' output
yongwun
cardctl ident output as below:

Socket 0:
product info: "Wireless LAN", "11Mbps PC Card", "Version 01.02", ""
manfid: 0x0156, 0x0002
function: 6 (network)


Below is the setting in hostap_cs.conf
card "Intersil PRISM2 Reference Design 11Mb/s WLAN Card"
version "INTERSIL", "HFA384x/IEEE"
manfid 0x0156, 0x0002
bind "hostap_cs"

in my SL5600 (tkRom), the card is working fine without problem.

In the wireless.conf setting look like below:
card "Intersil PRISM2 Reference Design 11Mb/s WLAN Card"
version "INTERSIL", "HFA384x/IEEE"
bind "prism2_cs"


I really hope to get this thing working ..... I do not want to flash back to SharpRom ... ohmy.gif or buy a new CF card ...
Hrw
argh.. 0x0156, 0x0002... Thats ID of reference card which many (too many) manufacturers does not change.

Try this in pcmcia config:
CODE
card "Sparklan WL672"
  version "Wireless LAN", "11Mbps PC Card", "Version 01.02", ""
  bind "hostap_cs"


if you lack hostap_cs but have prism2_cs or orinoco_cs then you can try them of course.
yongwun
Thanks all, I got it working ....... finally!

Following HRW instruction, it works find.

The following setting works as well:

card "Intersil PRISM2 Reference Design 11Mb/s WLAN Card"
manfid 0x0156, 0x0002
bind "hostap_cs

did not play around with unix/linux system too long ..... wink.gif
Hrw
Both methods will work. But 'manfid' one is not always best - especially with 0x0156, 0x0002 cards as some of them can work with hostap_cs OR orinoco_cs (first one preferred) but some works only with orinoco_cs.

Configuring by card version bind just for card which works.
freizugheit
Please refer to the link: http://www.oesf.org/forums/index.php?showt...99&#entry146599

I got it worked lately.
paulo
I can config my Sl-5500 and my SL-3100.

My cf wifi on "cardctl ident"

Socket 0:
product info: "Agere System", "wireless cf card model 1401", "," ""
manfid: 0x0156, 0x0003
function: 6 (network)

Some one can help me.

Regards
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.