Help - Search - Members - Calendar
Full Version: Tcp/ip Over Usb & Samba, Don't Work At Same Time
OESF Forums > General Forums > General Support and Discussion > Security and Networking
Jon_J
I finally got TCP/IP over USB working by following this post:
http://www.oesf.org/forums/index.php?showtopic=18619
It uses Internet Connection Sharing in Windows.
I'm using a LAN card to connect to ADSL
To get this working, I need to do these 2 things which affect Samba.
1. Enable Internet Connection Sharing on my LAN connection.
2. Change the following settings in /etc/hotplug/usbdnet.conf

DHCPS=yes
DHCPC=no
to
DHCPS=no
DHCPC=yes

This allows me to surf over USB on my Zaurus, but "Blocks" Samba
To get Samba working again, I need to:
1. Disable Internet Connection Sharing on my LAN connection.
2. Change above settings in usbdnet.conf back to what they were originally.
3. Disable Windows firewall

This stops me from being able to go online on my Z.
I'll figure out the firewall later, but why do I need to change the other 2 settings
to get Samba working?

Also, I noticed, the IP that I usually used to connect Samba changed from
192.168.129.201
to
192.168.129.1

I have a desktop shortcut on windows that quit working because Samba's IP changes now.

Thanks for reading this,
Jon
Meanie
QUOTE(Jon_J @ Oct 4 2006, 03:21 PM)
I finally got TCP/IP over USB working by following this post:
http://www.oesf.org/forums/index.php?showtopic=18619
It uses Internet Connection Sharing in Windows.
I'm using a LAN card to connect to ADSL
To get this working, I need to do these 2 things which affect Samba.
1. Enable Internet Connection Sharing on my LAN connection.
2. Change the following settings in /etc/hotplug/usbdnet.conf

DHCPS=yes
DHCPC=no
to
DHCPS=no
DHCPC=yes

This allows me to surf over USB on my Zaurus, but "Blocks" Samba
To get Samba working again, I need to:
1. Disable Internet Connection Sharing on my LAN connection.
2. Change above settings in usbdnet.conf back to what they were originally.
3. Disable Windows firewall

This stops me from being able to go online on my Z.
I'll figure out the firewall later, but why do I need to change the other 2 settings
to get Samba working?

Also, I noticed, the IP that I usually used to connect Samba changed from
192.168.129.201
to
192.168.129.1

I have a desktop shortcut on windows that quit working because Samba's IP changes now.

Thanks for reading this,
Jon
*


just add multiple sub networks to smb.conf or don;t restrict by subnet at all and restart samba after you setup usbd and you will have both working.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.