Help - Search - Members - Calendar
Full Version: Kernel Modules / Audio
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
daniel3000
Hello,

the current topic about kernel module comüilatoin mde me think of this:

There is the known bug that when the Z is suspended while XMMS is running, the audio device is blocked until the next reboot.

The audio driver seems to be compiled into the kernel, as no module is loaded for audio.

Couldn't we simply compile a kernel with audio drivers compiled as modules instead of built into the kernel, and unload the modules during suspend and reload them after resume in order to fix that problem?


daniel
pelrun
I think it'd be much simpler to write a suspend.d script to pause xmms and set a flag so that a resume.d script would know to unpause it.

But I'm pretty sure that when I've gotten into that state I've been able to get out of it again by kill -9'ing xmms and esd...
daniel3000
QUOTE(pelrun @ Oct 6 2006, 04:37 PM)
I think it'd be much simpler to write a suspend.d script to pause xmms and set a flag so that a resume.d script would know to unpause it.

But I'm pretty sure that when I've gotten into that state I've been able to get out of it again by kill -9'ing xmms and esd...
*


aha, good to know. WIll try it.
However, do you think pausing XMMS is what's needed?
I thought we get into that state even if XMMS is already paused and just open...
I could be wring though. Will have to try it out.

daniel
pelrun
Xmms has never gotten into a bad state for me whilst paused.
karlto
Also make sure that xmms is using esound and not oss
daniel3000
QUOTE(karlto @ Oct 8 2006, 10:36 PM)
Also make sure that xmms is using esound and not oss
*


oh, I have reconfigured it to use oss because esound didn't work when I tried it the first time. Now, when I retry, esound works fine. Stange.
What's the reason for using esound rather than oss?

Thanks
daniel
karlto
QUOTE(daniel3000 @ Oct 10 2006, 12:13 AM)
QUOTE(karlto @ Oct 8 2006, 10:36 PM)
Also make sure that xmms is using esound and not oss
*


oh, I have reconfigured it to use oss because esound didn't work when I tried it the first time. Now, when I retry, esound works fine. Stange.
What's the reason for using esound rather than oss?

Thanks
daniel
*


OSS uses the mixer device directly (and locks it so other programs can't use it at the same time). Esound is a daemon that allows all programs to share the sound device, so even if XMMS crashes, the sound shouldn't be locked out.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.