Help - Search - Members - Calendar
Full Version: Psx4zaurus Now Supports Cacko! :)
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Sharp ROMs
Pages: 1, 2
zodttd
A new build of psx4zaurus has been made:

For downloads and discussion, please use:
http://www.psx4all.net/

New in build 4:
- Improved performance for games such as Tekken.
- Now includes both a CACKO build and a PDAXROM build.

pdaXrom blits to the screen much faster than Cacko 1.23 with BVDD SDL. And with pdaXrom's overclocking ability it outpaces Cacko. But Cacko is faster clock-for-clock.

Cacko users now have psx4zaurus though! Try it out and let me know how it goes. smile.gif

I'd really appreciate at least a "hello" in the psx4all Zaurus forums. It will give me a feel for whether Cacko users really want this project.

Thanks!
Jon_J
I don't have any games yet, can I just test the interface before I find some games to load?

Where do I find "scph1001.bin BIOS file"?

Thank you,
Jon
desertrat
QUOTE(Jon_J @ Oct 12 2006, 05:56 AM)
I don't have any games yet, can I just test the interface before I find some games to load?

Yes, just remember that the 'x' key is for "action", ie move the pointer to your required option then press 'x'. That had me stumped for a while, I tried the obvious keys - enter, space, ok, then I went back to an older version of psx4zaurus and it still "didn't work", then I systematically tried every key on the keyboard rolleyes.gif


QUOTE
Where do I find "scph1001.bin BIOS file"?

google!
Jon_J
testing the interface, running psx4all, just froze up.
I ran it in the console
removing battery now..
placed scph1001.bin in proper dir, and it still locks up my Z.
Does this have to be installed to an ext2 volume?
I placed the directory of files on my FAT formatted /hdd3, and symlinked psx4all to my /bin directory.
What are the library requirements?
I have these libs installed from Chesho's neogeoturbogrfx-genesis-nes-snes emulator.

libmad_0.15.0b-zports-0_arm.ipk
libSDL_1.2.6-zports-5_arm.ipk
libSDL-mixer_1.2.6-zports-0_arm.ipk
libpng12_1.2.8-0_arm.ipk (actually i have libpng3_1.2.4-1)
libSDL-image_1.2.5cvs-1_arm.ipk

Running it from Qtopia. (I made a desktop icon for it) It locked up this time also.
Running from the console gives no error messages.
Does it need an actual game iso in it to prevent it from locking up?
zodttd
The interface is pretty much a black background / white text menu. The only things that can be done within the interface is set some graphic settings and turn the sound option on or off. smile.gif

The reason it could be locking up for you is that the Cacko build of psx4zaurus was built with a SDL version of 1.2.5. You might need to install libSDL-1.2.5 bvdd from the official Cacko feed to get things working right.

The BIOS is loaded when a game is selected.
Jon_J
I already have libSDL-1.2.5 bvdd installed (libsdl_1.2.5-bvdd-07-2_arm.ipk)
I didn't see it last night, but it IS installed.
When it locks up in the console, it says:
Display size = 480x640

Then a 1/8 inch horizontal band of "snow" (like on a television) appears in the upper third of the screen.
It is now locked up and the touchscreen doesn't respond.
None of the keyboard buttons respond, and the cancel button doesn't respond.
I either have to remove the battery and reboot, or open the battery compartment and click the reset switch, then reboot.

I can try to debug this, but I'm not sure if I want to do a "Fresh" re-flash of Cacko as I have about 6 months of configuring and tweaking on my Cacko Lite setup.
I do have current backups though.
Jon_J
Has anyone been able to use the link zodttd posted in first post, today?
Seems it's been dead all day
zodttd
Ouch, site went down. It should be back up shortly.
I never encountered that error you're having. I've only been able to test the Cacko build on a Zaurus C1000 using Cacko 1.23 Full. It should be compatible though...odd! Let me know if you made any progress getting it to work.
Jon_J
I'm posting here cause I cannot access the above site.
I get a variation of the above "snow" or "noise" when launching various turbo-nes-snes-genesis-neogeo games in that emulator, but it usually does that for a second or two, then the game comes up. The video noise I see in these instances is much wider and is in color.
The video noise I get when trying to launch psx4all is black & white.
Zodttd, can you give a detailed step by step instruction as to how you have installed it onto your C1000?
I mentioned I placed the folder with all it's contents on my FAT /hdd3 and symlinked psx4all_cacko to my /home/QtPalmtop/bin/ folder.
When I run it from the console or from an Icon in Qtopia, I get the lockup.
I tried something else last night also.
I CD'd to /hdd3/Documents/application/psx4all_build4/psx4zaurus/psx4zaurus/
Then I tried to run psx4all_cacko from there, and I get "command not found"
Do I need the pdaxrom files and folder in there?
I was thinking I would reduce the length of the path by just putting /psx4zaurus/ in my Documents folder,
and making a new symlink of psx4all_cacko to ~/bin/
EDIT: I reduced the path to /hdd3/Documents/psx4zaurus/ and made a new symlink.
It still has the same lockup.
I tried to get a picture of the error with my lousy Palm camera, but it was unreadable sad.gif
EDIT2: After reducing the path length, I CD'd to /hdd3/Documents/psx4zaurus/ and tried to launch psx4all_cacko. This time something happened, I didn't get the "command not found" as I did with the longer path, but psx4all_cacko tried to launch, but locked up again with the same video noise as described in my above post.
Jon_J
It Works!!
WOW! something so simple prevented it from working.
I put a checkmark in "Display with magnified screen" in the icon's properties and it launched into the settings screen. smile.gif
So don't launch this from the console, make an icon in Qtopia and launch it with magnified screen. biggrin.gif
----------------------------------------------------------------------------------------------------------------------
MY MODIFIED INSTALL INSTRUCTIONS
On a C3100 in Cacko follow instructions in readme, but with below modifications.
1. Place /psx4zaurus/ folder (with necessory contents) in /hdd3/Documents/
(This allows a short path to executable)
I just modified step one, I forgot to mention that it goes on /hdd3 (updated 10-15-06)
2. Symlink "psx4all_cacko" to /home/QtPalmtop/bin/
3. Create an icon in Qtopia for the symlink.
4. Once icon is created, tap & hold icon and make sure "Display with magnified screen" is checkmarked.
5. Do not run the emulator from the console, unless you know a command to "Display with magnified screen" when launched.
Updated install:
The emulator cannot find the BIOS file if it is on the FAT formatted /hdd3
I placed a copy of scph1001.bin in /home/zaurus
The emulator now runs and opens games with "Load Success"

----------------------------------------------------------------------------------------------------------------------
Cresho
QUOTE(Jon_J @ Oct 12 2006, 09:56 PM)
It Works!!
WOW! something so simple prevented it from working.
I put a checkmark in "Display with magnified screen" in the icon's properties and it launched into the settings screen. smile.gif
So don't launch this from the console, make an icon in Qtopia and launch it with magnified screen. biggrin.gif
----------------------------------------------------------------------------------------------------------------------
MY MODIFIED INSTALL INSTRUCTIONS
On a C3100 in Cacko follow instructions in readme, but with below modifications.
1. Place /psx4zaurus/ folder (with necessory contents) in Documents folder. (This allows a short path to executable)
2. Symlink "psx4all_cacko" to /home/QtPalmtop/bin/
3. Create an icon in Qtopia for the symlink.
4. Once icon is created, tap & hold icon and make sure "Display with magnified screen" is checkmarked.
5. Do not run the emulator from the console, unless you know a command to "Display with magnified screen" when launched.
----------------------------------------------------------------------------------------------------------------------
*



what the fak is a psx?
law
PlayStation, known early in development as the PlayStation EXperimental

http://en.wikipedia.org/wiki/PlayStation

smile.gif
Jon_J
Having probs navagating the menu.
I only find "Load game" > "Load selected game"
Is this the right selection? I don't have a game selected yet. I do have ffvi in the games_psx folder.
Anyway, when I use that selection, it starts in /home/zaurus/
I navagate to /hdd3/ and it drops me to the desktop.
Sometimes it will let me navagate to /hdd3/Documents/psx4zaurus/games_psx/
But it doesn't show any files in there.
I have ffvi.mdf in there, but it doesnt show up.
I renamed it to ffvi.iso and it won't show up.
The only option in THAT folder is two periods (..)
I read in the pdaxrom thread that I should rename scph1001.bin to all caps.
http://www.oesf.org/forums/index.php?showt...ndpost&p=115653
I tried that in my filemanager and in the console, but that file cannot be renamed.
I renamed it in Windows, but it turns to lowercase on my Zaurus.
I'm going to try rebooting and see if this clears up..

EDIT: I read at another board that the emulator only recognizes these extensions.
Z, .ZNX, and .BIN files.
http://www.gp32x.com/board/index.php?showtopic=22737&st=0
I got it to the point where it tries to load my game now.
It gives an error just before droping to the desktop, it's hard to read as it skips off fast.
Error is: Handling HLS BIOS enbios /home/zaurus/scph1001.bin Enab
The error message runs off the screen on both left and right sides

I may have a problem with the actual game file.
Gotta do more research, it may have been converted to the wrong format before it was converted to RAW..
danboid
Jon_J:

Use the cdrdao command I posted earlier. You can use it under Linux and Windows and I know for a fact that it produces working images. Whether or not your game will actually run is another question.

ZodTTD:

The psx4all site is still down unfortunately, these are the big unanswered questions about psx4all_cacko:

1- When ZodTTD made this first cacko build, he didn't know about the 'raw console' you can access under Cacko by pushing the '/' key when it says 'Waiting' on boot up. Running zpsx under the raw console, in QVGA mode, should give identical performance under cacko as compared to running it under pdaX b3 console, if it is possible to do this. Surely it is? It might require the Tetsu kernel.

2- Are USB joypads supported?

Can't wait to try it out myself! blink.gif
Jon_J
danboid, the file is a *.mdf file. I got it off a ng
I used isobuster to try to convert it.
Does cdrdao work with files/images?

I extracted xduplicator.exe into the cdrdao directory as the readme says.
Clicking it brings up windows error dialog, then it needs to close.

Cacko has the Tetsu kernel.

My gravis gamepad is recognized in devices, but it is a gameport type plugged into a gameport to USB switch.
Jon_J
the joypad and gameport adapter setup isn't recognized, just the adapter is.
I do have a newer joystick that is recognized, but it is one of those 20 button things.
Jon_J
ISObuster seems to find no errors in this file.
zodttd
It's been reported previously that MDF files tend to not work. I believe the iso extension should be recognized though.

But the reason you're most likely having trouble running the game is that the BIOS isn't found.

When the BIOS isn't found it tries to load some non existant HLE code for handling the BIOS. tongue.gif

I believe you need to rename scph1001.bin to all lowercase.

If you get the message "Load Success" then the BIOS was run properly. smile.gif

If it doesn't run after that, in this case it's most likely you have a bad game image file.
lardman
I understand there's no source available for this?

If I can provide you with a pair of toolchains, is there any reason you couldn't target OZ+Opie/GPE too?


Si
danboid
lardman

Zodttd has already tried it out under OZ but the blit performance was very poor. All these cxxxx owners eagerly awaiting on SRAM support getting into the 2.6 kernel! Makes you wonder how much quicker this would've got done if Sharp gave 1/2 a $hyte about the Z as a real embedded computing platform rather than as an advert for their screen tech, which is how Sharp often seem to me.
koen
QUOTE(danboid @ Oct 13 2006, 06:17 PM)
lardman

Zodttd has already tried it out under OZ but the blit performance was very poor.
*


So? Where's the package so people who want to work on sram support can have a testcase?
danboid
mplayer is THE test case, but yes I suppose zpsx is a strong contender for best test case #2 wink.gif

No offence ZodTTD, I just personally think more people are interested in smooth video playback than a console emu. As you know nobody has been more interested in zpsx than me smile.gif
Jon_J
zodttd, I renamed scph1001.bin to lowercase earlier.
This message suggests the wrong path for scph1001.bin
This is the message on the screen before it drops to the desktop.

Handling HLS BIOS enbios /home/zaurus/scph1001.bin Enab

I have scph1001.bin here:
/hdd3/Documents/psx4zaurus/
The file browser also starts in /home/zaurus/
I'm going to put a second copy of scph1001.bin in /home/zaurus/ and see if that works.

I found some sort of windows emulator, "ePSXe" and it loads this game and runs the "preview" screen. It shows some of the game playing, but at a very fast pace. The speed is too high. I just tried this to see if my game file was corrupt.
I also got a game called "Legend of Legaia", and it runs the "Preview" on Windows.
"Legend of Legaia", is an ISO from the start and it doesn't run on psx4all.
It does the same thing that the other game, "FFVI" does.
Jon_J
Zodttd,
That was the problem!!
It's running the game now!! smile.gif
I put a copy of scph1001.bin
in /home/zaurus
Jon_J
Trying this game: "Legend of Legaia"
The game opens with a splash screen and there is a flashing horizontal 1/16 inch bar at the bottom of the screen.
This flashing horizontal 1/16 inch bar persists throughout the game.
Game opens the main screen and is Panning a rural village.
This panning occurs very very slowly.
It finally gets to the Hero's hut and opens the hut to a screen to set your char's attributes.
Seems this game is kind of working but is unplayable in this state.
Maybe some video settings tweaking will help this?

Going to try FFVI next... (takes awhile to copy a ¼ to ½ GB game to the microdrive)

Anyone know how to take screenshots within the game?

EDIT: FFVI got to a screen with the framerates showing, (seems like very low numbers, I'm not sure how to read them).
Then it dropped back to the desktop. No title screen.
This file is a renamed *.MDF file.
Jon_J
In the install instructions it says:
Unzip psx4zaurus_b4_3.zip contents to a directory on a storage device for use with the Zaurus.
Does this entire directory and all it's contents need to be symlinked to /home/zaurus/ ?
This directory will not "fit" in internal flash with the games contained within.
The "workaround" method I had to use to get it running was to symlink the psx4all_cacko to /home/QtPalmtop/bin/
and copy the BIOS file "scph1001.bin" to /home/zaurus/

If this is the case, then it could possibably solve all the need to navagate the filesystem to select the game.
Navagating the filesystem with cacko's typmatic rate is somewhat difficult.
If you hold a key down for just a split second too long, it clicks more than one directory in the navagater, then crashes.
The way I have it set up now I have to navaagate from "here to here" (each line representing a seperate click)

/home/zaurus/
/
/hdd3
/Documents
/psx4zaurus
/games_psx

The original zip file's folder setup was 2 more directories deeper.
matthis
I haven't been able to test yet, but thank you very much for the Cacko version!!!
Jon_J
I got the game: "Legend of Legaia" running and have tried different settings under the video options.
Using progressive set to on, eliminates the flashing white horizontal band along the bottom of the screen.
Progressive cannot be enabled unless Interlace is enabled.
I tried 3 different scenerios, with Progressive enabled.

Interlace set to 1 produces thin horizontal bands onscreen during gameplay.
Interlace set to 3 produces medium horizontal bands onscreen during gameplay.
Interlace set to 7 produces large horizontal bands onscreen during gameplay.

Remember, the Progressive setting cannot be enabled without enabling an Interlace setting.
There are only 3 different settings for Interlace. (That's all I could get with the touchy keyboard, making these settings)

The flashing band that Progressive eliminates, is reduced to a thin white line, that is stationary, and does not flash.

Using Progressive, I get 3.89-10.9 FPS.
Using Default settings, I get 3.89-7.56 FPS
So progressive is faster. I took these readings in these two scenerios:
1. Opening screen when camera pans entire village and zooms into our character's hut.
2. Character automatically walking to center of village and talking to a group of other people.
I have the sound turnd off also.

Oh, by the way, I forgot to mention the D-pad is upside down in the menu where you load the game & make settings, down=up, & up=down.
The D-pad is also backwards when controlling your character.
When you walk around in the village, this is what happens.
left=right
up=down
EDIT: I finally got to the cave in the game, where the save point is located and saved my game.
The gamesaves made from within the game are placed in /home/zaurus/
This may be, because I symlinked the ISO to /home/zaurus/ and copied the BIOS file there also.
After doing some more testing, I decided to try to Load my saved game. This worked just like the PC version does.
Last night I downloaded a PC emulator, just to test these games to see if they are corrupt.
Jon_J
Has anyone figured out what is required to run psx4zaurus from the console that appears when qtopia is shut down?
(using '/' at 5,4,3,2,1)
The game I have above plays too slowly, it's barely playable.
I haven't tried the "Fight" sequences yet, but I imagine these will be unrealistically slow also.
I don't want to overclock to play games all the time.
I haven't tried overclocking, but will overclock this game for a short testing period, to see if the framerates go up.
EDIT:
I overclocked to (624/208/104)
The speed went up to 4.87-11.89 FPS, and sometimes peaking at 14.75 FPS with characters standing still.
The dialog boxes that appear when the characters are speaking, scrolled and responded much quicker.
The game is still mostly unplayable, the controls are backwards, the characters break up into interlaced sprites when moving, and it takes too long to travel anywhere in the game.
This game runs at 59FPS on my desktop PC (I have FPS limited to 60.0 FPS in the game configuration, otherwise, it runs too fast).
zodttd
I haven't tested this game on my end, as it's not often requested for.
It might be too slow to play on psx4zaurus currently. If you want to make sure, try psx4zaurus on pdaXrom Beta 3 using the SDL included with psx4zaurus.
pdaXrom Beta 3 runs games about 15-20% faster than Cacko currently.

danboid: I think I have you very confused on things. mPlayer probably benefits from the PXA Framebuffer YUV overlay support. I believe this is already being worked on/completed on OZ. Since I do not use or have a need for YUV color support in psx4zaurus, the only way I could see getting acceleration from PXA FB support is through the use of it's SRAM. I'm not even sure if it will actually help, but it might.

What is true though:
If you use the FBCON (Framebuffer Console) video driver for SDL instead of X11/Qtopia, you will notice around a 20% speed increase. The problem with using fbcon drivers with various SDL's is some don't do the rotation needed, as the Zaurus has a rotated framebuffer (portrait). To use fbcon driver in SDL even under X11/Qtopia run this after changing to the directory where psx4all is located:
env SDL_VIDEODRIVER=fbcon ./psx4all

To change the framebuffer from /dev/fb0 to a different /dev/fbX there is a SDL_FB... environment variable for that as well. Probably not needed though.
Jon_J
QUOTE(zodttd @ Oct 14 2006, 02:18 PM)
I haven't tested this game on my end, as it's not often requested for.
It might be too slow to play on psx4zaurus currently. If you want to make sure, try psx4zaurus on pdaXrom Beta 3 using the SDL included with psx4zaurus.
pdaXrom Beta 3 runs games about 15-20% faster than Cacko currently.
*
Thank you for your reply Zodttd, I'm too much of a linux noob to use pdaXrom at the moment.
A number of people that don't have a full understanding of flashing to pdaXrom have bricked their Z when trying to flash back to a Sharp rom.
I'm going to wait for the cacko version to be improved, or when it can be ran from the "pure console" that has been mentioned.
In other words, where you access the console with / outside qtopia.
(I'll need some install instructions to do that).

I have a question about interlace and progressive.
In my post, 2 posts above, I mentioned that I need to enable progressive to eliminate a white flashing bar at the bottom of the screen, and interlace needs to be enabled to use progressive.
Why do I need to do this to get rid of the flashing bar?

Is there a way to get a screenshot while in a game?
The standard Sharp/Zaurus way doesn't work. (fn+shift+c)

BTW, where is everyone else that uses Sharp/Cacko? This thread has 566 views.
Jon
bolbit
hi all,

I finally found time to test this cacko realease. I use a C1000 and Jon_J install instructions sems not working, i only get a black screen. does anyone runs cacko psx emu with a C1000?

I have done:
copy psx4zaurus folder in /home/Documents
put the bios file in this folder and in /home/zaurus
simlinked psx4zaurus_cacko in /home/QtPalmtop/bin
simlinked game_psx folder to my psx rom folder on the sd card (FAT)
add qtopia shortcut for psx4zaurus (note, i had to chmod +x psx4zaurus_cacko in the /home/Document/psx4zaurus to see it in the app list)

and get
a balck screen, and Z freezed

EDIT : It works. I added "execute with root privileges" on the shortcut, and i have the menu now !!!
I selected an FFVII Z image, the game crasched after i selected NEWGAME (it supposed to play the introduction movie)
Jon_J
If you see "Load Success"
Then everything is working.
If your game doesn't play, it may be incompatable, or one of the games that just won't play in the emulator.
Jon_J
Here's a howto for converting Alcohol 120% *.MDF files to psx4zaurus friendly *.BIN files.
This is for Windows.
I previously tried the suggested "cdrdao" in windows with XDuplicator, but XDuplicator.exe always crashed.
----------------------------------------------------------------------------------------------------
HowTo "convert" an MDF file to a usable format for psx4zaurus, using the latest version of ISOBuster. (ISOBuster 1.9.1)
These MDF files come with a MDS file, which is some kind of control file.
Open the MDS file in ISOBuster. (File -> Open Image File).
The Image file will open with the "folder" below "Track 01" selected.

Select the topmost CD (the folder tree will collapse).
Select the File menu, select "CD"
Following screenshot, do this action:
CD -> Extract CD <Image> -> RAW (*.bin, *.iso)
This will create two files, a *.bin and *.cue
(You can use the *.cue file to burn with CDRWin)
I just delete the *.cue file and use the *.bin file.
Rename the CD.bin file to your game's name.
It is now ready to load into psx4zaurus. smile.gif
-----------------------------------------------------------------------------------------------------
Jon_J
QUOTE(bolbit @ Oct 15 2006, 06:20 AM)
hi all,

I finally found time to test this cacko realease. I use a C1000 and Jon_J install instructions sems not working, i only get a black screen. does anyone runs cacko psx emu with a C1000?

I have done:
copy psx4zaurus folder in /home/Documents
put the bios file in this folder and in /home/zaurus
simlinked psx4zaurus_cacko in /home/QtPalmtop/bin
simlinked game_psx folder to my psx rom folder on the sd card (FAT)
add qtopia shortcut for psx4zaurus (note, i had to chmod +x psx4zaurus_cacko in the /home/Document/psx4zaurus to see it in the app list)

and get
a balck screen, and Z freezed

EDIT : It works. I added "execute with root privileges" on the shortcut, and i have the menu now !!!
I selected an FFVII Z image, the game crasched after i selected NEWGAME (it supposed to play the introduction movie)
*

I didn't symlink the folder, I just symlinked psx4zaurus_cacko to /home/QtPalmtop/bin/ and copied the BIOS file to /home/zaurus/
I didn't need to use the "root privilege" option in the icon.

bolbit, in my instructions on page one, I forgot to mention /Documents is on /hdd3
So I put my folder and files in /hdd3/Documents/ (I've updated those instructions).

Do this, to make it easier to navagate the filesystem in psx4zaurus.
symlink your game.bin to /home/zaurus/
bolbit
Thanks for the advice. I tried an European version of FFVII ( french ). Maybe it is because of that that the game crashed. I read before that psx4zaurus is suppose to run FFVII.
I will try another one.
Jon_J
I read in one of the 3 large threads in pdaXrom forum, that zoddt said there were problems with PAL versions.
Is your French version PAL or NTSC?
danboid
QUOTE(zodttd @ Oct 14 2006, 07:18 PM)
I haven't tested this game on my end, as it's not often requested for.
It might be too slow to play on psx4zaurus currently. If you want to make sure, try psx4zaurus on pdaXrom Beta 3 using the SDL included with psx4zaurus.
pdaXrom Beta 3 runs games about 15-20% faster than Cacko currently.

danboid: I think I have you very confused on things. mPlayer probably benefits from the PXA Framebuffer YUV overlay support. I believe this is already being worked on/completed on OZ. Since I do not use or have a need for YUV color support in psx4zaurus, the only way I could see getting acceleration from PXA FB support is through the use of it's SRAM. I'm not even sure if it will actually help, but it might.

What is true though:
If you use the FBCON (Framebuffer Console) video driver for SDL instead of X11/Qtopia, you will notice around a 20% speed increase. The problem with using fbcon drivers with various SDL's is some don't do the rotation needed, as the Zaurus has a rotated framebuffer (portrait).  To use fbcon driver in SDL even under X11/Qtopia run this after changing to the directory where psx4all is located:
env SDL_VIDEODRIVER=fbcon ./psx4all

To change the framebuffer from /dev/fb0 to a different /dev/fbX there is a SDL_FB... environment variable for that as well. Probably not needed though.
*


Yes you do have me pretty confused Zodttd! sad.gif

Am I right in thinking that

env SDL_VIDEODRIVER=fbcon ./psx4all

is the magic command which makes the current psx4z cacko build work under the / console? Does it run at the same speed as pdaXrom when doing this? I'm not bothered about running it under qtopia at all.

I realise the overlay stuff and colourspace conversion would be of no use to you but this has only been done for 2.6 and cacko runs 2.4, which has bvdd instead. I thought that it the bvdd module that enabled use of the SRAM under 2.4 kernels? Is this not the case? If this is true then Cacko should already be as good as pdaXrom at this.

If its not running the same speed as under pdaX under the / console then I would imagine getting the code for the pdaXb3 sdl lib and then statically linking this into the next psx4zaurus will make the cacko build as fast as the pdaX version.

Anybody know where ZodTTD might find the source for the pdaX b3 SDL version, if its not just vanilla SDL 1.2.9? I think cacko 1.23 comes with SDL 1.2.5, no?
Raul
How can I download this emu? I tried to register on the forum but I didn't get e-mail with registration details.
Jon_J
Raul, just login using the username/pass you used to register.
That's what zodttd said to do.
I haven't got my verification yet either, but can login.
I hope he doesn't mind if I just post the file here.
Someone posted it to the thread in pdaXrom forum.

Jon
Raul
I played a bit of Final Fantasy Tactics.
From Qutopia screen is small, frame rate is between 9 to 25 frames per second (without music) (I overcloced zaurus to maximum).
Still , i'm suprised that game looks very nice and could be playable from console (and on the full screen).
Thanks for the emu, I hope it will get even better smile.gif
Mecit
hi all
first thank you very much for your work zodttd
i have the standard sharp rom, does it suppose to work in it. when i try to run i get the menu. i also load the game (gta 2) i get something like this

Loading game

Load success

and the zaurus freezes and none of the keys work. is there a way to fix this.

thanks
bolbit
In fact FFVI PAL (French) works. First i tried a pocket ISO img without the movies, that's why it crashed. I have tried the full img and it is working good !!.
So PAL img works.
I even tried to use the 7005 bios (or something like that, by renaming it with the one expected by psx4z) and it is working too.
I'm very happy to see this psx emu for the Z. Thanks Zodttd. Time to donate :-)
moku
Havnt succesfully loaded any roms yet, guess i got to use magic iso or some other tool to convert them. But I am really excited. Thank You for all the hard work.
Antikx
QUOTE(bolbit @ Oct 19 2006, 06:09 AM)
In fact FFVI PAL (French) works. First i tried a pocket ISO img without the movies, that's why it crashed. I have tried the full img and it is working good !!.
So PAL img works.
I even tried to use the 7005 bios (or something like that, by renaming it with the one expected by psx4z)  and it is working too.
I'm very happy to see this psx emu for the Z. Thanks Zodttd. Time to donate :-)
*

Cool, how's the speed in FF VI? Any graphical or audio glitches? Are you over clocking?
danboid
I can't get psx4zaurus_cacko to run under Cacko 1.23b on a c3000. First it was complaining about missing libsdl so I copied the included libs into /usr/lib and ran ldconfig. Now it is saying that it can't find (from memory)

libgcc_s.so.1

I've searched my Z for any libgcc*, nothing, and neither does there seem to be any libgcc in the cacko feed. Surely I don't have to install Meanies zgcc image to get this running? I'm wondering why no other cacko users have had this problem (or at least they've not posted about it)?
danboid
I installed Meanies zgcc lite cramfs package psx4all_cacko still says

error whilst loading shared libraries: libgcc_s.so.1

Which is no surprise as zgcc comes with a libgcc.a but no libgcc_s.so.1

I can't imagine that the bigger zgcc is going to be any different in this respect but there should be no need to install zgcc anyway.

Does libgcc_s.so.1 come with cacko for other Zs but not the c3k?
Jon_J
I have Cacko 1.23 Lite and it has these under /usr/lib/
libgcc_s.so.1
libgcc_s.so (which is a link to libgcc_s.so.1)

I zipped it up, if you want to try it.
bolbit
QUOTE(Antikx @ Oct 20 2006, 01:41 PM)
QUOTE(bolbit @ Oct 19 2006, 06:09 AM)
In fact FFVI PAL (French) works. First i tried a pocket ISO img without the movies, that's why it crashed. I have tried the full img and it is working good !!.
So PAL img works.
I even tried to use the 7005 bios (or something like that, by renaming it with the one expected by psx4z)  and it is working too.
I'm very happy to see this psx emu for the Z. Thanks Zodttd. Time to donate :-)
*

Cool, how's the speed in FF VI? Any graphical or audio glitches? Are you over clocking?
*



sorry, it seems that i forgot a "i". i tested ffvii. ffvi runs very well from the snes emulator
danboid
Thanks for that Jon J!

After I installed your lib it was complaining about missing libstdc++.so.6 but I got round that easy enough by going into /hdd2/QtPalmtop/lib and doing a

ln -s libstdc++-libc6.2-2.so.3 libstdc++.so.6

but now it says it is missing

libX11.so.6

Eh? I thought this was supposed to be a cacko build I'm trying to run here? What has X11 got to do with anything? I could try installing X/Qt maybe but, again, there should be no need.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.