Help - Search - Members - Calendar
Full Version: Partition Sd 4gig - Hmmm
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > Cxx0 General discussions
I just got a new 4 gig card YAY!! now I want to partition it, so I have a vfat partition, and an ext2 partition ...

I'm using fdisk as shipped with pdaXrom beta3 - I have replaced the SD driver with the newer tetsu/cresho one (from the newer 3200 series)

I fdisk /dev/mmcda

and create two new partitions. (at cylinders 1600 and 2407)

This should give me two partitions roughly 3 gigs and 1 gig .. or close enough.

then I use the type option to set primary partition 1 to type 6 (fat16) and primary partition 2 to type 83 (linux)

Then I do mkfs.msdos /dev/mmcda1
and a mkfs.ext2 /dev/mmcda2

mkdir /mnt/ext2

a mount -t ext2 /dev/mmcda2 /mnt/ext2 fails with a generic error .. wrong fs, too many mounted file systems ... etc ... Not sure why this is happening. . .

And when I put the SD card into my windows machine, it only reconizes 1 gig. (.99 to be exact) I figured this was because of choosing fat16 and a limitation. so I chose hex option b (fat32) the next time I fdisked the card ... and still the same problem.

I have since re-built the partition info, and formatted in windows to get the full 4gigs in vfat. However -- I don't like that it didn't work ... I followed all the instructions I've found perfectly, and I understand what it is doing and how it's happening ... but I don't see where my error is occuring.

Anyone else have some input that might help me out on this? I would like to install GIMP + extra brushes on the SD card since I don't have enough room for it internally.

Thanks! biggrin.gif
keep it simple, as far as I can tell, lots of things are buggy
it's only creating two partitions ... I was originally going to do 3 and use swap at the end of the drive ... but /dev/mmcda3 wasn't being crated, so I said screw it.

Also is using fdisk going through the SD driver? I suppose it would have to be. . . I could change it back to the pdax_mmc and try that I suppose ... but I find it very strange that i can't get the partitions created correctly . . . I thought maybe I use using outdated tools or something. .

or do you mean to keep my explination simple? I was writing a tutorial as I was working, so I can post each and every keystroke if nessacary. . . I'm driving cross country in a couple days .. so I'm not sure how much time I'll have to play .. but I'll try to track down what's going on. thanks!
I have a 4gig no-name brand. I partitioned it the same way you did and it works except for the 1.1g dos partition doesn't work thru my external card reader. It does work if I use a CF adapter and put it in the CF reader.

The ext2 partition probably doesn't work because of the block size. There was another thread here that stated you could 'mke2fs -b 1024 /dev/mmcda2' and it works, at least for me.
Well I tried to change the bitsize of the ext2 partition ... and it's still giving me the same error .... I tried these same commands on a 1 gig SD card I had prior ot this,and it's working on that card ... so I think that the size is an issue .... the print option of fdisk shows that it's seeing 4 Gigs. however it shows 128704 cylinders while the 1 gig card shows 167680 cylinders ... that's because the size of each is much smaller on the 1 gig than the 4 gig. (12 * 512 as opposed to 64 * 512)

it's driving me a little batty :: I can't figure out where it's having trouble.

I tried switching the order of the partitions .. making the primary 1 the ext2 and the second as vfat ... and now I am able to mount -t ext2 /dev/mmcda /mnt/ext2 fine ... however I get the same error when I try to do mount -t vfat /dev/mmcda2 /mnt/card --- so it seems the end of the card isn't happy mounting ... grrr what causes this?
guess it wont wwork with this card. there are tons of hidden issues.
do you mean issues with the driver ? or with this version of fdisk? Sandisc Ultra cards are common enough I would assume they are supported
Just saying that not all of them work. Some people report great success while others fail.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.