Help - Search - Members - Calendar
Full Version: Usbapplet
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
Meanie
I just wrote a little usb applet which allows you to unmount usb devices such as usb sticks, usb hdds, usb zip, usb cdrom, etc... once they have been mounted by automounter.
I am working on updating it to also do usb networking and other usb devices related things.

This is primarily for Sharp ROM. Cacko already has an unmount for USB disks. However, this one handles 4 concurrent disks (provided my automounter package is installed).
Jon_J
Cool!
Thank you Meanie. smile.gif
It's the little USB icon to the left of the paw-print on my statusbar in pic.
It gives you a little notification of CD-ROM mounted when I plugged in my CD-ROM, I like that. smile.gif
I needed to re-start Qtopia after installation because some of the icons on my statusbar disappeared.
After downloading from forum, rename to qtopia-usbapplet_1.0.0_arm.ipk
..............This forum changes the name to qtopia_usbapplet_1.0.0_arm.ipk
I just tried my 100MB & 750MB Zip drives and they mounted with no problems.
Zip drives DO appear in the Qtopia Files tab.
Still makes me wonder why CD-ROM doesn't, but I use FileLaunch with one pane open in /mnt
I gave up trying different methods to make CD-ROM appear in the Qtopia Files Tab.
Cresho
iLL TRY IT OUT...as soon as i get a host usb
Meanie
QUOTE(Jon_J @ Nov 3 2006, 03:47 PM)
Cool!
Thank you Meanie. smile.gif
It's the little USB icon to the left of the paw-print on my statusbar in pic.
It gives you a little notification of CD-ROM mounted when I plugged in my CD-ROM, I like that. smile.gif
I needed to re-start Qtopia after installation because some of the icons on my statusbar disappeared.
After downloading from forum, rename to qtopia-usbapplet_1.0.0_arm.ipk
..............This forum changes the name to qtopia_usbapplet_1.0.0_arm.ipk
I just tried my 100MB & 750MB Zip drives and they mounted with no problems.
Zip drives DO appear in the Qtopia Files tab.
Still makes me wonder why CD-ROM doesn't, but I use FileLaunch with one pane open in /mnt
I gave up trying different methods to make CD-ROM appear in the Qtopia Files Tab.
*


The newer version that I am still working on will have the USB icon in the tray if the USB host cable is plugged in even if no other devices are attached to it. This way you can check if you have the right cable smile.gif
Also, in addition to unmounting USB devices, I will also add an option to re-mount then, ie after you unmounted a CD-ROM, you can mount it again after changing the disk without pulling the plug and stuffing it back in. I also plan to have it detect some usb ethernet lan cards and do something with them. Not sure what to do with USB mouse and keyboard, maybe just pop up and say that they were plugged in. Maybe add some hooks for usb bluetooth dongles as well.. we will see...
jpmatrix
QUOTE(Jon_J @ Nov 3 2006, 07:47 AM)
It's the little USB icon to the left of the paw-print on my statusbar in pic.
I gave up trying different methods to make CD-ROM appear in the Qtopia Files Tab.
*





Jon_J,
what are all these tray icons you have ? smile.gif
j'm just curious wink.gif
dougeeebear
Great work, Meanie.
I wanted something like this because my card monitor doesn't notify on usb mount/unmount.
I don't have a hub, but it works perfect on my usb host with a usb flash drive attached.
I also don't have automounter installed (guess I don't need it).

Thanks a lot for this.

Regards,
Doug
dougeeebear
I changed the size of the usb-host.png icon from 48x48 to 32x32.
This makes the icon fit better in the tray.
The icon is located in /home/QtPalmtop/pics144/sysinfo

After downloading it, make sure you rename it to "usb-host.png".

You need to reboot after installing the new icon to see the difference.
Jon_J
QUOTE(jpmatrix @ Nov 3 2006, 06:54 AM)
Jon_J,
what are all these tray icons you have ? smile.gif
j'm just curious wink.gif
*
I have Cresho's "noia" theme installed.
From left to right are:
clipboard-applet
netactive-applet
network-applet (connect/disconnect)
screenshot-applet (I'm using "screenshotapplet_1.1.0_arm.ipk" because it has the correct sized icon)
volume-applet
CF/SD card applet (cardmonapplet)
pawprint brings up applet list. (I cannot remember it's correct name)
battery monitor
memory monitor
clock
subapplet

Dougeeebear,
Thank you
I used "Restart Qtopia" instead of a full reboot and the new icon registered itself.

EDIT: opps, it's actually oslinux theme, see Cresho's correction below.
Jon
Cresho
actually, its oslinux but he hasnt modified the icons to make it look "together".

noia looks like this.

Jon_J
Cresho, you're right. It's oslinux. I just installed it and didn't add the icons from the xtra folder except a few.
dougeeebear
QUOTE(Meanie @ Nov 3 2006, 04:39 AM)
The newer version that I am still working on will have the USB icon in the tray if the USB host cable is plugged in even if no other devices are attached to it. This way you can check if you have the right cable smile.gif
Also, in addition to unmounting USB devices, I will also add an option to re-mount then, ie after you unmounted a CD-ROM, you can mount it again after changing the disk without pulling the plug and stuffing it back in. I also plan to have it detect some usb ethernet  lan cards and do something with them. Not sure what to do with USB mouse and keyboard, maybe just pop up and say that they were plugged in. Maybe add some hooks for usb bluetooth dongles as well.. we will see...
*

I think your idea for a pop up notification on insertion/removal of a usb mouse and keyboard would be a nice feature.
MrStaypuft
This is GREAT.

I was just going to jump on the forum and ask about occasionally getting corruption in my FAT32 harddrive (I think it was becuase I was unplugging without unmounting... probably a pretty silly thing to do now I think about it!)

Now I've got an easy way to do it without even opening terminal.

Thanks Meanie.

Puffer
Meanie
I really hate filesystem corruptions. My source file for the applet just got corrupted just when I was about to have it finished. Darn, and no backups sad.gif Have to start again sad.gif
dougeeebear
QUOTE(Meanie @ Nov 5 2006, 09:45 PM)
I really hate filesystem corruptions. My source file for the applet just got corrupted just when I was about to have it finished. Darn, and no backups sad.gif Have to start again sad.gif
*

Man, that's a real bummer.

I'm just curious about something here.
Since I don't have a hub, I only have one drive attached to my usb host at a time.
Therefore I don't really need to have automounter installed.
I use the directory /mnt/usbstorage and the usbapplet recognizes it and notifies me on insertion with no problem.
However when I try to unmount the drive I get a "failed to unmount" error message.
In your updated version, would it be possible to add that directory to the list of recognized directories in order to be able to unmount it?

Thanks for this handy program.

Regards,
Doug
Meanie
QUOTE(dougeeebear @ Nov 6 2006, 11:25 PM)
QUOTE(Meanie @ Nov 5 2006, 09:45 PM)
I really hate filesystem corruptions. My source file for the applet just got corrupted just when I was about to have it finished. Darn, and no backups sad.gif Have to start again sad.gif
*

Man, that's a real bummer.

I'm just curious about something here.
Since I don't have a hub, I only have one drive attached to my usb host at a time.
Therefore I don't really need to have automounter installed.
I use the directory /mnt/usbstorage and the usbapplet recognizes it and notifies me on insertion with no problem.
However when I try to unmount the drive I get a "failed to unmount" error message.
In your updated version, would it be possible to add that directory to the list of recognized directories in order to be able to unmount it?

Thanks for this handy program.

Regards,
Doug
*



I managed to rewrite the applet while everyone was watching the horse race.
Here's the rewritten version. It has some more features, but needs much more testing also...
dougeeebear
QUOTE(Meanie @ Nov 7 2006, 09:21 AM)
I managed to rewrite the applet while everyone was watching the horse race.Here's the rewritten version. It has some more features, but needs much more testing also...
*

Wow! That was fast smile.gif

Here's how it works for me so far:
I get a popup notification on insertion of usb drive using /mnt/usbstorage directory.
Unmount option now works.
After unmount, this item disappears from the list (no option to remount)
Not sure if this is intended behavior.

No popup notification on insertion of usb mouse, but it shows up in the list.
Not sure if this is intended behavior.

Nice work.
Thanks for this update.

Regards,
Doug
John Galt
QUOTE(dougeeebear @ Nov 7 2006, 12:16 PM)
QUOTE(Meanie @ Nov 7 2006, 09:21 AM)
I managed to rewrite the applet while everyone was watching the horse race.Here's the rewritten version. It has some more features, but needs much more testing also...
*

Wow! That was fast smile.gif

Here's how it works for me so far:
I get a popup notification on insertion of usb drive using /mnt/usbstorage directory.
Unmount option now works.
After unmount, this item disappears from the list (no option to remount)
Not sure if this is intended behavior.

No popup notification on insertion of usb mouse, but it shows up in the list.
Not sure if this is intended behavior.

Nice work.
Thanks for this update.

Regards,
Doug
*



Nice update indeed. In my case, though, I do not see an icon in the the statusbar. Instead, there is blank space. When I click on the space, it shows me the various options: "Unmount usbstorage1", "Mount USB ZIP" and "Mount CD-ROM".

By the way, the blank spot (or potential icon) only shows up after I attach the USB cable and the USB flash drive to the Z.


Thanks again!

N.

C3000, Sharp ROM
dougeeebear
QUOTE(John Galt @ Nov 7 2006, 12:04 PM)
I do not see an icon in the the statusbar.
*

Do you have Meanie's System Info ipk installed?
It containes the icon the usbapplet uses, but I don't think sharp's default system info does.
Meanie
QUOTE(dougeeebear @ Nov 8 2006, 06:55 AM)
QUOTE(John Galt @ Nov 7 2006, 12:04 PM)
I do not see an icon in the the statusbar.
*

Do you have Meanie's System Info ipk installed?
It containes the icon the usbapplet uses, but I don't think sharp's default system info does.
*



i will repackage it with its own icons eventually once i got it fully functional. functionality first, then the art work can begin smile.gif

everything seems to be working ok, except the keyboard/mouse notifications sometimes dont happen, but they sometimes do so i dont know what is wrong sad.gif
John Galt
QUOTE(dougeeebear @ Nov 7 2006, 04:55 PM)
QUOTE(John Galt @ Nov 7 2006, 12:04 PM)
I do not see an icon in the the statusbar.
*

Do you have Meanie's System Info ipk installed?
It containes the icon the usbapplet uses, but I don't think sharp's default system info does.
*



I don't think I do...I will search for it and install it. Thanks!
dougeeebear
QUOTE(John Galt @ Nov 7 2006, 03:47 PM)
QUOTE(dougeeebear @ Nov 7 2006, 04:55 PM)
QUOTE(John Galt @ Nov 7 2006, 12:04 PM)
I do not see an icon in the the statusbar.
*

Do you have Meanie's System Info ipk installed?
It containes the icon the usbapplet uses, but I don't think sharp's default system info does.
*



I don't think I do...I will search for it and install it. Thanks!
*


You will find it at the link in Meanie's sig.
There are also some updates to it here
Meanie
I build a new version (1.0.2) to be uploaded later once I package it.

This version will contain the following features and enhancements:

a set of icons for the menu options and small tray icon
usb icon is displayed in tray when usb host cable and/or devices is/are plugged in
can unmount up to 4 USB disks/devices if used in combination with a USB hub and my automounter script
can unmount single USB disk/device using standard usb-storage script
can mount and unmount usb cdrom (without the need to physically unplug and replug the drive)
can mount and unmount usbzip (without the need to physically unplug and replug the drive)
detects when a usb device (mouse/keyboard/ethernet/bluetooth) is plugged in or unplugged. there will be additional item(s) in the usb menu and also a short popup notification (sometimes popup does not appear sad.gif )
if a custom script exists (to be created by user) then the usb menu will have a start and a stop menu selection for the script.
ie. if there is a /opt/QtPalmtop/bin/usbethernet script and the applet detects a usb lan card being plugged in, then there will be two options added, one which call the usbethernet script with the start option being passed and one with the stop option being passed. This way, the usbethernet script can be tailored to be executed to for example connect to a specific network and disconnect from it. if the script does not exist, a single menu item will be added instead which does not do anything but just says USB Ethernet Detected.
currently, the following scripts can be added for customisation:
/opt/QtPalmtop/bin/usbbluetooth
/opt/QtPalmtop/bin/usbethernet
/opt/QtPalmtop/bin/usbkeyboard
/opt/QtPalmtop/bin/usbmouse
Meanie
here's the updated package
dougeeebear
Nice job.

I see the two menu items "Mount USB ZIP" and "Mount CD-ROM" are not listed now.
I assume they only show up if they are plugged in (which makes sense).
I don't have either one to check it out.

Thanks again for this very handy application.

Doug
dougeeebear
Here's a little icon I whipped up for usb storage.
To use it, save image as "usbstorage.png" and copy it to /home/QtPalmtop/pics144/usbmon

It would also be kind of neat if there could be separate icons for the mouse and keyboard smile.gif
Meanie
QUOTE(dougeeebear @ Nov 9 2006, 07:29 AM)
Here's a little icon I whipped up for usb storage.
To use it, save image as "usbstorage.png" and copy it to /home/QtPalmtop/pics144/usbmon

It would also be kind of neat if there could be separate icons for the mouse and keyboard smile.gif
*


send me more nice looking images and I will add them to the package smile.gif

btw, the USB ZIP and CDROM will only appear if they are detected, ie automounter script detects them and creates the required mount points for them. (ie, /mnt/cdrom /mnt/usbzip). Unfortunately, this means, once, you have those directories, they will always appear, even when they are not plugged in. I will need to fix that eventually...
Meanie
QUOTE(Meanie @ Nov 9 2006, 11:26 AM)
btw, the USB ZIP and CDROM will only appear if they are detected, ie automounter script detects them and creates the required mount points for them. (ie, /mnt/cdrom /mnt/usbzip). Unfortunately, this means, once, you have those directories, they will always appear, even when they are not plugged in. I will need to fix that eventually...
*


fixed that now smile.gif

I will repackage again and include more images. The applet will look for the following images under usbmon:

usbbluetooth.png
usbethernet.png
usbmouse.png
usbkeyboard.png
usbzip.png
usbcdrom.png
usbstorage.png
usb-host.png

I will just link all those images that I don't have to usb.png so you can break the link and replace with appropriate icons in the future...
dougeeebear
QUOTE(Meanie @ Nov 8 2006, 08:15 PM)
I will just link all those images that I don't have to usb.png so you can break the link and replace with appropriate icons in the future...
*

So do you mean the applet will use the icons if they exist, otherwise it will use usb.png?

I'll look around for some icons that will fit in and look good.
(I cheat and save them from various sites and edit them).
The keyboard might be hard to get a good looking one.

Here's one for the usbmouse:
Meanie
QUOTE(dougeeebear @ Nov 9 2006, 10:28 PM)
QUOTE(Meanie @ Nov 8 2006, 08:15 PM)
I will just link all those images that I don't have to usb.png so you can break the link and replace with appropriate icons in the future...
*

So do you mean the applet will use the icons if they exist, otherwise it will use usb.png?

I'll look around for some icons that will fit in and look good.
(I cheat and save them from various sites and edit them).
The keyboard might be hard to get a good looking one.

Here's one for the usbmouse:
*



I added the icons you posted. The applet will use the images of those names which are symbolic links to usb.png, so all you need to do to customise them is to delete them and replace with your own image.

removed attached package. see newer post for fixed package
dougeeebear
This is nice.

One question:
(since I only have a usb drive and a mouse, I can't check other items)

On the mouse popup detected/unplugged notifications I get the mouse icon ok.

On the usbstorage popup mounted/unmounted notifications I get the usb.png icon, but the usbstorage.png icon displays ok in the menu.

Not sure what's going on there.
I'm using /mnt/usbstorage (I don't have automounter installed).
Maybe that's the problem.

Thanks,
Doug
Meanie
QUOTE(dougeeebear @ Nov 9 2006, 11:33 PM)
This is nice.

One question:
(since I only have a usb drive and a mouse, I can't check other items)

On the mouse popup detected/unplugged notifications I get the mouse icon ok.

On the usbstorage popup mounted/unmounted notifications I get the usb.png icon, but the usbstorage.png icon displays ok in the menu.

Not sure what's going on there.
I'm using /mnt/usbstorage (I don't have automounter installed).
Maybe that's the problem.

Thanks,
Doug
*


prolly a bug sad.gif i must have forgotten to change the code to look for usbstorage.png instead of usb.png
dougeeebear
I think I was wrong about what icon the usbstorage mounted/unmounted popup notifications are using.
I believe they are still using the usb.png icon from sysinfo, as they did before you added the new icons.
Meanie
QUOTE(dougeeebear @ Nov 10 2006, 04:30 AM)
I think I was wrong about what icon the usbstorage mounted/unmounted popup notifications are using.
I believe they are still using the usb.png icon from sysinfo, as they did before you added the new icons.
*


you prolly need to restart qtopia since it caches images...
dougeeebear
QUOTE(Meanie @ Nov 9 2006, 03:29 PM)
QUOTE(dougeeebear @ Nov 10 2006, 04:30 AM)
I think I was wrong about what icon the usbstorage mounted/unmounted popup notifications are using.
I believe they are still using the usb.png icon from sysinfo, as they did before you added the new icons.
*


you prolly need to restart qtopia since it caches images...
*

I reboot each time I make a change (I don't have an option to restart qtopia).
Anyway, I renamed /sysinfo/usb.png and the popup notification icon didn't display at all which tells me that it's still using that icon.

EDIT:
Just to make sure I was right, I just renamed usbstorage.png to usb.png and copied it to /sysinfo and it's displaying as it should on the popup.

Doug
Meanie
QUOTE(dougeeebear @ Nov 10 2006, 08:33 AM)
QUOTE(Meanie @ Nov 9 2006, 03:29 PM)
QUOTE(dougeeebear @ Nov 10 2006, 04:30 AM)
I think I was wrong about what icon the usbstorage mounted/unmounted popup notifications are using.
I believe they are still using the usb.png icon from sysinfo, as they did before you added the new icons.
*


you prolly need to restart qtopia since it caches images...
*

I reboot each time I make a change (I don't have an option to restart qtopia).
Anyway, I renamed /sysinfo/usb.png and the popup notification icon didn't display at all which tells me that it's still using that icon.

EDIT:
Just to make sure I was right, I just renamed usbstorage.png to usb.png and copied it to /sysinfo and it's displaying as it should on the popup.

Doug
*



ok, I checked the code and indeed I forgot to change the icons for the popup messages so the menu was displaying the right icons, but the popup messages for the usbstorage devices were not.

well, back to recompile and repackage smile.gif

ok, that took only a minute to do biggrin.gif
dougeeebear
That's got it.
This applet is a real jewel.
Thanks a lot.

Regards,
Doug
tml
I installed 1.0.3 on sharp rom (c3100, tetsu kernel) and created a file usbkeyboard, which checks $1 using a case statement whether it's start of stop. The usbkeyboard should switch key maps using keyhelper.

When I plug in the keyboard, two items appear in the menu. Now, when I click "start" the zaurus gets stuck for a moment and then a error message (could not be mounted) appears. The script works fine when run from the command line as user zaurus.

Could somebody please post a sample script? Are there any log messages so I can look what went wrong? I assume the script is run as the standard user zaurus?
dougeeebear
This is interesting...
When I insert/remove an SD card, I usually get a popup notification (I have qtopia-cardmon installed).
But if I have a usb drive connected I don't get the SD notification popup, although it does mount and unmount.
I'm not sure if this happened before I installed the usb applet or not, but I think I'll check it out.
(Regardless, I wouldn't be without the usb applet).

UPDATE:
I uninstalled the usb applet and it still acted the same.
So it's apparently a little conflict caused when a drive is plugged into the usb port.
It must be a sharp rom thing I guess.

Meanie, you're off the hook smile.gif
Jon_J
Got a copy of CardExport and now I can use my Palm as a card reader. biggrin.gif biggrin.gif
Meanie
QUOTE(tml @ Nov 11 2006, 09:27 PM)
I installed 1.0.3 on sharp rom (c3100, tetsu kernel) and created a file usbkeyboard, which checks $1 using a case statement whether it's start of stop. The usbkeyboard should switch key maps using keyhelper.

When I plug in the keyboard, two items appear in the menu. Now, when I click "start" the zaurus gets stuck for a moment and then a error message (could not be mounted) appears. The script works fine when run from the command line as user zaurus.

Could somebody please post a sample script? Are there any log messages so I can look what went wrong? I assume the script is run as the standard user zaurus?
*


The scripts are executed as root user so it will fail to run qcop command since only zaurus user can run those. you need to add sudo or su to your commands to root user can run the commands as zaurus user.
I will update the applet when i have time to also check for the usb client mode so you can enable/disable samba, usbnetworking when the client cable is plugged in....
Snappy
This is really neat meanie! This is really making Cacko feel very polished! smile.gif
xamindar
Wow, can't believe I never saw this before. Works great! Only bother is that it doesn't mount more than one usb drive at a time. Anyone know if this is possible?
speculatrix
QUOTE(xamindar @ Oct 4 2008, 10:05 AM) *
Wow, can't believe I never saw this before. Works great! Only bother is that it doesn't mount more than one usb drive at a time. Anyone know if this is possible?


you should be able to have lots of USB drives mounted; just be warned of the power limits on the USB host, and/or use a powered hub.
xamindar
QUOTE(speculatrix @ Oct 4 2008, 02:29 AM) *
QUOTE(xamindar @ Oct 4 2008, 10:05 AM) *
Wow, can't believe I never saw this before. Works great! Only bother is that it doesn't mount more than one usb drive at a time. Anyone know if this is possible?


you should be able to have lots of USB drives mounted; just be warned of the power limits on the USB host, and/or use a powered hub.

I'm using a powered usb hub. When I plug more than one usb drive into it only the first is mounted and shows in the files tab. I can mount a second one manually so I know they work. Just wondering why this applet and/or the automount package doesn't do more than one.
xamindar
QUOTE(xamindar @ Oct 4 2008, 02:59 AM) *
I'm using a powered usb hub. When I plug more than one usb drive into it only the first is mounted and shows in the files tab. I can mount a second one manually so I know they work. Just wondering why this applet and/or the automount package doesn't do more than one.

No one ever responded to this so I decided (2 years later wink.gif) to look into it myself. The /etc/hotplug/usb/usb-storage script is what is called when a drive is inserted and it will by default mount up to 4 drives (sda-sdd). If you connect one flash drive it will run through, check for a remove script and if it does not exist will then go ahead and mount the drive by looking for each of the four in turn. Then, once it is done mounting it will create a remove link under /var/run/usb/. If you then connect a second drive afterwards the script will run again and first check for any remove scripts which in this case will exist and therefore it will not try to mount anything else.
On the other hand, if I plug four flash drives into a usb hub and then afterwards plug that hub into the Zaurus the script will run and because there is no remove link yet it will run through and mount all four drives in the first go. Drives can be unmounted individually from the usb tray applet but ALL have to be physically disconnected from the zaurus before it will remove that remove link and allow mounting new drives again.
I'm not sure why whoever made this automounter (meanie?) decided to make it this way but it isn't very robust at all. Of course, I'm not very skilled with hotplug as the zaurus is the only linux I have that still uses it. Oh well, good enough as long as you understand how this usb-storage script is working. Maybe a simple change to the script to check if the drive is already mounted before trying to mount it instead of looking for that remove script would fix it. I'll try it but it may be that way for a reason.

I mainly put this here so in the future when I again try to figure this out I will remember where I left off.
Meanie
QUOTE(xamindar @ May 16 2010, 06:48 PM) *
QUOTE(xamindar @ Oct 4 2008, 02:59 AM) *
I'm using a powered usb hub. When I plug more than one usb drive into it only the first is mounted and shows in the files tab. I can mount a second one manually so I know they work. Just wondering why this applet and/or the automount package doesn't do more than one.

No one ever responded to this so I decided (2 years later wink.gif) to look into it myself. The /etc/hotplug/usb/usb-storage script is what is called when a drive is inserted and it will by default mount up to 4 drives (sda-sdd). If you connect one flash drive it will run through, check for a remove script and if it does not exist will then go ahead and mount the drive by looking for each of the four in turn. Then, once it is done mounting it will create a remove link under /var/run/usb/. If you then connect a second drive afterwards the script will run again and first check for any remove scripts which in this case will exist and therefore it will not try to mount anything else.
On the other hand, if I plug four flash drives into a usb hub and then afterwards plug that hub into the Zaurus the script will run and because there is no remove link yet it will run through and mount all four drives in the first go. Drives can be unmounted individually from the usb tray applet but ALL have to be physically disconnected from the zaurus before it will remove that remove link and allow mounting new drives again.
I'm not sure why whoever made this automounter (meanie?) decided to make it this way but it isn't very robust at all. Of course, I'm not very skilled with hotplug as the zaurus is the only linux I have that still uses it. Oh well, good enough as long as you understand how this usb-storage script is working. Maybe a simple change to the script to check if the drive is already mounted before trying to mount it instead of looking for that remove script would fix it. I'll try it but it may be that way for a reason.

I mainly put this here so in the future when I again try to figure this out I will remember where I left off.


Yeah that was my fault. Back then when I wrote it I was a Linux n00b.
Snappy
Hi folks, how has everyone been? smile.gif
Meanie
QUOTE(Snappy @ Aug 16 2010, 01:33 AM) *
Hi folks, how has everyone been? smile.gif


Life has been too busy. No time to to develop anything new for the Zaurus, but I am still using it.
xamindar
QUOTE(Meanie @ Sep 6 2010, 05:55 AM) *
QUOTE(Snappy @ Aug 16 2010, 01:33 AM) *
Hi folks, how has everyone been? smile.gif


Life has been too busy. No time to to develop anything new for the Zaurus, but I am still using it.

Great to see you are still around. I still refer to your website on occasion. I haven't found anything to replace my Zaurus yet and am starting to think I never will.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2016 Invision Power Services, Inc.