Help - Search - Members - Calendar
Full Version: Problem With Wireless Lan Wl-672 Wifi Card
OESF Forums > General Forums > General Support and Discussion > Security and Networking
freizugheit
I got two pieces of the above-mentioned WiFi cards from my friend.

The response of "cardctl ident" is as follows:

product info: "Wireless LAN", "11Mbps PC Card", Version 01.02", ""
manfid: 0x0156, 0x0002
function: 6 (network)

I added the following in /etc/pcmcia/wlan-ng.conf:

card "Wireless LAN"
manfid 0x0156, 0x0002
bind "prism2_cs"

After restarting the cardmanager, I received the following from "cardctl stauts":

Socket 0:
3.3V 16-bit PC Card
function 0: [ready]

When I tried to use the network module to connect the card to the wireless LAN of my Linksys WAG54G modem router, which was configured as mixed mode Wireless connection, the card switched to suspended mode after short handshaking.


Any pointer to get this card worked?

My Zaurus is SL-5600 with the original Sharp ROM.
freizugheit
Making some progress.

Activating lsmod found that p80211 and prims2_cs were not there.

Usse the following commands to install both modules:

insmod p80211
insmod prims2_cs


After rebooting, kismet was able to detect neighbour's wireless LAN, but not my own from Linksys WAG54G wireless modem router running at mixed mode.

However, when the router's wireless LAN changed to B-only mode, Kismet could detect. But I still could not connect to the Wireless LAN using WEP.
Cyberdoc1971
Actually I have one of these cars as well, and I have never had any success with it. Ambicom seems to be one of the best brand of cards to work with.
freizugheit
I got it worked. Zaurus rocks.

I checked the content of /etc/pcmcia/network.opts and found this:

CODE
case "$ADDRESS" in
qpewlan0,*,*,*)
   BOOTP=n
   DHCP=y
   IPADDR=
   GATEWAY=192.168.1.1
  DHCP_HOSTNAME=JS
  start_fn () { return; }
   stop_fn () { return; }
 ;;


I added Gateway IP and DHCP Hostname to point to my wireless router, which is configures as Wireless Access Point in Mixed Mode with disabled WEP.

I used "su cardctl status" to check the card status. The card should show:

CODE
Socket 0:
3.3V 16-bit PC Card
function 0: [ready]


If you found the card in suspended mod, issue "su cardctl resume"

As soon as the card is ready, just issue "su cardctl scehme qpewlan0 &" to configure the card. Do not make use of the network configuration module under Utilities, which does not work at all.


When this configuration command is issued first time, you should notice that the last line of message should be "resultcode=success". Then you can issue "ifconfig eth0" to check that the card has obtained a latest IP from the DHCP server residing in the router.

At times, I need to issue "su cardctl config" followed by "su cardctl scehme qewlan0 &" to get the network up.

As for Opera browser, I encountered "No proxy server" found first time. It works latter after changing the proxy setting as shown:

CODE
[Proxy]
Use GOPHER=0
Use WAIS=0
Gopher Server=
WAIS Server=
No Proxy Servers=.sg
Use HTTP=0
Use HTTPS=0
Use FTP=0
HTTP Server
HTTPS Server
FTP Server



I still have problem to configure the card to work with my router which is configured in WEP with shared key mode.

Can someone shed light how to do it with command line?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.