Help - Search - Members - Calendar
Full Version: Bluetooth And R121 And Gui
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Chero
If a picture paints a thousand words, then why shoud I say more ...

Click to view attachmentClick to view attachmentClick to view attachmentClick to view attachment
InSearchOf
Congrats on that...

but why arent you using xfce... it works... a little diff... but it works...

Late
Chero
I will, but I first wanted to test that bluetooth thing.

Wait and see ...

Have fun,
Chero.
Chero
Mmm, lack of intrest in the forums lately ..... ?

I was able to get a gui working for sending files over bluetooth as well.
Will add some screenshots this evening (left my usb-cable at home).

In short :
- right click on a file in thunar
- select "send via bluetooth"
- you get a window to select (or search for) bluetooth devices
- then you get a progress-bar showing the sending of the file

Feels better than openobex, no messing with settings, just needs a working bluetooth card.

Chero.
Chero
OK, I have a mini-card-reader with me :

Click to view attachmentClick to view attachmentClick to view attachment

Having fun,
Chero.
svs57
QUOTE(Chero @ Nov 21 2006, 01:07 PM)
OK, I have a mini-card-reader with me :

Click to view attachmentClick to view attachmentClick to view attachment

Having fun,
Chero.
*

Where can I get latest xfce4 working with R121?
Is it possible to test your bluetooth program?
Thks
Chero
QUOTE(svs57 @ Nov 21 2006, 01:44 PM)
Where can I get latest xfce4 working with R121?
Is it possible to test your bluetooth program?
Thks
*


I'm currently testing xfce 4.4rc2 on r121. No packages available yet.

The bluetooth thing is gnome-bluetooth. It's still missing some features, but as you can see, it's quite usable. Package will follow soon.

Chero.
Chero
Hi,

It takes 65 secs to send a 446.5Kb file.

Is this an acceptable speed ?

Chero.
InSearchOf
QUOTE(Chero @ Nov 21 2006, 02:27 PM)
Hi,

It takes 65 secs to send a 446.5Kb file.

Is this an acceptable speed ?

Chero.
*


On a full blown pc... NO!... I believe bluetooths through-put is 721kbps... which equals to approximently 90kb/s... and with that calculation... it should have been done in aprox. 5 secs... I typed a big speal about why it may be slow... but changed my mind and didnt feel like verifying all the crap I wrote... so sorry I deleted it...

Well with that said... it is better to have it working slow... then not working at all :-)

Late
Chero
Something old, something new, something borrowed, something blue(tooth)

Click to view attachmentClick to view attachmentClick to view attachmentClick to view attachment
svs57
I also compiled gnome-bluetooth-0.8.0.
What version of gnome-bluetooth on your screenshots?
I havn't "send msg" and "preference" on 0.8.0
What file manager you are using?
Chero
QUOTE(svs57 @ Nov 23 2006, 03:44 PM)
I also compiled gnome-bluetooth-0.8.0.
What version of gnome-bluetooth on your screenshots?
I havn't "send msg" and "preference" on 0.8.0
What file manager you are using?
*


The "send message" and "preferences" are from gnome-phonemanager (or "phonemanager").

I guess I compiled 0.8.2 (have to check).

The file-manager is "thunar". I'm testdriving xfce4.4rc2 on pdax 1.1.0r121. I'll let you know more soon.

Tonight I'll try to add "btrcv" to this all and then create some ipkgs.

Chero.
newkirk
What's the status of this now? I'm running r121 on my C860 and trying to get it to recognize my billionton is driving me crazy. But at some point I really need to get it back in the saddle for file transfers and DUN with my cell.

j
Chero
QUOTE(newkirk @ Nov 26 2006, 09:15 AM)
What's the status of this now?  I'm running r121 on my C860 and trying to get it to recognize my billionton is driving me crazy.  But at some point I really need to get it back in the saddle for file transfers and DUN with my cell.

j
*


The status of this all is unfinished, but here comes what I have.

Your billionton card :
- remove it
- run /etc/rc.d/init.d/bluetooth restart
- insert it again
- run blue-start (in the attached zip-file)
at least, mine works like that (but without leds)

The rest is what you see in the pictures above.

Have fun,
Chero
badog
does these software only run in 1.10 R121? can they be run in 1.1.0 beta 1?
Chero
QUOTE(badog @ Nov 27 2006, 06:41 PM)
does these software only run in 1.10 R121? can they be run in 1.1.0 beta 1?
*


Don't know, give it a try and you'll know.

Chero.
neopes
sorry... but where i can get libebook?
Chero
QUOTE(neopes @ Nov 29 2006, 03:53 PM)
sorry... but where i can get libebook?
*


evolution-data-server (it's in the r121 feed)

Chero.
LSQ
I've just tryied it after running blue-start rxvt say me )) what he
'Can't get port settings: input/output error
Can't initialize device: Illegal seek'

What i've done wrong?

Thanks LSQ
Chero
QUOTE(LSQ @ Jan 3 2007, 10:11 PM)
I've just tryied it after running blue-start rxvt say me )) what he
'Can't get port settings: input/output error
Can't initialize device: Illegal seek'

What i've done wrong?

Thanks LSQ
*


probably your card isn't initialized.
Your Z doesn't seem to recognize it.

What does "hcitool scan" say in rxvt ?

What Z are you using, which BT-card, which rom ?

Chero.
LSQ
#hcitool [scan] [config] [cc] etc work without any problems
Device Sharp 3000
pdaXROM Alice (Beta3?)
Noname CF bluetooth (
About Z i don't understand because my English rather bad( 'BlueZ' if you mean this...

But in fact # obexftp doesn't work too (
Chero
QUOTE(LSQ @ Jan 4 2007, 09:43 AM)
#hcitool [scan] [config] [cc] etc work without any problems
Device Sharp 3000
pdaXROM Alice (Beta3?)
Noname CF bluetooth (
About Z i don't understand because my English rather bad( 'BlueZ' if you mean this...

But in fact # obexftp doesn't work too (
*


I meant Zaurus. Sorry for not being clear.

If hcitool scan works, your bt-card will be OK and there is no need to use "blue-start". Just forget about it.

Did you also install the rest of the ipkgs? Then,
from command line(rxvt) try
CODE
#gnome-obex-send yourfile

Replace "yourfile" with the filename of the file you want to send.

A dialog should pop up to let you search for bluetooth devices.

Notes :
As far as I know, it hasn't been tested on beta3. (I use r121)

If it doesn't work, please post the output here.

Chero.
LSQ
gnome-obex-send: relocation error: /usr/lib/libbtctl.so.4: undefined symbol: g_intern_static_string


(((


but ectually i sent and recieved files using obexftp and obexserver so bt is really working...

but gnome-~ in your screenshots true so i wanna use it but can't(

maybe i need to reinstall my brain to make it working? help plz)
Chero
QUOTE(LSQ @ Jan 7 2007, 03:30 PM)
gnome-obex-send: relocation error: /usr/lib/libbtctl.so.4: undefined symbol: g_intern_static_string


(((


but ectually i sent and recieved files using obexftp and obexserver so bt is really working...

but gnome-~ in your screenshots true so i wanna use it but can't(

maybe i need to reinstall my brain to make it working? help plz)
*


Not sure,

But the error seems to be related to glib2. If I remember correctly, r121 uses a newer version of glib2 then beta3.
It seems the ipkgs aren't compatible with beta3 (I compiled them on r121).

Sorry,
But if you want to use this, you'll have to upgrade to r121 (Which is only for people who really want to experiment !!). A new - more stable ? - version is coming soon.

Anyone has this running on beta3 ? If so, then what I say here is wrong.

Chero.
jpmatrix
QUOTE(LSQ @ Jan 7 2007, 04:30 PM)
gnome-obex-send: relocation error: /usr/lib/libbtctl.so.4: undefined symbol: g_intern_static_string


(((


but ectually i sent and recieved files using obexftp and obexserver so bt is really working...

but gnome-~ in your screenshots true so i wanna use it but can't(

maybe i need to reinstall my brain to make it working? help plz)
*


guys,
i tried to install all the stuff on pdaxii13, i ended with ipkg install evolution-data-server from r121 feed. and i finally got the same error :
/usr/lib/libbtctl.so.4: undefined symbol

any help?
Chero
QUOTE(jpmatrix @ Jan 8 2007, 12:12 PM)
QUOTE(LSQ @ Jan 7 2007, 04:30 PM)
gnome-obex-send: relocation error: /usr/lib/libbtctl.so.4: undefined symbol: g_intern_static_string


(((


but ectually i sent and recieved files using obexftp and obexserver so bt is really working...

but gnome-~ in your screenshots true so i wanna use it but can't(

maybe i need to reinstall my brain to make it working? help plz)
*


guys,
i tried to install all the stuff on pdaxii13, i ended with ipkg install evolution-data-server from r121 feed. and i finally got the same error :
/usr/lib/libbtctl.so.4: undefined symbol

any help?
*



The possible solutions I see are :
option 1 : compile a newer glib2 for beta3 (which could cause other problems or will lead into a long list of packages to upgrade)
option 2 : recompile the packages for beta3.

I'd go for the second solution. If nobody is interested, I'm prepared to setup the beta3 cross-compiler and do it myself (but you'll have to be patient, I'm quite busy this week).

Chero.
Meanie
QUOTE(Chero @ Jan 9 2007, 05:25 AM)
QUOTE(jpmatrix @ Jan 8 2007, 12:12 PM)
QUOTE(LSQ @ Jan 7 2007, 04:30 PM)
gnome-obex-send: relocation error: /usr/lib/libbtctl.so.4: undefined symbol: g_intern_static_string


(((


but ectually i sent and recieved files using obexftp and obexserver so bt is really working...

but gnome-~ in your screenshots true so i wanna use it but can't(

maybe i need to reinstall my brain to make it working? help plz)
*


guys,
i tried to install all the stuff on pdaxii13, i ended with ipkg install evolution-data-server from r121 feed. and i finally got the same error :
/usr/lib/libbtctl.so.4: undefined symbol

any help?
*



The possible solutions I see are :
option 1 : compile a newer glib2 for beta3 (which could cause other problems or will lead into a long list of packages to upgrade)
option 2 : recompile the packages for beta3.

I'd go for the second solution. If nobody is interested, I'm prepared to setup the beta3 cross-compiler and do it myself (but you'll have to be patient, I'm quite busy this week).

Chero.
*



if you send me the sources, I can try to compile the packages for beta3 on my Z
Chero
QUOTE(Meanie @ Jan 9 2007, 12:17 AM)
if you send me the sources, I can try to compile the packages for beta3 on my Z
*


Great,

You'll have them this evening (it's 8:37am over here)

Chero.
jpmatrix
while googleing, i found that method which works perfectly :

1) sdptool add --channel 4 OPUSH
2) obex_test -b xx:xx:xx:xx:xx:xx
3) enter "s" to be server mode
4) send a file from nokia mobile to Zaurus


not really quick but at least it works smile.gif
shade
Have anybody ipks compiled for beta 3 ?
Chero
QUOTE(shade @ Jan 10 2007, 12:01 AM)
Have anybody ipks compiled for beta 3 ?
*


I've sent the sources to Meanie last night.

Knowing Meanie, there will be ipks for beta3 real soon ... wink.gif

Have fun,
Chero.
LSQ
topic must live!(

is there some news about beta 3's project?
Meanie
QUOTE(Chero @ Jan 10 2007, 04:55 PM)
QUOTE(shade @ Jan 10 2007, 12:01 AM)
Have anybody ipks compiled for beta 3 ?
*


I've sent the sources to Meanie last night.

Knowing Meanie, there will be ipks for beta3 real soon ... wink.gif

Have fun,
Chero.
*



I am having problems linking libegg. It compiles but fails when it tries to link tray comlaining about not finding a library called '`' , ie nothing. sad.gif
Chero
QUOTE(Meanie @ Jan 15 2007, 07:10 AM)
I am having problems linking libegg. It compiles but fails when it tries to link tray comlaining about not finding a library called '`' , ie nothing. sad.gif
*


After struggling with "genmarshal", I ran into the same trouble. I tried a dirty and ugly "make install -i -k" to see what worked and what didn't. Sending, searching and receiving works with all the gui-s. I guess it's missing some properties windows.

I searched the gnome-bluetooth mailing list about it, but coudn't find anything useful so far. Right now I'm too busy to dig deeper.

BTW : I believe I'm having the same problem on my xubuntu-box. I'll have to verify that this evening to be sure.

Chero.
Meanie
QUOTE(Chero @ Jan 16 2007, 05:26 PM)
QUOTE(Meanie @ Jan 15 2007, 07:10 AM)
I am having problems linking libegg. It compiles but fails when it tries to link tray comlaining about not finding a library called '`' , ie nothing. sad.gif
*


After struggling with "genmarshal", I ran into the same trouble. I tried a dirty and ugly "make install -i -k" to see what worked and what didn't. Sending, searching and receiving works with all the gui-s. I guess it's missing some properties windows.

I searched the gnome-bluetooth mailing list about it, but coudn't find anything useful so far. Right now I'm too busy to dig deeper.

BTW : I believe I'm having the same problem on my xubuntu-box. I'll have to verify that this evening to be sure.

Chero.
*



Thanks. This got gnome-bluetooth compiled. Still having problems with gnome-phone-manager. Got gnokii compiled but its spewing at compiling eds

Anyways, here is what I got so far
Meanie
ok, I figured out why libegg was failing, it required gnutls. the packages for gnutls that come with pdaXrom don't include the .la files and once I compiled gnutls and its dependencies, with all the required .la files, libegg compiles and links fine and so does gnome-bluetooth smile.gif
Chero
QUOTE(Meanie @ Feb 2 2007, 06:25 AM)
ok, I figured out why libegg was failing, it required gnutls. the packages for gnutls that come with pdaXrom don't include the .la files and once I compiled gnutls and its dependencies, with all the required .la files, libegg compiles and links fine and so does gnome-bluetooth smile.gif
*


You never give up, do you ? unsure.gif

What's the difference compared to the "forced" version ?

Chero.
Meanie
QUOTE(Chero @ Feb 6 2007, 04:45 PM)
QUOTE(Meanie @ Feb 2 2007, 06:25 AM)
ok, I figured out why libegg was failing, it required gnutls. the packages for gnutls that come with pdaXrom don't include the .la files and once I compiled gnutls and its dependencies, with all the required .la files, libegg compiles and links fine and so does gnome-bluetooth smile.gif
*


You never give up, do you ? unsure.gif

What's the difference compared to the "forced" version ?

Chero.
*



on my build, the forced version only build one of the binaries in the bin directory and I had to 'steal' your version of the missing binary which luckily worked. now it builds cleanly, i don't need to steal your binaries anymore smile.gif i think that the binaries of gnome-bluetooth and gnome-phone-manager for r121 work fine on beta3, but the dependent libraries like libbtctl and eds don't which is why they failed previously. anyway, i got everything build now for beta3 so i am not worrying anymore whether i could had just compiled the dependent libs and used your gnome apps...
jpmatrix
Meanie,
it seems i've problems receiving via bluetooth with latest pdaxii13 (sending from zaurus to phone is ok)
i've got this error message:

close_sock: Read error: Connection reset by peer

any idea?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.