Help - Search - Members - Calendar
Full Version: Libxml-parser-perl Doesn't Work
OESF Forums > Distros, Development, and Model Specific Forums > Everything Development > OpenZaurus/Opie/Qtopia
ShiroiKuma
I'm using GPE 3.5.4.1 on an SL-C3200 and having problems with XML Parser.

I've installed the one from the feed but it bombs with an error when required by Perl, the problem is the file /usr/lib/perl5/auto/XML/Parser/Expat/Expat.so

In fact, when building libxml-parser-perl with OpenEmbedded it gives a fatal error on stripping the same file, but it goes and completes the build, but it's unusable.

I tried compiling XML Parser natively on the Z, but I get "no rule to make target /usr/lib/perl5/5.8.7/ExtUtils/typemap" error and haven't discovered how to fix it.

Has anyone built a working XML Parser for Perl?
Wildherb
QUOTE(ShiroiKuma @ Dec 6 2006, 09:11 AM) *
I'm using GPE 3.5.4.1 on an SL-C3200 and having problems with XML Parser.

I've installed the one from the feed but it bombs with an error when required by Perl, the problem is the file /usr/lib/perl5/auto/XML/Parser/Expat/Expat.so

In fact, when building libxml-parser-perl with OpenEmbedded it gives a fatal error on stripping the same file, but it goes and completes the build, but it's unusable.

I tried compiling XML Parser natively on the Z, but I get "no rule to make target /usr/lib/perl5/5.8.7/ExtUtils/typemap" error and haven't discovered how to fix it.

Has anyone built a working XML Parser for Perl?



I've got exactly the same error while trying to build Compress::Raw::Zlib

I've not found a way round this
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.