Help - Search - Members - Calendar
Full Version: Bluetooth PAN trouble Permission denied (13)
OESF Forums > General Forums > General Support and Discussion > Security and Networking
Anonymous
Hi,

Ive gotten a lot of great help by reading on this forum but ive come to a problem I cant find anything about. I am a newbie to linux but have some experience with it and have lots of experience with computers otherwise. I recently got a Zaurus 5500 and a bluetooth CF card (the ambicom BT2000E, I know only certain revisions work). Im trying to set up a PAN using the BlueZ stack and the guide on http://www.jens-koenen.de/zaurus_pan.html . On my desktop im running WinXP Pro and am trying to connect to my bluetooth USB dongle. When I do an hcitool scan the Z detects the bluetooth dongle and its MAC address, and when I scan for available devices via windows it finds the CF card and gets its MAC also. However when I either try to use the command line connect pand --role PANU --service NAP --connect xx:xx:xx:xx:xx:xx --nodetach I get the error "connect to xx:xx:xx:xx:xx:xx failed. Permission denied (13). When I try to just use the Z network connection, I get a similar problem, it seems to start to connect then says "Cennection Setup Error - No Connection detected - Check your TCP/IP settings". Im at a lose. I assume its a problem with how XP is configured... but I cant for the life of me figure it out. Oh and I have a file sharing working on my XP box with my apartment LAN if that matters. Anyway, any help would be greatly appreciated.

Thanks in advance,
Erik
maslovsky
Try to manualy pair your desktop and zaurus from WinXP box. Then select zaurus properties and select a check box at Network Access optino.
Anonymous
Thanks for the response. I have already paired the Z with my XP box, its listed as such when I list the devices in range. And I already have checked the box on the zaurus to give it network access.

Any other ideas?
:?:
maslovsky
Try to reboot you XP machine. I think it's glitch at windows drivers side.
datajerk
I have a the same problem. A sdptool browse lists no NAP service on XP. Any ideas how to enable/add?
datajerk
NAP to be native in XP with SP2.
maslovsky
NAP should be supported by the bluetooth drivers on your PC. If not, update the drivers for your bluetooth device.
tumnus
It is possible that the Bluetooth dongle on the PC doesn't physically support the NAP profile.

As for enabling stuff on the Windows, the manuals that came with the drivers are the best source of that information.
Anonymous
Hi,

I've had this problem as well (using Win2K and a TDK systems USB bluetooth dongle). In my case, the problem was that the TDK software only allows authenticated connections, and was solved by editing /etc/bluetooth/hcid.conf to contain:
CODE
       auth enable;


(look near the end of hcid.conf). This means that when the Z tries to connect, a window pops up on the PC that allows me to accept or refuse the connection (different BT software on the PC may have different ways of specifying this).

Other things to look at:

Make sure that only one of your PC and Z try to become a PAN master (look for "Default link mode" in /etc/bluetooth/hcid.conf, and try editing this according to the comments there).

The NAP service may introduce other complications due to sharing internet connections etc. To get the Z <-> PC end of things working, try using "--service GN" instead (this still allows you to connect between the PC and the Z; in fact I am doing this to telnet into my Z over Bluetooth and browse its files right now).

Good luck,
P.
pakman
Aaaaargh - that last post was me - forgot to login......
lami
Be sure you are executing command as root, I had same problem but was running it as zaurus user (cacko rom 1.22a)
speculatrix
when you've changed hcid.conf, you'll need to eject and reinsert the card ("cardctl eject", "cardctl insert")... or even reboot the Z.

another thing I found what that both the PC and Z wanted to be master of the link, so set the option lm to be just "lm accept" on both ends, and set the option "lp rswitch" too.

Paul
craigtyson
Had this same problem last year with my 5500 PAN ing to my XPsp1 box with a Belkin USB bluetooth card. after much frustration I found that ther was no PAN profile on the Belkin dongle so no way to connect. I eventualy got things going by using a combination of PPP to the XP box. a freeware proxy on XP + ICM + the serial network adapter from XP. The tread seems to have been archived sad.gif

I then bought a new BT adapter for my XP box whth PAN and all worked fine.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.