Help - Search - Members - Calendar
Full Version: Missing Or Can't Find Libiconv.so.2
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
tombraider
I actually found libiconv.so.2 somewhere through Google but no matter which lib directory I copy it to, the apps complain they can't find it.

Also, is there any PIM which works? I can't seem to install gpe-contacts from the feed...even to internal memory. It just still shows it's not installed. There's something called fltdj or something but I could not install it either.
I just need to put about 30 phone numbers, addresses and emails somewhere.

Thanks...I know I'm being a pest. sad.gif
Jon_J
I collect libraries, a lesson learned in cacko.
here's 2 versions of libiconv

check the filename of this one.
libiconv_1.8-2_arm.ipk (there is a dash, not underscore between 8-2)
EDIT: (April 04, 2008)
libiconv_1.8-2_arm.ipk is for Sharp/Cacko.
tombraider
Thanks, Jon_J, you're a lifesaver! Thanks for your help in other threads if I forget to thank you specifically in the thread.

I'm glad you are a collector. laugh.gif

edit: I installed BOTH files to internal for good measure but gringotts still complains. I previously uninstalled streamtuner so don't know if it works...probably not. Sigh...

On a positive note, there's a TON of stuff already incorporated into the basic installation of Beta3 so there aren't as many problems as there could be and the ROM is pretty darned awesome.

QUOTE(Jon_J @ Feb 10 2007, 07:30 PM)
I collect libraries, a lesson learned in cacko.
here's 2 versions of libiconv

check the filename of this one.
libiconv_1.8-2_arm.ipk (there is a dash, not underscore between 8-2)
*
Meanie
QUOTE(tombraider @ Feb 11 2007, 09:47 AM)
Thanks, Jon_J,  you're a lifesaver!  Thanks for your help in other threads if I forget to thank you specifically in the thread. 

I'm glad you are a collector.  laugh.gif 

edit:  I installed BOTH files to internal for good measure but gringotts still complains. I previously uninstalled streamtuner so don't know if it works...probably not.  Sigh...

On a positive note,  there's a TON of stuff already incorporated into the basic installation of Beta3 so there aren't as many problems as there could be and the ROM is pretty darned awesome.

QUOTE(Jon_J @ Feb 10 2007, 07:30 PM)
I collect libraries, a lesson learned in cacko.
here's 2 versions of libiconv

check the filename of this one.
libiconv_1.8-2_arm.ipk (there is a dash, not underscore between 8-2)
*

*



that's why I suggest you try pdaXii13. It includes libiconv as well smile.gif pretty much all your problems so far would have never been a problem if you had installed pdaXii13, ie xmms by default is larger as well in pdaXii13. Ok, enough of me trying to persuade you to use pdaXii13. one thing though, you should use these feeds:

http://www.tyrannozaurus.com/feed/beta3/feed/
this feed basically contains all the beta1/beta3 feeds in one single feeds and also includes extra packages that you need such as libiconv and libstdc++ that are not in those feeds. it also contains some packages from the contrib feeds...

http://www.tyrannozaurus.com/feed/beta3/custom/

in addition, this feed also includes some extra packages found in some more contrib feeds that are not hosted on the pdaXrom site plus it also includes my custom packages some of which are bug fixed version of packages in the other feeds...
tombraider
Meanie,

Actually, I got up this morning determined to install pdaXii13, but then went to its thread and read of problems people were having and changed my mind. You see, they seemed to know how to get out of great difficulties by using linux commands and I am still floundering around in Linux so I think I will wait until I see fewer serious problems described.

Yeah, yeah, I'm a coward... I admit it. blink.gif

Thanks for the feed urls. I had one of them but not the other.


QUOTE(Meanie @ Feb 10 2007, 08:17 PM)
QUOTE(tombraider @ Feb 11 2007, 09:47 AM)
Thanks, Jon_J,  you're a lifesaver!  Thanks for your help in other threads if I forget to thank you specifically in the thread. 

I'm glad you are a collector.  laugh.gif  

edit:  I installed BOTH files to internal for good measure but gringotts still complains. I previously uninstalled streamtuner so don't know if it works...probably not.  Sigh...

On a positive note,  there's a TON of stuff already incorporated into the basic installation of Beta3 so there aren't as many problems as there could be and the ROM is pretty darned awesome.

QUOTE(Jon_J @ Feb 10 2007, 07:30 PM)
I collect libraries, a lesson learned in cacko.
here's 2 versions of libiconv

check the filename of this one.
libiconv_1.8-2_arm.ipk (there is a dash, not underscore between 8-2)
*

*



that's why I suggest you try pdaXii13. It includes libiconv as well smile.gif pretty much all your problems so far would have never been a problem if you had installed pdaXii13, ie xmms by default is larger as well in pdaXii13. Ok, enough of me trying to persuade you to use pdaXii13. one thing though, you should use these feeds:

http://www.tyrannozaurus.com/feed/beta3/feed/
this feed basically contains all the beta1/beta3 feeds in one single feeds and also includes extra packages that you need such as libiconv and libstdc++ that are not in those feeds. it also contains some packages from the contrib feeds...

http://www.tyrannozaurus.com/feed/beta3/custom/

in addition, this feed also includes some extra packages found in some more contrib feeds that are not hosted on the pdaXrom site plus it also includes my custom packages some of which are bug fixed version of packages in the other feeds...
*

Ling
Meanie,

Just so you know... I am running pdaXii13 and gringotts does not work.

1) Install gringotts using package manager, puts icon in the Office folder
2) Click icon, nothing, run gringotts from command line.
- missing libgringotts.so.2. Rather dumb that the install doesn't install the library.
3) Use package manager to install libgringotts.
4) Click icon, nothing, run gringotts from command line.
- missing libmcrypt.so.4. Not available in the feeds.

Too bad, sounded like a neat program.
Jon_J
I'm a Linux newb and switched to pdaxii13, one minute after I installed beta3.
Since there are a lot less problems with pdaxii13, there should be less arcane Linux commands to use to make things work.
I'm happy with it. I did try beta 3 for a few short hours, the next day, but I think it is more buggy than pdaxii13. smile.gif
Jon
EDIT:
A lot of problems you see with pdaxii13 are in the testing stage.
meanie has released 2 stable versions, since yesterday
One to install to HDD
One to install to Flash.
Meanie
QUOTE(Ling @ Feb 11 2007, 11:34 AM)
Meanie,

Just so you know... I am running pdaXii13 and gringotts does not work.

1) Install gringotts using package manager, puts icon in the Office folder
2) Click icon, nothing, run gringotts from command line.
    - missing libgringotts.so.2. Rather dumb that the install doesn't install the library.
3) Use package manager to install libgringotts.
4) Click icon, nothing, run gringotts from command line.
    - missing libmcrypt.so.4. Not available in the feeds.

Too bad, sounded like a neat program.
*


whoever creates the packages needs to put the correct depends in the control file of the package, otherwise package manager does not know that it needs to install extra packages... complain to whoever build that package...
Ling
I am not complaining. I understand about dependencies. The problem at the beginning of the thread was missing libraries for streamtuner and gringotts. The suggested solution was install pdaXii13 and use the two feeds. Streamtuner works fine, gringotts doesn't. Just thought I would let you know. Also was hoping that maybe you knew of a source for libmcrypt.
Jon_J
Ling, I found libmcrypt here:
http://zaurus.spy.org/feeds/cacko/pdaXrom/unstable/
Meanie
QUOTE(Ling @ Feb 11 2007, 01:01 PM)
I am not complaining. I understand about dependencies. The problem at the beginning of the thread was missing libraries for streamtuner and gringotts. The suggested solution was install pdaXii13 and use the two feeds. Streamtuner works fine, gringotts doesn't. Just thought I would let you know. Also was hoping that maybe you knew of a source for libmcrypt.
*


http://www.tyrannozaurus.com/feed/beta3/custom/
Ling
Thanks. I needed to do an update. It would be nifty if the package manager would run an update when you open it. Oh well. In order to get gringotts going I had to install libgringotts, libmcrypt and libmhash. Thought it might save others some time.
tombraider
Thanks, Ling, for that info! I was finally able to get Gringotts working...however I have not a clue what to do with it...wanted to import my logins and passwords from zsafe but it baffles me how to do it. Will be looking for Gringotts help files today. :-)

QUOTE(Ling @ Feb 10 2007, 11:45 PM)
Thanks. I needed to do an update. It would be nifty if the package manager would run an update when you open it. Oh well. In order to get gringotts going I had to install libgringotts, libmcrypt and libmhash. Thought it might save others some time.
*
randy11
Thanks you, Jon_J, for the files smile.gif. I've not this files on my Beta3.

THANKS !
Jon_J
QUOTE(randy11 @ Apr 4 2008, 08:02 AM) *
Thanks you, Jon_J, for the files smile.gif. I've not this files on my Beta3.

THANKS !

You're welcome.
I just edited post #2 with the files to point out that "libiconv_1.8-2_arm.ipk" is for Sharp/Cacko.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.