Help - Search - Members - Calendar
Full Version: System Status Display And Gps Questions
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
VirtusRex
Hey guys,

Iíve got two questions: first has anybody got a good gps program for sl-c1000 running pdaxii13, and second what is the system display thingy call and where can I download the package??

Hereís a picture of the system display thingy:
Meanie
QUOTE(VirtusRex @ Mar 8 2007, 01:21 AM)
Hey guys,

Iíve got two questions: first has anybody got a good gps program for sl-c1000 running pdaxii13, and second what is the system display thingy call and where can I download the package??

Hereís a picture of the system display thingy:
*


gpsdrive

that's torsmo. its not automatically started unless you set TORSMO=true in /home/root/Choices/pdaxii13.conf

and its not pre-installed on pdaXii13 base either...
VirtusRex
QUOTE(Meanie @ Mar 7 2007, 10:24 AM)
QUOTE(VirtusRex @ Mar 8 2007, 01:21 AM)
Hey guys,

Iíve got two questions: first has anybody got a good gps program for sl-c1000 running pdaxii13, and second what is the system display thingy call and where can I download the package??

Hereís a picture of the system display thingy:
*


gpsdrive

that's torsmo. its not automatically started unless you set TORSMO=true in /home/root/Choices/pdaxii13.conf

and its not pre-installed on pdaXii13 base either...
*



Thanks Meanie
VirtusRex
What is the package call that contains the torsmo files?
Jon_J
QUOTE(VirtusRex @ Mar 7 2007, 09:39 AM)
What is the package call that contains the torsmo files?
*

Here's the version I have.
EDIT:
I launched torsmo in the console, but does anyone know the switch to shut it down?
VirtusRex
QUOTE(Jon_J @ Mar 7 2007, 11:24 AM)
QUOTE(VirtusRex @ Mar 7 2007, 09:39 AM)
What is the package call that contains the torsmo files?
*

Here's the version I have.
EDIT:
I launched torsmo in the console, but does anyone know the switch to shut it down?
*



Hey Jon_J,

I install you tormso.ipk, but I get the following error:

torsmo: can't open /home/root/.torsmorc: No such file or directory
torsmo: scandir for /sys/bus/i2c/devices/: No such file or directory
Floating point exception

Could the problem be I'm using pdaxii13 for sl-c1000??

VirtusRex
Jon_J
VirtusRex, sorry I'm not sure what the problem might be.
.torsmorc is the configuration file.
The version I posted here is also in the New Packages Announcement pinned thread.
-------------------------------
EDIT: I had to edit this post.
I didn't get this package in the above thread, I think I got it from meanie's feed.
-------------------------------
I'm currently using pdaxii13 build 5.3 on NAND only. (I don't have the spitz upgrade)
I installed torsmo a while back on this setup, but did uninstall it once, and just re-installed it today after I posted it.

BTW, if you get it working, I found the website for it's commands and configurations.
http://torsmo.sourceforge.net/readme.php

Here's the commandline switches.
CODE
Command line options
Argument           Description
-V                 Prints version and exits
-a ALIGNMENT       Text alignment on screen, {top,bottom}_{left,right}
-c FILE            Config file to load instead of $HOME/.torsmorc
-d  D              aemonize, fork to background
-f FONT            Font to use
-h                 Prints command line help and exits
-o                 Create own window to draw
-b                 double buffer (prevents flickering)
-t TEXT            Text to render, remember single quotes, like -t '$uptime'
-u SECS            Update interval
-w WIN_ID          Window id to draw
-x X               X position
-y Y               Y position

Command line options override configurations defined in configuration file.
VirtusRex
QUOTE(Jon_J @ Mar 7 2007, 11:55 AM)
VirtusRex, sorry I'm not sure what the problem might be.
.torsmorc is the configuration file.
The version I posted here is also in the New Packages Announcement pinned thread.
-------------------------------
EDIT: I had to edit this post.
I didn't get this package in the above thread, I think I got it from meanie's feed.
-------------------------------
I'm currently using pdaxii13 build 5.3 on NAND only. (I don't have the spitz upgrade)
I installed torsmo a while back on this setup, but did uninstall it once, and just re-installed it today after I posted it.

BTW, if you get it working, I found the website for it's commands and configurations.
http://torsmo.sourceforge.net/readme.php

Here's the commandline switches.
CODE
Command line options
Argument           Description
-V                 Prints version and exits
-a ALIGNMENT       Text alignment on screen, {top,bottom}_{left,right}
-c FILE            Config file to load instead of $HOME/.torsmorc
-d  D              aemonize, fork to background
-f FONT            Font to use
-h                 Prints command line help and exits
-o                 Create own window to draw
-b                 double buffer (prevents flickering)
-t TEXT            Text to render, remember single quotes, like -t '$uptime'
-u SECS            Update interval
-w WIN_ID          Window id to draw
-x X               X position
-y Y               Y position

Command line options override configurations defined in configuration file.

*


Thanks Jon_J,

Well torsmo_0.18_armv5tel.ipk didn't work, but I tried torsmo_0.17_armv5tel.ipk and it seems to run ok.

VirtusRex
Meanie
yeah, latest is not always greatest....
Drake01
QUOTE(VirtusRex @ Mar 7 2007, 01:41 PM)
Well torsmo_0.18_armv5tel.ipk  didn't work, but I tried torsmo_0.17_armv5tel.ipk and it seems to run ok.
*

I also have the floating point exception error. Where did you find the 0.17 version?

I'm curious how much of my system resources will be diverted to this utility. I still have to try it, though. smile.gif
merli
QUOTE(Meanie @ Mar 8 2007, 12:47 AM)
yeah, latest is not always greatest....
*


I installed wellswang version of torsmo and edited pdaxii13.cnf file but torsmo won't start on startx. But will startt with torsmo -w 0x80001c wjich is my roxfiller window. Where can be problem?
wellswang
QUOTE(merli @ Apr 3 2007, 09:21 PM)
QUOTE(Meanie @ Mar 8 2007, 12:47 AM)
yeah, latest is not always greatest....
*


I installed wellswang version of torsmo and edited pdaxii13.cnf file but torsmo won't start on startx. But will startt with torsmo -w 0x80001c wjich is my roxfiller window. Where can be problem?
*



because during startx process, when your script executing "torsmo -w xxxxx", the desktop window which id is xxxxx is not created yet. you need to sleep to wait until the window been created.

to start torsmo in startx session,
you may create a script file , for example, named starttorsmo.sh , contains following contents:
CODE
sleep 15;torsmo -w xxxxxxx

give execute permission to it
CODE
# chmod +x starttorsmo.sh


then in .xinitrc file, add following line
CODE
starttorsmo.sh &

before
CODE
eval "matchbox-panel --no-flip $MBORIENT" 2>/dev/null >/dev/null



to stop torsmo, just use this command
CODE
# killall torsmo
cool.gif
merli
QUOTE(wellswang @ Apr 3 2007, 03:57 PM)
QUOTE(merli @ Apr 3 2007, 09:21 PM)
QUOTE(Meanie @ Mar 8 2007, 12:47 AM)
yeah, latest is not always greatest....
*


I installed wellswang version of torsmo and edited pdaxii13.cnf file but torsmo won't start on startx. But will startt with torsmo -w 0x80001c wjich is my roxfiller window. Where can be problem?
*



because during startx process, when your script executing "torsmo -w xxxxx", the desktop window which id is xxxxx is not created yet. you need to sleep to wait until the window been created.

to start torsmo in startx session,
you may create a script file , for example, named starttorsmo.sh , contains following contents:
CODE
sleep 15;torsmo -w xxxxxxx

give execute permission to it
CODE
# chmod +x starttorsmo.sh


then in .xinitrc file, add following line
CODE
starttorsmo.sh &

before
CODE
eval "matchbox-panel --no-flip $MBORIENT" 2>/dev/null >/dev/null



to stop torsmo, just use this command
CODE
# killall torsmo
cool.gif
*




Thnx now it is working

I put
CODE
sleep 15;torsmo -w xxxxxxx

into $HOME/.matchbox/autoexec.
That file is tested in pdaxii13 .xinitrc

Then I edited ./xinitrc and after this line
CODE
echo "... torsmo is enabled"

I added

CODE
$HOME/.machbox/autoexec &
Meanie
autoexec is loaded by task applet...
merli
QUOTE(Meanie @ Apr 3 2007, 05:28 PM)
autoexec is loaded by task applet...
*


without editing .xinitrc it is not working :-(.
Meanie
QUOTE(merli @ Apr 4 2007, 01:34 AM)
QUOTE(Meanie @ Apr 3 2007, 05:28 PM)
autoexec is loaded by task applet...
*


without editing .xinitrc it is not working :-(.
*



the task applet might not be installed. it is only pre-installed on spitz...
merli
QUOTE(Meanie @ Apr 3 2007, 05:44 PM)
QUOTE(merli @ Apr 4 2007, 01:34 AM)
QUOTE(Meanie @ Apr 3 2007, 05:28 PM)
autoexec is loaded by task applet...
*


without editing .xinitrc it is not working :-(.
*



the task applet might not be installed. it is only pre-installed on spitz...
*



you are right... :-)
Drake01
QUOTE(merli @ Apr 3 2007, 08:21 AM)
I installed wellswang version of torsmo and edited pdaxii13.cnf file but torsmo won't start on startx. But will startt with torsmo -w 0x80001c wjich is my roxfiller window. Where can be problem?
*

I thought that was the one that I installed. I'll give it another shot. It looks like your configuration is the same as mine (C-1000, pdaxii13 5.3.3), so if it works for you I think it should work for me, too.
portalgod
F.Y.I I also had the seg fault on 0.18 so I installed 0.17 from here :

http://zaurus.spy.org/feeds/cacko/pdaXrom/...17_armv5tel.ipk

Runs fine now.
Drake01
QUOTE(portalgod @ Apr 12 2007, 10:01 PM)
F.Y.I  I also had the seg fault on 0.18 so I installed 0.17 from here :

http://zaurus.spy.org/feeds/cacko/pdaXrom/...17_armv5tel.ipk

Runs fine now.
*

This one works for me. Thanks, portalgod!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.