Help - Search - Members - Calendar
Full Version: Cacko Sl1000 To Motorola A780, Bluetooth
OESF Forums > General Forums > General Support and Discussion > Security and Networking
wls
Greetings all.

I have been unsuccessfully hammering my head against this problem. I would like to, as a start, be able to minicom over /dev/rfcomm0 to my A780 using a Billionton bluetooth CF card.

Minicom is confirmed working on a CF modem.

The Billionton and the A780 also are confirmed working from my Windows laptop. Note that while the A780 has a DUN profile, it has to be specifically enabled each time for use, so I just want to start with the SP service and minicom to confirm I can eventually AT*99#.....

With no existing bluetooth computer devices defined on my A780, I commence as follows:

sdptool records 00:17:00:A8:A0:4B

Service Name: Object Push
Service RecHandle: 0x10000
Service Class ID List:
"OBEX Object Push" (0x1105)
Protocol Descriptor List:
"L2CAP" (0x0100)
"RFCOMM" (0x0003)
Channel: 2
"OBEX" (0x0008)
Profile Descriptor List:
"OBEX Object Push" (0x1105)
Version: 0x0100

Service Name: Headset AG
Service RecHandle: 0x10001
Service Class ID List:
"Headset Audio Gateway" (0x1112)
"Generic Audio" (0x1203)
Protocol Descriptor List:
"L2CAP" (0x0100)
"RFCOMM" (0x0003)
Channel: 3
Profile Descriptor List:
"Headset" (0x1108)
Version: 0x0100

Service Name: Handsfree AG
Service RecHandle: 0x10002
Service Class ID List:
"Handfree Audio Gateway" (0x111f)
"Generic Audio" (0x1203)
Protocol Descriptor List:
"L2CAP" (0x0100)
"RFCOMM" (0x0003)
Channel: 4
Profile Descriptor List:
"Handsfree" (0x111e)
Version: 0x0101

Service Name: Serial Port
Service RecHandle: 0x10003
Service Class ID List:
"Serial Port" (0x1101)
Protocol Descriptor List:
"L2CAP" (0x0100)
"RFCOMM" (0x0003)
Channel: 5


So, I want to be able to use channel 5. So far so good....

rfcomm bind 0 00:17:00:A8:A0:4B 5
rfcomm show

rfcomm0: 00:17:00:A8:A0:4B channel 5 clean

rfcomm connect 0 00:17:00:A8:A0:4B 5

At this point the "Bind With" prompt shows up on my A780 phone. If I enter the wrong code, I simply get the following message on my Zaurus:

Can't connect RFCOMM socket: Connection refused

If I try again, and enter the right passcode (default 1234 as per the Cacko givepin), then the phone then creates a profile for my zaurus and asks me if I want to accept an SPP connection.

If I say yes, I get the following:

Can't create RFCOMM TTY: Address already in use


If I repeat that command, the bluetooth icon against the Zaurus on my phone flashes briefly, and I instead get:

Can't connect RFCOMM socket: Connection refused.


... almost as if the bind isn't working anymore.

Also, from that point forward I can do:

cat < /dev/rfcomm0

And consistently receive /dev/rfcomm0: Connection refused.

This process is 100% repeatable starting from deleting the Zaurus profile on the A780 and restarting the bind process. I can use either rfcomm connect or cat < /dev/rfcomm0... after the first bind, all subsequent connections are refused.

I am using stock Cacko 1.23 full. Any tips would be greatly appreciated!
wls
This problem so far is solved. I had to delete some crappy linkkeys data. See This post by speculatrix.
harvell
thanks for updating the thread smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.