Help - Search - Members - Calendar
Full Version: Freera
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Capn_Fish
Since FreeCnC segfaulted, I've built FreeRA, a spinoff that works with Red Alert. It crashes loading fonts (I believe), so I'm posting my build to see if somebody can determine what the problem is. This was built with a 2.6.x kernel. Demo RA data files can be obtained here:

ftp://ftp.westwood.com/pub/redalert/previ...mo/ra95demo.zip

You need main.mix and redalert.mix. Put them in the "mix" folder.

EDIT: Source is included as well.
Snappy
I tried the windows version and it also crashes at the fonts part. type.fnt is missing and I also had to edit the /freera++/data/settings/files.ini and comment out those requiredX where X=3~9.

Not sure where type.fnt can be gotten but that's the error that popped up.

[RedAlert]
required1=main.mix
required2=redalert.mix
; Submixes (contained in one of the above)
;required3=allies.mix
;required4=conquer.mix
;required5=general.mix
;required6=local.mix
;required7=hires.mix
;required8=snow.mix
;required9=temperat.mix
Capn_Fish
Did you put main.mix and redalert.mix in the data/mix/ directory?
Snappy
Yes I did. smile.gif
deniscallies
Hello i get the same error...


will there be a solution?

Denis
Capn_Fish
I don't know...I'm hoping somebody who knows what they're doing will propose one.
Capn_Fish
For what it's worth, you can now get Red Alert for free:

http://www.ea.com/redalert/news-detail.jsp?id=62

Also, it appears that there's a new-ish project called OpenRedAlert that looks promising (it's continuing the FreeCnC and FreeRA projects):

http://www.ohloh.net/projects/openredalert
http://www.happypenguin.org/show?OpenRedAlert

No builds for the Z ATM, but I may change that wink.gif
pelrun
Hmm. I've built openredalert, and it looks like the problem from FreeRA above still exists. That is, it has trouble reading subfiles from the mixes. Commenting out lines in files.ini is not the answer, as those files are IN main.mix/redalert.mix, and themselves contain the rest of the data files - i.e. fonts etc.

I'm having a poke around using gdb, but I forgot how clunky the command line client is... :S
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.