Help - Search - Members - Calendar
Full Version: Where Can I Get Firmware Symbol_sp24t_prim_fw
OESF Forums > General Forums > General Support and Discussion > Security and Networking
Meanie
can someone attach them here or email them to me?
InSearchOf
I will zip them and send them to you...

Late
Meanie
QUOTE(InSearchOf @ Mar 19 2007, 10:49 PM)
I will zip them and send them to you...

Late
*


thanks

now just need some time to do testing....
BerndS
QUOTE(Meanie @ Mar 19 2007, 12:56 PM)
thanks

now just need some time to do testing....
*


Hi,

I now have a Spectrum24 High Rate Wireless card and I get the error message:

CODE
orinoco 0.15rc2HEAD (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
spectrum_cs 0.15rc2HEAD (Pavel Roskin <proski@gnu.org>, David Gibson <hermes@gibson.dropbear.id.au>, et al)
spectrum_cs: Cannot find firmware: symbol_sp24t_prim_fw
spectrum_cs: Firmware download failed
hermes @ IO 0xf6000000: Timeout waiting for card to reset (reg=0x0000)!
wlan0: failed to initialize firmware (err = -110)
spectrum_cs: register_netdev() failed
pxa_pcmcia_init(0)


after inserting the card.

So: Is the firmware someware available for download?


cardctl identifys the card as

Socket 0:
product info: "Symbol", "Spectrum24 LA4100 Series WLAN PC Card", "1.00"
manfid: 0x026c, 0x0001
function: 6 (network)
Socket 1:
product info: "HITACHI", "microdrive"
manfid: 0x0319, 0x0000
function: 4 (fixed disk)

and it's listed in /etc/pcmica/spectrum.conf

root@/mnt/ide3/new> cat /etc/pcmcia/spectrum.conf
device "spectrum_cs"
# class "network" module "hermes", "orinoco", "spectrum_cs"
class "spectrum" module "hermes", "orinoco", "spectrum_cs"

card "LA4100 Spectrum24 CF WLAN Card"
manfid 0x026c, 0x0001
bind "spectrum_cs"

...


My /etc/pcmcia/firmware contains now:

root@/mnt/ide3/new> ls /etc/pcmcia/firmware/
pm010102.hex rf010804.hex
root@/mnt/ide3/new>

Do I need /etc/hotplug/firmware.agent (as described here http://www.tyrannozaurus.com/?q=node/492]) ? I don't have it right now

regards

Bernd
wayne
I posted a very similar question in the openzaurus forum, here.

Hopefully, someone will have an idea that can help us both.
BerndS
Hi,

QUOTE(wayne @ Apr 21 2007, 06:57 PM)
I posted a very similar question in the openzaurus forum, here.

Hopefully, someone will have an idea that can help us both.
*


I finally found the firmware in the image files for pdaxii3. I don`t know why it`s not available separate. IMHO there`s no big difference between a distribution of the firmware in an image and a package.

The firmware worked but I had to use the orinoco drivers from the file orinoco_modules.tar.gz.

regards

Bernd
kellyharding
QUOTE(BerndS @ Apr 21 2007, 08:08 PM)
Hi,

QUOTE(wayne @ Apr 21 2007, 06:57 PM)
I posted a very similar question in the openzaurus forum, here.

Hopefully, someone will have an idea that can help us both.
*


I finally found the firmware in the image files for pdaxii3. I don`t know why it`s not available separate. IMHO there`s no big difference between a distribution of the firmware in an image and a package.

The firmware worked but I had to use the orinoco drivers from the file orinoco_modules.tar.gz.

regards

Bernd
*



You can get them using the orinoco-fw-utils package easily enough.

Kelly
ZDevil
QUOTE(wayne @ Apr 21 2007, 08:57 PM)
I posted a very similar question in the openzaurus forum, here.

Hopefully, someone will have an idea that can help us both.
*


You can get the firmware with this tool:
https://sourceforge.net/project/showfiles.p...ckage_id=162521
(Run "get_symbol_fw" and you'll get the two firmware files smile.gif )
wayne
QUOTE(ZDevil @ Apr 21 2007, 03:53 PM)
You can get the firmware with this tool:
https://sourceforge.net/project/showfiles.p...ckage_id=162521
(Run "get_symbol_fw" and you'll get the two firmware files  smile.gif )
*


Great!! Do you know where I should copy the firmware files?

I tried placing them in: /etc/pcmcia and /etc/pcmcia/cis and it's still not finding them. I guess there's a default place for the firmwares to be put, i just can't find it...
wayne
GOT IT! Found a thread in tyranozaurus forum.

I had to create /lib/firmware and then place the files there. Voila!

Thanks a MILLION, ZDevil.

I've been dying to get openzaurus working on my poodle for YEARS! All I need to do now is set up my wep key for my AP...
speculatrix
did you try and get WPA working? I had a spectrum24 (branded as socket/symbol) card long ago and gave up, was told it didn't work, needed hostap instead, but am curious if someone found a way to work.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.