Hi all,
I have taken the pain of rebuilding gcc 2.95.3 from scratch and here is now the new version:

http://www.quantum-step.com/wiki.php?page=Compiler

It is now Universal in the sense that there is a package for i386 and one for powerpc based Macs (you don't have to install both...).

Why gcc 2.95.3 and not (yet) gcc-4.1? Well, it is the "standard compiler" for Linux 2.4 which is used in SharpROM and Cacko.

And, this version includes Objective-C and even libobjc.so, so you can use this in applications as well! Please note that there is mySTEP, a Zaurus compatible implementation of the Cocoa APIs.

Happy coding!

-- hns