Help - Search - Members - Calendar
Full Version: Sticky Keys
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
BerndS
Hi,

How can I enable Stickykeys in pdaXrom 1.10beta3 without loosing other functionality?

If I enable it using the instructions from Meanies post here

http://www.oesf.org/forums/index.php?showt...ndpost&p=150095

and here

http://www.users.on.net/~hluc/myZaurus/cus...rom.html#keymap

Sticky Keys work for Shift, ctrl, and FN the way I want it. But: FN-1, FN-2, FN-3 and FN-4 does not work anymore ... FN-1 only prints 1, FN-2 prints 2 and so on


regards

Bernd
Meanie
QUOTE(BerndS @ Apr 4 2007, 05:29 AM)
Hi,

How can I enable Stickykeys in pdaXrom 1.10beta3 without loosing other functionality?

If I enable it using the instructions from Meanies post here

http://www.oesf.org/forums/index.php?showt...ndpost&p=150095

and here

http://www.users.on.net/~hluc/myZaurus/cus...rom.html#keymap

Sticky Keys work for Shift, ctrl, and FN the way I want it. But: FN-1, FN-2, FN-3 and FN-4 does not work anymore ... FN-1 only prints 1, FN-2 prints 2 and so on


regards

Bernd
*



you may want to use my updated keymap as well

http://www.users.on.net/~hluc/myZaurus/pdaxii13.html#keymap
BerndS
QUOTE(Meanie @ Apr 3 2007, 11:06 PM)
you may want to use my updated keymap as well

http://www.users.on.net/~hluc/myZaurus/pdaxii13.html#keymap
*


Mmhh. reading again your page I saw that you remapped the functions normally on FN-1, etc:

>>Some function keys have been remapped as follows:
>># Super+1 = Switch VGA mode (320x240)
>># Super+2 = Switch SVGA mode (640x480)
>># Super+3 = Decrease Brightness
>># Super+4 = Increase Brightness
>># Super+5 = Refresh

So I assume FN-1 etc does not work with your keymap also (or is Super = Fn key)?

regards

Bernd
Meanie
QUOTE(BerndS @ Apr 4 2007, 02:15 PM)
QUOTE(Meanie @ Apr 3 2007, 11:06 PM)

you may want to use my updated keymap as well

http://www.users.on.net/~hluc/myZaurus/pdaxii13.html#keymap
*


Mmhh. reading again your page I saw that you remapped the functions normally on FN-1, etc:

>>Some function keys have been remapped as follows:
>># Super+1 = Switch VGA mode (320x240)
>># Super+2 = Switch SVGA mode (640x480)
>># Super+3 = Decrease Brightness
>># Super+4 = Increase Brightness
>># Super+5 = Refresh

So I assume FN-1 etc does not work with your keymap also (or is Super = Fn key)?

regards

Bernd
*



Fn+num keys are disabled if you have kbd option in the X server options which is required if you want to enable stickykeys...
Jon_J
QUOTE(Meanie @ Apr 4 2007, 02:02 AM)
QUOTE(BerndS @ Apr 4 2007, 02:15 PM)
QUOTE(Meanie @ Apr 3 2007, 11:06 PM)

you may want to use my updated keymap as well

http://www.users.on.net/~hluc/myZaurus/pdaxii13.html#keymap
*


Mmhh. reading again your page I saw that you remapped the functions normally on FN-1, etc:

>>Some function keys have been remapped as follows:
>># Super+1 = Switch VGA mode (320x240)
>># Super+2 = Switch SVGA mode (640x480)
>># Super+3 = Decrease Brightness
>># Super+4 = Increase Brightness
>># Super+5 = Refresh

So I assume FN-1 etc does not work with your keymap also (or is Super = Fn key)?

regards

Bernd
*



Fn+num keys are disabled if you have kbd option in the X server options which is required if you want to enable stickykeys...
*


Is this what is causing this key behavior in dosbox?
http://www.oesf.org/forums/index.php?showt...ndpost&p=156955

BTW, I have "sticky keys" switched off in pdaxii13.config
BerndS
Hi,

QUOTE(Meanie @ Apr 4 2007, 07:02 AM)
Fn+num keys are disabled if you have kbd option in the X server options which is required if you want to enable stickykeys...
*


Not nice, but anyway I need sticky keys so I enabled them and assigend the functions to change the display brightness to Super -<key>.

Next problem:

How to I configure FN-Tab to toggle Capslock?

With

! modifier keys
clear Lock
remove Lock = Tab
! add Lock = Caps_Lock
keycode 73 = Tab Tab Caps_Lock Caps_Lock

in the file /etc/X11/kb/akita.xmodmap it does not work and if I add

add Lock = Caps_Lock

Tab *always* triggers CapsLock (regardless if I press TAB, FN-TAB, CNTRL-TAB, or SHIFT-TAB)

Do I have to change the file /etc/sysconfig/keyboard/kernel.map?

Now it looks like

keycode 65 = Tab
alt keycode 65 = Caps_Lock
shift keycode 65 = Caps_Lock
control keycode 65 = Caps_Lock
keycode 27 = Shift
keycode 89 = Alt
keycode 88 = Control
keycode 112 = Shift


regards

Bernd
BerndS
Hi Meanie,

QUOTE(Meanie @ Apr 4 2007, 07:02 AM)
Fn+num keys are disabled if you have kbd option in the X server options which is required if you want to enable stickykeys...


I found a solution to have both Sticky Keys and Fn+num!

For those that are interested in sticky keys and FN-1 .. FN-4 the workaround to use both is:

I used the instructions from Meanie to enable sticky keys.

To enable Fn-1 to Fn-4 again after enabling sticky keys I made the
following changes:


In /etc/X11/kb/akita.xmodmap I changed the lines for the keys 1 to 4 to

keycode 49 = 1 exclam F13 F1
keycode 50 = 2 quotedbl F14 F2
keycode 51 = 3 numbersign F15 F3
keycode 52 = 4 dollar F16 F4

and in /home/root/.config/openbox/rc.xml I added

<keybind key="F13">
<action name="Execute"><execute>xrandr -s 0</execute></action>
</keybind>

<keybind key="F14">
<action name="Execute"><execute>xrandr -s 1</execute></action>
</keybind>

<keybind key="F15">
<action name="Execute"><execute>setfl-wrapper</execute></action>
</keybind>

<keybind key="F16">
<action name="Execute"><execute>setfl +</execute></action>
</keybind>

Restarted X and voila - sticky keys and Fn-num works

I did only minor tests until now to but it seems to work.

Now if I get Fn-Tab for Capslock to work all my keyboard issues are solved.

(Note: setfl-wrapper is a script from weeXpc to ensure, that you can't switch off the screen using Fn-num)

regards

Bernd
daniel3000
Hi Bernd,

Thank you for that tutorial!

Are you aware that accessx seems to have an equivalent to Caps lock built-in?
If you hit the Shift key twice, all following keys are shifted, until you press shift once more. So maybe you don't need Caps lock at all on Tab?


A question:

I tried to follow Meanie's and your instructions, but the Fn-Num keys don't work here.
This is what I did. maybe I missed something important?

1. ipkg install accessx_0.951_armv5tel.ipk

2. in /usr/X11R6/bin/startx change defaultserverargs to " +kb +accessx -screen 480x640@270"

3. Put "ax +stickykeys -stickytwokeydisable -timeout" into ~/.matchbox/autoexec (so the tasks applet will execute this when it is started)

4. chmod +x ~/.matchbox/autoexec

5. changed akita.xmodmap for F13..F16 support as Bernd described (no other changes done to this file, coming from the weeXpc default file - may this be the problem?)

6. added ~/.config/openbox/rc.xml for F13..F16 support

Result:
Sticky keys work great, but Fn-Num don't have effect.



(Alternatively I tried for step 6 this:
No ~/.config/openbox/rc.xml, but instead changed the Mod2-1 etc. entries in the /etc/xdg/openbox/rc.xml to F13 etc. But that had an even funnier effect:
Hitting the numbers without any modifier changed the brightness. With Fn they had no special effect. )

Strange. Something must be different here than in your configuration.

Do you know what?

Thanks
daniel
BerndS
Hi Daniel,

QUOTE(daniel3000 @ Apr 11 2007, 09:37 AM)
Hi Bernd,

Thank you for that tutorial!

Are you aware that accessx seems to have an equivalent to Caps lock built-in?
If you hit the Shift key twice, all following keys are shifted, until you press shift once more. So maybe you don't need Caps lock at all on Tab?


No, I was not aware of this feature. But now I know why I had CapsLock on while testing without knowing why smile.gif

Do you know where to get the docs for accessx?


QUOTE
A question:

I tried to follow Meanie's and your instructions, but the Fn-Num keys don't work here.
...
(Alternatively I tried for step 6 this:
No ~/.config/openbox/rc.xml, but instead changed the Mod2-1 etc. entries in the /etc/xdg/openbox/rc.xml to F13 etc. But that had an even funnier effect:
Hitting the numbers without any modifier changed the brightness. With Fn they had no special effect. )


Strange, I now have the same effect . I'm sure yesterday evening it worked. The only difference is that there were some suspend/resume cycles between yesterday and today.

I'll have to do more tests.

regards

Bernd
daniel3000
Hi Bernd,


QUOTE(BerndS @ Apr 11 2007, 08:53 PM)
No, I was not aware of this feature. But now I know why I had CapsLock on while testing without knowing why  smile.gif

Do you know where to get the docs for accessx?


No, I have no idea.


QUOTE
Strange, I now have the same effect . I'm sure yesterday evening it worked. The only difference is that there were some suspend/resume cycles between yesterday and today.

I'll have to do more tests.
*


Resume / suspend, being a very special and Zaurus-specific thing, has caused a lot of trouble in the past. I think there were some more issues affecting keyboard functionality, which had to do with suspend/resume.


I hope you will find a way.

daniel
Meanie
QUOTE(BerndS @ Apr 11 2007, 07:34 AM)
Hi Meanie,

QUOTE(Meanie @ Apr 4 2007, 07:02 AM)
Fn+num keys are disabled if you have kbd option in the X server options which is required if you want to enable stickykeys...


I found a solution to have both Sticky Keys and Fn+num!

For those that are interested in sticky keys and FN-1 .. FN-4 the workaround to use both is:

I used the instructions from Meanie to enable sticky keys.

To enable Fn-1 to Fn-4 again after enabling sticky keys I made the
following changes:


In /etc/X11/kb/akita.xmodmap I changed the lines for the keys 1 to 4 to

keycode 49 = 1 exclam F13 F1
keycode 50 = 2 quotedbl F14 F2
keycode 51 = 3 numbersign F15 F3
keycode 52 = 4 dollar F16 F4

and in /home/root/.config/openbox/rc.xml I added

<keybind key="F13">
<action name="Execute"><execute>xrandr -s 0</execute></action>
</keybind>

<keybind key="F14">
<action name="Execute"><execute>xrandr -s 1</execute></action>
</keybind>

<keybind key="F15">
<action name="Execute"><execute>setfl-wrapper</execute></action>
</keybind>

<keybind key="F16">
<action name="Execute"><execute>setfl +</execute></action>
</keybind>

Restarted X and voila - sticky keys and Fn-num works

I did only minor tests until now to but it seems to work.

Now if I get Fn-Tab for Capslock to work all my keyboard issues are solved.

(Note: setfl-wrapper is a script from weeXpc to ensure, that you can't switch off the screen using Fn-num)

regards

Bernd
*



I doubt this will work because of the way the X server keymapping is done. However, I tried it anyway and gotten the same results as Daniel.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2015 Invision Power Services, Inc.