Help - Search - Members - Calendar
Full Version: Cf Card
OESF Forums > General Forums > General Support and Discussion > Accessories
baptista
Hi people: Iīm working with my collie with a 500Mb card type II. Now for a mistake I received a card type I with 1 GB. Any problem to read the data and transfer it for ancient to new card?.
Thanks for any help
baptista
Capn_Fish
There should be no issue with transfering the data.
baptista
Thankyou for the help Capn_Fish, but I canīt eject the CF via applet or terminal: umount /mnt/cf, what is wrong?. Excuse me the little aknowlegment, thanks again.
baptista
InSearchOf
Maybe an application is using it...

Late
Antikx
What is it saying when you try to eject the card via terminal?
baptista
Iīm saying that I umount it from terminal and them would be possivel to eject it via aplet. Is it correct? Thanks for the help
baptista
baptista
Thanks to everybody that try to help me. At last I meet the way. I suspend the collie, push out the CF card II copy it to CF card type I via a memory reader writer and insert CF type I to the machine, that all. The only thing is that this type of card is not detected by the applet, so it is not necessary to eject it (I think so...). Nevertheles everything is functioning OK.
baptista
sdjf
I am very suspicious about your having to suspend collie to eject card.. I believe the correct command to enter is:

umount /dev/hda1

are you sure the card is not corrupt? I wrote a bunch about this in my blog, about a card I ended up returning, at

http://sdjf.wordpress.com/tag/cf-card-issues

Maybe it isn't relevant, as I don't know about the type I, type II CF card issue.

But, here's the info, in case it might help someone. It turned out wordpress had not accepted most of my final post on the issue, but I have now edited out the binary and anyone who saw it before, the conclusion is now truly on the web.

sdjf

EDIT: I checked on card types, and that seems to just be a matter of physical thickness of the card itself. If it fits properly into the slot, it shouldn't matter.
sdjf
BTW, if your umount command is successful, the CF card applet will show that it has been ejected...you do not have to do both.

If something is hanging on to the Card, then ideally one should shut down or kill that process to keep from damaging any data, just to be on the safe side.

And actually, I would use "cardctl eject" instead, since you really did want to eject the card once you were done with transferring the data off of it to internal memory or SD card.

My two cents worth...for future reference. wink.gif
sdjf
sdjf
Here's some more info in case none of the commands work.

First, some questions. What is on the card? And what happens when you can't get it to eject? Post a cut/paste of what you enter and see in the console.

Another thing to do is run "ps ax | more" to get a full list of everything that is running. Do you see anything that might be holding on to the card? If you are not sure, then paste the output here.

Can't help much more without seeing some output.
sdjf
sdjf
Another thing you may need to do to get control of the CF card ejection, is to use some qcop commands.

An easy way to test if you need to upgrade to qcop2 is run the following.

qcop QPE/Application/clock 'raise()'

If the clock raises (appears), you are okay. If it does not, then get information about upgrading your qcop at my qcop page:

http://www.sdjf.esmartdesign.com/ipks/qcop.html

sdjf
baptista
Thankyou very much sdjf for your interest in help me, I have in the card some programs, a lot of books in pdf, gzip and hamcomword. Many musics and some films(clips).
The command about qcop functions, the clock appear!
The first command you send to me answer a lot of things that if I have time enough, iīll send to you today or tomorrow, I think that some of them make reference to the card but Iīm not sure now.
Now we (I..) are very near of a solution.
It happens the same thing with the SD card, that has 256 MB (SD), but it is not so necessary to eject, because the CF card I need to eject it to put a modem card or a WiFi card.
Regards from
baptista
sdjf
You are welcome. That's what oesf is all about, helping each other. wink.gif

I think you will find the output of 'ps ax|more' interesting, and it is good to hear that your qcop command functions well. I piped the output through more because that way the lines of the display will not get cut off and you can see more information.

If you close all programs that use the SD card which show in the list, it should eject without a problem. But if you have programs installed using the GUI installer, onto the SD card, you can't eject it without uninstalling them! That is why I install everything to internal memory, and then move the program binaries to the SD card afterwards. Then I make symlinks to them from the first directory in my path, /home/QtPalmtop/bin. But I leave the console in internal memory so I can always use it, no matter what.

Oh, I suggest you post the output here instead of sending it to me personally, so everyone else can help or learn also.

Cheers,
sdjf
baptista
Hi sdjf, here goes the answer of the console to the command you said:


PID TTY STAT TIME COMMAND
1 ? S 0:03 init
2 ? SW 0:04 [keventd]
3 ? DW 0:00 [swapper]
4 ? DW 0:00 [swapper]
5 ? SW 0:00 [swapper]
6 ? SW 73:42 [kapm-idled] 7 ? SWN 0:00 [ksoftirqd_CPU0]
8 ? SW 5:04 [kswapd]
9 ? SW 0:00 [bdflush]
10 ? SW 0:25 [kupdated]
11 ? DW 0:00 [swapper]
12 ? SW 0:29 [mtdblockd] 96 ? S 0:00 /sbin/sdmgr 130 ? S 0:06 /sbin/cardmgr
149 ? S 0:00 /usr/sbin/inetd
159 ? S 0:00 /usr/sbin/rpc.portmap
169 ? S 0:00 /home/QtPalmtop/bin/atd /var/spool/at
206 ? S 0:48 /usr/local/bin/tssimd
208 ? S 0:54 /sbin/shsync 367 ? SN 0:00 /usr/local/bin/fbvncserver -double -rfbauth /home/zau
437 ? S 0:00 /sbin/launch 438 ? S 0:00 /bin/sh ./qpe.sh
1188 ? SN 1:25 qpe -owner zaurus.qpe
1189 ? SN 0:00 qeserver zaurus qpe
1191 ? SN 0:02 qeserver zaurus qpe
1220 ? SN 0:00 addressbook -qcop /tmp/qcop-msg-addressbook
1221 ? SN 0:00 todolist -qcop /tmp/qcop-msg-todolist
1222 ? SN 0:00 qtmail -qcop /tmp/qcop-msg-qtmail
1223 ? SN 1:51 stageone -qcop /tmp/qcop-msg-stageone
1224 ? SN 0:55 kopi -qcop /tmp/qcop-msg-kopi
1225 ? SN 0:26 kapi -qcop /tmp/qcop-msg-kapi
1226 ? SN 0:00 datebook -qcop /tmp/qcop-msg-datebook
1229 ? SN 0:50 launcher -qcop /tmp/qcop-msg-launcher
1230 ? SN 0:07 qeserver zaurus qpe
1231 ? SN 0:06 qeserver zaurus qpe
1232 ? SN 0:05 qeserver zaurus qpe
1233 ? SN 0:57 qeserver zaurus qpe
1718 ? SN 0:02 embeddedkonsole -qcop /tmp/qcop-msg-embeddedkonsole 1719 ttya0 SN 0:00 /bin/bash
1720 ttya0 RN 0:00 ps ax
1721 ttya0 SN 0:00 more

When I try to eject the CF card with thw collie on the response is:
(Eject card 0: ATA/IDE FixedDisk) :
CF/PMCIA ejct failed
(Ejecting SD-card):
Failed to eject the card. Please eject the card after you close all applications and turn off the Zaurus.
In fact I have installed KOPI/KAPI in the SD but also in the file browser appear files of it in the /home/zaurus.
Why would not be the samething for ejecting CF card?

Excuse me if i spoke many things wrong.... Well now I wait your evr kind response, and would like to have some explication abou all this, if you have patience.
Greatfully
baptista
sdjf
Let's talk about one card at a time, to keep from getting confused. Let's focus on the CF card as that is the most urgent.

I want to see the command you entered, not just the output.

Also, are any of these programs ones that are looking at files on the CF card? Forgive me, I do not know what some of those apps are in your list. I also do not know if it is a CF data card or a CF modem card that you are trying to eject. What to do depends on which.

What please, are stageone, kopi, and kapi?
sdjf
sdjf
Also, if your file browser is open, you may be unable to eject the CF data card because the file browser/manager will be accessing it's files.

I'm not sure about this, I think I have been able to eject cards when file manager is open, but you are having so much trouble that I think you should close all apps you can before trying to eject, so we can track down the problem(s) more easily.

Awaiting more data. wink.gif

sdjf

NOTE: original post said "able", I meant unable and have corrected the typo.
baptista
Hi sdj: Ok it is also many things for me..but in April 30 you said:

"Another thing to do is run "ps ax | more" to get a full list of everything that is running. Do you see anything that might be holding on to the card? If you are not sure, then paste the output here."

Stageone is a program type iqnotes, kapi and kopi are programs for pim data,installed on SF card so I have it duplicated, and are more efficient than the zaurus one,( zautrix) is the name of the developper.

With the file manager open I canīt eject the card.

sdj, excuse me, but in all this time iīm speaking about CF data card. Everything began when you said that Type I or II is a matter of thickness, and really I could copy all the data of the ancient card type II with 500Mb to this one that we are speaking of 1GB. My ROM is 3.13
Iīll hope that you will not worry with me....and many thanks for everythings that Iīm learning.

My best regards
baptista
sdjf
Okay, first close the file manager.

Second, try to eject the CF card from the GUI, the one that is at an angle, not the one that says SD on it. You do that by pressing hard where it says "Eject card". Then wait a few seconds and run your stylus over your screen...you will be able to tell (I hope) if your z is frozen while it detaches the files, or it is ignoring the request. Also write down everything that happens and report it in detail, and make another "ps ax|more" again just before this in case anything changed.

Third, if that didn't work, from your console, enter "carctl ident; cardctl status; cardctl eject" and post the command(s) you entered and the results.

sdjf
sdjf
OMG, another thing. Do:

cat /var/lock/LCK..ttyS3

If there is a lock file there (which there should not be, then do

rm /var/lock/LCK..ttyS3
sdjf
Also, you mentioned both modem and wifi cards. Do you have both? What do you use to connect to the web or a network? IRDA, dialup, or what?

If you use Opera browser at all, it could make trouble with ejecting the CF card too, so that's why I ask. I'm interested if you found a lock file. Lock files are usually only placed on ttyS3 by networking programs or programs that use the internet such as Opera.

sdjf
sdjf
Oh no, wait, I just noticed you said you installed kapi and kopi on SF card. Is that the "CF" card or the "SD" card? If it is the CF card, you must uninstall them if you wish to eject your CF card.

Which card are they installed on? Is anything installed to the CF card using the GUI Installer? I hope not!

I know it can get confusing. I understand if you use "ipkg" from commandline instead of the GUI Installer (however you invoked it doesn't matter, what matters is that it is the qtopia GUI one), that ejecting the card an app is installed to is okay if you did not use the GUI to install it, but do you remember how you installed the apps?

sdjf
baptista
Hi sdjf: Somethings more: The modem car( Targus ) is for receiving mails from a fone line , the WiFi card (D-link Air, DCF 660 W,Wireless Compact Flash 802.11b) is for connecting to the web in places where are wifi signal, them I need to know the Wep key in the networking configuration. I have used the two ones without problems.
And now the most foolish thing: I observed that the new CF data card 1Gb about we are speaking, appears ( I donīt remember if I said to you) in the collie as
CODE
card 0/pmcia: ATA/IDE  Fixed Disk)
the pmcia is a card por notebooks. So I decided with the collie off change the new for the older CF card, put the collie on and the machine begins to function normally, of course without the new books and other things I that charged in tis mid time. Them I try to eject the card via applet, and was ejected without problem!, them I entered the new card that was recgnized as card 0: ATA/IDE Fixe4d Disk, That is the
CODE
pmcia not appearing
and begin to use it normally, everything were there and made the test of eject it many times. I donīt no why....may you understand?...
Thankyou for you help, and wait for anything you want to say me.
My best regards
baptista
sdjf
My best guess is that something was open on the old card and since you changed card with the collie asleep originally, when you put back the card that the collie expected, it allowed it to figure out how to close that file and let go of the card. When things are functioning normally, I would never yank out a card that the applet does not work correctly with because later on there can be problems. So next time there is such a problem, I hope we can talk and figure out how to "cleanly" correct the problem before more things are done that make it impossible to figure out what the true source of the problem is.

I do want to check something now, though, for future reference. Do you use the Sharp Serial I/O Port at the bottom of your Collie for anything at all? If you do not use it at all, you may be able to benefit from halting respawning of ttyS0, which keeps that tty open all the time. See my writeup on this:

http://www.sdjf.esmartdesign.com/respawn.html

hth,
sdjf
baptista
Hi sdjf: Thans again and again, with your link you open to me a new world of possibilities for a newbie. Iīm going out this weekend. At my return i`ll read all your site, I just begin now. Iīll be in contact with you.
In fact I use yhe I/O port for making syncronization with my notebook (windows xp).
Let me ask you why you did not have the last zaurus ROM 3.13?
Cheers
baptista
sdjf
QUOTE(baptista)
Let me ask you why you did not have
  the last zaurus ROM 3.13?


Too much time and energy with no guaranteed results, for one reason. For more reasons, read what I wrote at http://sdjf.wordpress.com/life

If you use that port all the time, you do not want to stop respawning. If it's just occasionally, you could experiment with changing the respawning and see if it really matters.

I could not get card ejection under control until I stopped the respawning, but I also do not have any current use for that port, either.

I'm busy too. Have a good weekend.

sdjf
baptista
Hi sdj: I return from my "weekend" that its a kind o work that I make some months helping in some way to others, as you do, not properly nothing to do.
Iīm surprise reading the link you send, and I thank you once more for your help that will not end here, I hope. I begin to study your site, and certainly I must have many things to ask about zaurus.
Thankyou once more, and excuse my poor english..
My best regards from
baptista
sdjf
You're welcome again. I know a little Spanish, and your English is much better than my Spanish. smile.gif

I am very interested in seeing what happens the next time you need to eject a card. I also want to know what you think about respawning since you use ttyS0 for connecting to your Windows box.

take care,
sdjf
baptista
Hi sdjf,
thanks by the mail you posted to me, I answer by the Forums site as you like,
I have many things to learn, so I entered many times in your site. The time here in São Paulo (Brazil) now 14 of may 2007 is 4h 25m PM, when Iīm posting this mail.
You must to explain me what is respawn ( more or less I can imagine ) but is better to hear from you. Also woul like to know what is an IRC client....if it is better to go to tyranozaurus site explain me better. You see how newbie I am..at least in Zaurus.
Another thing, really you were with all the reason in everything you said to me. Now not ever I can eject the CF card. When I can the collie recognize the Targus as a serial or modem card. But it now donīt function. I set the modem with the same conditions I have in the account of my provider. I suppose that it where funtioning when I had the ancient ROM, then of course I took various mails.
Really I donīt use the collie ever for mails, the normal is to use the desktop at home. But would like to have it ok for if I travel or so. The WiFi card that I said to you is functioning, I prove it in a WiFi point, nevertheless it is no easy the navigation with the opera, and the battery goes on rapidly. I have for this cases an battery extender.
I remember you say to me somethings about tty. May you repeat it for me if you donīt bore too much. Of course I will make a review of all your mails, till now.
Excuse me for take many of your time.
Cheers from
baptista
sdjf
Can we just focus on one problem at a time? It get's too confusing otherwise. Which problem is the most important?

About IRC, you can download an IRC client (internet relay chat) or go to chat with the link at http://tyrannozaurus.com, and that may be easier for you.

I need to know which question is most important, and then we can work on that one.

It's too confusing for me to try to fix all the problems at once.
sdjf
sdjf
Well, I will comment on your respawning question. See this document here at oesf: http://www.oesf.org/index.php?title=Serial...ial_port_access

From what they say there, maybe respawning does not make any difference on 3.10. Remember I have 2.38, and they work a little differently. I will ask my friend who has a 3.1 if he has stopped respawning. I don't know if it is wise for you.

To respawn the connection means, in simple terms, it just keeps starting up again if you try to stop it. I know on my ROM the ttyS0 (I/O port) respawning creates difficulties for ttyS3 (CF slot), but I don't know about your rom for this issue.

I will ask my friend for advice since no one else has jumped in here yet.
sdjf
baptista
Hi sdjf
Thanks for your answer.
I know that I have a long way to go (as the song...) I income in tyranozaurus.com but still donīt have the password they promise...
I would like, in order, to know:
How can I eject the CF card when the applet do not permit.
Why my Targus modem card donīt function now, how to set it
Many other things Iīll go to learn as the time is going, thanks to your patience and the ways you are opening to me.
As a joke: in Brazil the language is portuguese not spanish but really my first language is Spanish...
So long!
Regards from your friend
baptista

PS What is the difference in our time?
sdjf
I said one question. We can't solve them both at the same time.

Please be patient, and wait for the next instructions before doing something that might make things worse.

1. I need to know what you have in your CF slot right now, and whether you have your Z attached to your PC now.

2. Run the following tests for me, and copy everything that appears on your screen, including the commands you entered, into a file and post it all here:

cardctl ident
cardctl status

cat /var/lock/LCK..ttyS3

for i in `find /proc -name fd 2>/dev/null`;do p=${i%%/fd} ;q=`basename $p`;cmd=`cat $p/cmdline 2>/dev/null`; ls -l $i 2>/dev/null | grep tty | sed "s|^l.*>|$q $cmd:|" ;done
(there are 4 commands to enter. the final one must be on one long line, starting with "for" and ending with "done"
3. Don't do anything else to the CF card until I see what the output is and can study the situation. I'm sorry I can't solve it all at once, but if I can't see that output, I can't tell you what I would do. And if you take the card out somehow, the situation will change and I will need answers to all of the above all over again. We have to study your problem carefully IMO if we are going to solve it or them in a way you can depend on, instead of always guessing.

I'll check back in a few hours. I'm running behind today.

sdjf
sdjf
Any time you cannot eject a card using the GUI, that means that something is holding on to the card. The Zaurus thinks the card is in use and will not let you take it out because of that.

That can happen no matter what kind of CF card is in the slot, but what you can do about it depends on whether it is a data card or a network device, and on the exact nature of the hold it has to the card.

That's why we need to study the situation, to decide why and make an appropriate plan of action. wink.gif

sdjf

p.s. 2-4 hours difference, I'm not sure. this is GMT -700. I can go to chat evening time here, but usually not before 8 or 9 pm. my time, and that's very late for you. I am usually too busy for chat earlier in the evening.
baptista
Hi sdjf:Once thanks,Iīm pasting here the answer to the things you asked me in the prior mail.

Opening the documents tab for CF there are 5 folders: Applications,Documents, local, QtPalmtop, Screen files.It has also some books in PDF, musics,and 2 backups I ever have, also appears a file(journal) belonging to Kopi and 2 icons of text Editor:my calendar and std (belonging to Kapi, that is addresses), as I said to you the Kopi and Kapi where installed in the SD card, so I think that this are older files
The folder Applications is empty
The folder Documents have the following folders: Applications,Audio,Chemical,Install_files,Image,Textfiles,Text, have also some files about theSharp Motion Art.

The folder Application have the folders: Excel, Hancomword, Ipkg, msword,octet-stream, portabase, rtf, x-gzip, x-htest, x-msdos-programs.

If you want I can send everythings is on each folder, but you can suppose that is a long list perhaps not interesting for you.

I think is interesting the folder chemical, it was created by a book that a friend of mine send by IRDA ,from their PalmTreo content a file in pdb not possible to open.

Think that you want to know the folder QtPalmtop: it has this others folders:apps, help, pics, bdicty, i-ching, pics 144, bin, i18n, plugins, demo, java, qtmail, dtm, lib, share, etc, man.

About the commands:
Cardctl ident:
Response: Socket0:
Product info: “SanDisk”, “SDP”, “5/3 0,6”
Manfid: 0x0045, 0x0401
Function: 4 (fixed disk)
Socket 1:
No product info available

Cardctl status
Response: Socket 0:
3,3 V 16 bit PC Card
Function 0: (ready), (bat dead), (bat low)
Socket 1:
No card

cat/var/lock/LCK...ttyS3
Response: no such file or directory

About the long command that I repeat many times
Response
>

Excuse me if I delay a little, Iīm learning as never. I passed the hole yesterday working in this

Best regards
baptista
sdjf
So, is the problem now that you cannot eject the CF data card?

I am wondering what is holding on to the card. I must see the complete output of "ps ax". I am suspicious that kopi/kapi is using that journal file [EDIT:], and whatever other kopi/kapi files are on your CF card. Can you exit from kopi/kapi (whichever that was) and then try to use the icon to eject the card.

Also, whether or not the card will eject now, I recommend that you install the "lsof" command if you do not have it.

You can see if you have it by entering the "type" command:

bash-2.05# type lsof
lsof is /usr/bin/lsof
bash-2.05#

If you do not have it, the output will be:

bash: type: lsof: not found

You can find information about "lsof" at:

http://www.sdjf.esmartdesign.com/ipks/lsof.html
sdjf
I ran out of lines to type on. wink.gif

I need to see "ps ax" run just before you try to eject the card. That will contain the names of any applications that are holding on to it.

Even though kopi/kapi is installed to your SD card, if there is kopi/kapi file on the CF card, kopi/kapi will be reading that file and not let you eject the card.

you have several possible solutions. You can close kopi/kapi (and have to anyhow, I think). Then if you want to prevent the same problem in the future, you should either delete that file or move it to the SD card.

Do you know how to do that? There are many ways and I'm hoping you know how so I don't have to explain.

Will kopi/kapi let you move or delete the file from inside the application before you exit? I think that is the most preferred way.

take care,
sdjf
baptista
Hi sdjf:
I donīt have lsof, will see your site. What means "ps ax"?
Tomorrow will delete the file journal, and will write again
Regards from
baptista
sdjf
QUOTE(baptista @ May 16 2007, 01:33 PM)
Hi sdjf:
I donīt have lsof, will see your site. What means "ps ax"?
Tomorrow will delete the file journal, and  will write again
Regards from
baptista
*

"ps ax" is the command you gave me the output from in post #14 in this current thread on page 1. I tried to put the url in but the board wouldn't accept it. Anyhow, it's just a command:
bash-2.05# ps ax

I have less time for the next 3 days but I'll try to check back at least once or twice each day.

You don't have to post the results of "ps ax" unless the card still does not eject after removing all kopi/kapi files from the CF card.

sdjf
baptista
Hi sdjf:
As ever till now you had the reason...well I deleted the 2 famous files relationed with kopi and kapi, and everything is going ok. Also I installed the lsof command and chek the CF card, nothing open. Excuse me how many headache i gave to you, but I learned many things.
Now donīt strange the fact that I visit your site frequently for learning more.

Again a thing more, the question of modem card, as I said to you is a Pocket modem card 56K V.90 brand TARGUS In the userīs Guide they say that work with Windows CE and Pocket PC. In fact I use it, perhaps with 2.38 ROM, I donīt remember, and receive many mails. Iīll try to use again now changing the settings of the modem, now are ATDT.

You said to me that only use the collie for everythings, and what happens with the battery?

Hope you had time enough for solving your questions. Nevertheless I feel that I win a friend in USA,would like to know the city.Anything that you want from São Paulo, Brazil, take me in account.
My best regards from your friend
baptista
sdjf
If the modem worked on 2.38, I'm sure you can get it to work on 3.13, but it may be difficult because you also want to be able to sync to your windows box. Again, you ask so many questions, I am needing to focus on just one.

I think the modem is the next important thing. But I need to know the current status of your collie, and what goes wrong, and get all the same information all over again before and after you try the modem.

But one more thing. If it is your dialup modem, I also need to see the output of an "cat /tmp/qpe-pppd-log" to figure out what is wrong. But also all the other answers I will need again as well so that we can study the situation.

take care,
sdjf
baptista
Hi sdjf:
I think everythyng is ok with the collie now.
The response of the terminal to the command you said is
"no such file or directorie"
Regards
baptista
sdjf
Here is a tip for you and anyone else who posts output from a command.

IMNSHO, it is very helpful and important to show exactly what the command you entered is, as well as the results. It makes debugging a lot easier for those of us trying to problem solve with you.

So, although I can guess what command you entered to get "no such file or directory", I cannot be sure, and if you made a typo in entering the command (and we all do sometimes wink.gif ), the readers have no way to determine that.

So Please, next time, make your output something more like:

bash-2.05# cat myfile
cat: myfile: No such file or directory
bash-2.05#

Your collie is fine now, but I have a hunch you may have trouble with it a couple times after the next time you use Opera, so be prepared to post all the output I've asked for before, the next time there is a problem with your WIFI or modem (if there is one).

Have a good weekend,
sdjf
baptista
Hi sdjf:
Excuse me again, I don't make well the things as you say, I don't leave a space between the cat and the following commands. Well I do

bash-2.05$ cat /tmp/qpe-pppd-log
May 18 18:53:50 localhost pppd[2274]: pppd 2.4.0 started by root, uid 0
May 18 18:53:51 localhost chat[2276]: abort on (NO CARRIER)
May 18 18:53:51 localhost chat[2276]: abort on (NO DIALTONE)
May 18 18:53:51 localhost chat[2276]: abort on (BUSY)
May 18 18:53:51 localhost chat[2276]: send (ATZ^M)
May 18 18:53:51 localhost chat[2276]: expect (OK)
May 18 18:53:51 localhost chat[2276]: ATZ^M^M
May 18 18:53:51 localhost chat[2276]: OK
May 18 18:53:51 localhost chat[2276]:
-- got it
May 18 18:53:51 localhost chat[2276]: send (ATZG^M)
May 18 18:53:51 localhost chat[2276]: expect (OK)
May 18 18:53:51 localhost chat[2276]: ^M
May 18 18:53:51 localhost chat[2276]: ATZG^M^M
May 18 18:53:51 localhost chat[2276]: OK
May 18 18:53:51 localhost chat[2276]:
-- got it
May 18 18:53:51 localhost chat[2276]: send (ATDT9,30095007^M)
May 18 18:53:51 localhost chat[2276]: expect (CONNECT)
May 18 18:53:51 localhost chat[2276]: ^M
May 18 18:54:22 localhost chat[2276]: ATDT9,30095007^M^M
May 18 18:54:22 localhost chat[2276]: CONNECT
May 18 18:54:22 localhost chat[2276]:
-- got it
May 18 18:54:22 localhost pppd[2274]: Serial connection established.
May 18 18:54:22 localhost pppd[2274]: using channel 9
May 18 18:54:22 localhost pppd[2274]: Using interface ppp0
May 18 18:54:22 localhost pppd[2274]: Connect: ppp0 <--> /dev/ttyS3
May 18 18:54:41 localhost pppd[2274]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x7f5589f8> <pcomp> <accomp>]
May 18 18:54:41 localhost pppd[2274]: Timeout 0x20084bc:0x203b440 in 3 seconds.
May 18 18:54:44 localhost pppd[2274]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x7f5589f8> <pcomp> <accomp>]
May 18 18:54:44 localhost pppd[2274]: Timeout 0x20084bc:0x203b440 in 3 seconds.
May 18 18:54:47 localhost pppd[2274]: rcvd [LCP ConfReq id=0x1 < 00 04 00 00> <mru 1100> <asyncmap 0xa0000> <auth pap> <pcomp> <accomp> <mrru 1100> <endpoint [MAC:00:d0:52:03:b7:c8]>]
May 18 18:54:47 localhost pppd[2274]: lcp_reqci: rcvd unknown option 0
May 18 18:54:47 localhost pppd[2274]: lcp_reqci: returning CONFREJ.
May 18 18:54:47 localhost pppd[2274]: sent [LCP ConfRej id=0x1 < 00 04 00 00> <mrru 1100>]
May 18 18:54:47 localhost pppd[2274]: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x7f5589f8> <pcomp> <accomp>]
May 18 18:54:47 localhost pppd[2274]: rcvd [LCP ConfReq id=0x2 <mru 1100> <asyncmap 0xa0000> <auth pap> <pcomp> <accomp> <endpoint [MAC:00:d0:52:03:b7:c8]>]May 18 18:54:47 localhost pppd[2274]: lcp_reqci: returning CONFACK.
May 18 18:54:47 localhost pppd[2274]: sent [LCP ConfAck id=0x2 <mru 1100> <asyncmap 0xa0000> <auth pap> <pcomp> <accomp> <endpoint [MAC:00:d0:52:03:b7:c8]>]May 18 18:54:47 localhost pppd[2274]: Untimeout 0x20084bc:0x203b440.
May 18 18:54:47 localhost pppd[2274]: sent [PAP AuthReq id=0x1 user="f.burgos" password=<hidden>]
May 18 18:54:47 localhost pppd[2274]: Timeout 0x200ebbc:0x203b6e0 in 3 seconds.
May 18 18:54:47 localhost pppd[2274]: rcvd [PAP AuthNak id=0x1 ""]
May 18 18:54:47 localhost pppd[2274]: PAP authentication failed
May 18 18:54:47 localhost pppd[2274]: sent [LCP TermReq id=0x2 "Failed to authenticate ourselves to peer"]
May 18 18:54:47 localhost pppd[2274]: Timeout 0x20084bc:0x203b440 in 3 seconds.
May 18 18:54:47 localhost pppd[2274]: rcvd [LCP TermAck id=0x2]
May 18 18:54:47 localhost pppd[2274]: Untimeout 0x20084bc:0x203b440.
May 18 18:54:47 localhost pppd[2274]: Connection terminated.
May 18 18:54:48 localhost pppd[2274]: Exit.

As you can see I'll try by myself to connect via modem card.....I beg your pardon, still don't know how to set the modem. Well I think is better no speak more...wait your words. But it is interesting to know that I don't sync the mails wit windows box.

My best regards
baptista
sdjf
[QUOTE=baptista] As you can see I'll try by myself to connect via modem card.....I beg your pardon, still don't know how to set the modem. [/QUOTE=baptista]

Hmmm. Didn't you say that you have used the modem before with this ROM? It sounds like it didn't like your password. Did you use the Internet Wizard GUI to set it up? Are you sure you have your login ID and password correct?

I sometimes have this kind of Authentication problem when not enough time is allowed, but I don't see any timeouts. Also, sometimes there is a problem at the ISP end, or once they didn't get my payment. Did you pay your bill on time? wink.gif

[QUOTE=baptista] But it is interesting to know that I don't sync the mails wit windows box. [/QUOTE=baptista]

Please explain. I don't understand what you're trying to tell me about syncing.

Oh, no problem with the spaces. Your pasting was fine, except you left out the final bash$ afterwards. I like to see that too, so I'm sure I've got all the output. wink.gif

sdjf
sdjf
Hi baptista!

I'm sorry. I was too tired and didn't study your output carefully enough. There was a timeout problem, so we need to change some settings so that doesn't happen. 3 seconds is not enough time for a sloww ISP. wink.gif

If your networking configuration files are the same on 3.13 as on 2.38, then the following should help me see your settings. I used "grep -Ev password" so you would not post your password publicly. Be sure that it doesn't appear in anything you post, so examine your post before you push the button here. smile.gif

grep -l 30095007 /etc/ppp/peers/* | tee greppeersfiles | xargs cat
cat greppeersfiles
grep -l 30095007 Applications/Network/modules/* | tee modulesfile | xargs cat | grep -Ev password
cat modulesfile
rm greppeersfiles modulesfile # removes unnecessary files you just created

I want to compare your dialup settings with mine.

Also, do you know how to use vi? It may be easier to explain the changes than with the GUI if you do know how to use it. If you don't, do not worry. I'll figure out which GUI setting to change if we need to do it that way.

sdjf

EDIT: Please I also need to see the output from step #2 commands in post #32, that you get just before the next time you try to use the modem. You could try it again and run these commands without changing any settings.
baptista
Hi sdjf: I,m writing for my joy and the yours,I think, from Opera. I,ll explain better...waiting a kick in the ass from you....your patience is giving results,once more thanks.
My best regards
baptista
sdjf
Huh? I guess that means you got online?

I recommend running all those commands and posting the output, the next time your modem gives you trouble.

What did you do that made Authentication succeed instead of fail?

sdjf
baptista
Hi sdjf:
Really I entered the Opera and post you my first replay.

I think that when I update the 3.13 ROM must be lost the settings of Network GUI. Nevertheless Iīll try do something by myself without boring you everytime..and taking in account everything that you say to me.
So I begin my trial and error settings and at last functioned...will pass to you my configurations:

I give a name and a fone number
Connection x Dial-up( via Modem)

Connection name
f.burgos-UOL
Telefone number 9,xxxxxxxx (we have a fone central)
Dialing xTone
x make mail and settings
Dialing xTone
Advance settings:Init commands: ATZ
Speed 57600
xHardware control
Wait time 11 sec ( taking in account what you said about 3 sec.)

Connection ID: f.burgos@uol.com.br
x save pasword: xxxxxxxxx

x Auto-detect name servers

Proxy No proxy

Enter mail and settings

Account name f.burgos@uol.com.br
User name: Francisco Baptista (now you know my complete name...)
x save password xxxxxxxx

Account Type POP3
POP/IMAP pop3a.uol.com.br
SMTP server smtpa.uol.com.br

x Autentication settings
xSame a incoming mail server
Mail address: f.burgos@uol.com.br
Register

So I connected and entered in Opera. It is difficult to work with it by the size of collie...also de battery goes out rappidly, During this time I have the external power connected. But have the joy of sending to you the first reply in the Forums...

Ah! thee bills with the ISP are updated....
Well you make a mention to vi..give me some tips if necessary.
Of course I need and OK from you about what I done (if you want)
I hope that this weekend you could to rest something more, I donīt know if I can help in something from here but would like. Something in your site is in the air...but I donīt want to enter in your privacity.Would like to know in internet language IMNSO

Till your answer I send
my best regards
baptista
sdjf
IMNSHO means "in my not so humble opinion". Not well today, so when I feel better I'll fetch the urls of sites that are dictionaries of "chat slang". You could also google yourself.

Again, what matter is that I see what is the output of the various commands I showed above, and contents of settings files, the next time you have a problem. But maybe you will not! wink.gif

that would be nice,

take care,
sdjf
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.