Help - Search - Members - Calendar
Full Version: Gpe-mini-browser_0.19_1 Questions And Notes
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Jon_J
I installed this as noted by meanie in the new packages thread.
http://www.oesf.org/forums/index.php?showt...ndpost&p=158709
I already had the files that come with osb-browser installed, they are:
----------------------------------------
osb_browser_0.5.2_armv5tel.ipk
osb_jscore_0.5.2_armv5tel.ipk
osb_nrcit_0.5.2_armv5tel.ipk
osb_nrcore_0.5.2_armv5tel.ipk
----------------------------------------
Then I installed gpe-mini-browser and depends that meanie suggested.
----------------------------------------
gpe-mini-browser_0.19_1_armv5tel.ipk
libgpewidget_0.112.060606-1_armv5tel.ipk
gpe-icons_0.25.050606_armv5tel.ipk
----------------------------------------
Launching gpe-mini-browser in a console found one more missing depends. (libsqlite)
I did a search for libsqlite here in this forum and came upon a post about a newer version not working,
so I went to meanie's pdaxrom feed and found this one, and it works.
---------------------------------------
sqlite_2.8.17_armv5tel.ipk
---------------------------------------
The browser launches now. In a console it gives similar error as osb-browser gives.
CODE
** (gpe-mini-browser:3265): WARNING **: NotYetImplemented: virtual void BridgeImpl::windowObjectCleared()

I have a couple questions about the new gpe-mini-browser
1. why develop this browser instead of osb-browser?
osb-browser has nicer menu/toolbar layout with more (grayed-out) options.
2. Will there be a "File>Open" dialog to open local files?
3. Bookmarks doesn't work with local files, Is Bookmarks working for online urls only? (see screenshot)
I don't have my pdaxii13 Z online, so I cannot test the online functions of browsers.
I can only try to open local files.

I closed it and re-opened it and used "History" to re-open my local file and this works. smile.gif
Not the same as having bookmarks though.
4. Will "import bookmarks" from other browsers be implemented?
zi99y
Dude, meanie isn't developing this software, he's just compiled it!

and I imagine it's just a frontend to the same engine as osb-browser, similar to firefox using the gecko engine....
Meanie
yeah, I just hacked the order of the buttons because the original layout was even worst...

as for the bookmarks, they work, but you need to select the "Add new" radio button. The "Add current web page" one does not seem to work. probably a bug in mini-browser. report a bug in OE about it if you so desire...
Jon_J
I tried both buttons and got same error.
"Add new" gives same error as Add current

I'll try again, it takes some time to load the page, brb.
Also, I had to paste the url/path into both places shown in the screenshot, because the url disappears after the page loads.
EDIT:
It did work this time, I must have copied/pasted the url/path incorrectly the first time smile.gif

So this is what you need to do to save a bookmark:
When pasting or typing an url or path into the "Url" box, copy it first, because as soon as the page opens, the url will disappear from this box.
Then open bookmarks and select Add:, then click bottom radio button "Add new", then paste in the url, or if you remember the url, type it in, and select the Add button.

EDIT2:
The url in the url box doesn't disappear anymore after a page loads. smile.gif
After saving several local bookmarks, and changing just the filenames at the end of the path in the url box, it stopped disappearing.
I'm not sure what "fixed" this, but I first used the "Enter" key on the keyboard to launch an url, then later I started pressing the "OK" button at the end of the url box, and sometime during all of that, the urls remained persistent and didn't disappear anymore. smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.