Help - Search - Members - Calendar
Full Version: Help Needed With Wpa
OESF Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > C1000/3x00 General discussions
I have a c-1000 with Opie (Akita and a Linksys wcf11 card which was working fine on my WEP network.

With the latest increased insecurity of WEP, I have switched the network over to WPA/PSK, and all of my other computers are working fine with it.

I have tried configuring the Z as described here
I used the example wpa_supplicant.conf, changing this section:

# Only WPA-PSK is used. Any valid cipher combination is accepted.
pairwise=CCMP TKIP
group=CCMP TKIP WEP104 WEP40
putting my own information in for the ssid and psk lines, and leaving everything else in the file "as-is".
When I give the ifup command it says "Sending discover..." three times and forks to background since it can't get a lease. The card is active (LED blinking) and it works with Wellenreiter, so it seems the hardware is OK.

I need help troubleshooting this. Just some additional information about what went wrong - like the ssid was wrong, or the key was refused, or the card wasn't found....

Any help will be very much appreciated.

check firmware of card (run 'hostap_diag wlan0') - it need STA 1.7.0 or later.

You can load firmware to ram of card with 'prism2_srec -r /etc/pcmcia/rf010804.hex wlan0' after card insert.
QUOTE(Hrw @ May 2 2007, 09:09 PM)
check firmware of card (run 'hostap_diag wlan0') - it need STA 1.7.0 or later.

You can load firmware to ram of card with 'prism2_srec -r /etc/pcmcia/rf010804.hex wlan0' after card insert.

Thanks, Marcin! I'm glad that you are still active in the OE forum - from what I'm reading everything is going over to Angstrom, but when I installed it, nothing worked! The GUI network configuration seemed to work, but since my network is now WPA, I couldn't set it up. In the Console, ifconfig and his friends don't seem to be installed!

So I re-installed Open Zaurus Akita and tried to follow your instructions. I do have an old firmware version, STA is 1.3.4, so I tried updating the firmware, and it replies:
'wlan0' not readable : No such file or directory
Parsing 'wlan0' failed.

Note that Wellenreiter still works, using wlan0 as the interface!

I'm happy to work with Angstrom, but at this stage it looks to me as if you need to be a fairly skilled Linux programmer to get anything to work - and I'm not that!

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2016 Invision Power Services, Inc.