Help - Search - Members - Calendar
Full Version: Fixes For R198/r197
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Pages: 1, 2
Meanie
I am almost done with some essential fixes for r198 and will be packaging up all the fixes into a single large ipk for easy installation.

Here's the control file with summary of the fixes


Package: pdaXrom-fixes
Version: r198-sp1
Maintainer: hdluc@yahoo.com
Architecture: armv5tel
Priority: optional
Section: Applications
Depends: scrot
Description: bug fixes
- fixed fstab to auto mount SD and CF
- updated keymap (Cxx00 only) with same key assignments as in pdaXii13
- added inputrc (so Fn left/right can be used)
- added motd
- updated ipkg.conf with current feeds
- hacked pci.rc to be quiet
- replaced vi with vim
- updated rc.xml (openbox config)
- updated startx (re)load kernel.map
- updated makefbmenu
- updated fbpanel-session
- updated mbsession
- made the menu key work for fbmenu
- added .Xdefaults
- added ax (to enable sticky keys)
- replaced xterm
- added libiconv and libXau
- added diff
- updated gqview
- updated xpdf
- updated xmms
- updated qtconfig
- updated pppconfig
- added default configs for pppdialer
- added ipkg-make-index
- added screencap
- added reboot
- added unclutter
- updated mb-applet-blanker
- updated mb-applet-cards
- updated looknfeel.py
- updated inputconfig.py
- made xmms default to double size
- made AbiWord default startup size fit on screen
- made Sylpheed default startup size fit on screen


coming soon...
adf
the possibility of a polished 2.6 based system for the Zaurus ? Fabulous!
cortez
A good reason to give r198 another try!
Current release is far too unpolished for me, so I fell back to my trusty RC12. It's a good thing to see there are still people spending their precious spare time trying to make this a succes! Thanks a lot
Dromede
great news but... last time i tried r198 abiword was much slower than on pdaxii3. can we expect any improvement regarding this? is r198 really faster than pdaxii3?
danboid
Whats the status of mplayer on 2.6 based pdaX now? Is the 2.6 pxa vo mode as good as bvdd on 2.4 now?

Also, how does nokia's osb browser run under r198? I know people said it was very unstable under pdaXii13 but r198 has much more recent glib, gtk etc so I'm guessing there's a much better chance of it working properly.
scoutme
any improvement for 860?
InSearchOf
QUOTE(scoutme @ May 25 2007, 04:09 PM)
any improvement for 860?
*


that will come with kernel 2.6.21

:-)

Late
Capn_Fish
QUOTE(InSearchOf @ May 25 2007, 03:13 PM)
QUOTE(scoutme @ May 25 2007, 04:09 PM)
any improvement for 860?
*

kernel 2.6.21
*


smile.gif
Meanie
have fun
grog
QUOTE(Capn_Fish @ May 25 2007, 03:07 PM)
QUOTE(InSearchOf @ May 25 2007, 03:13 PM)
QUOTE(scoutme @ May 25 2007, 04:09 PM)
any improvement for 860?
*
kernel 2.6.21
*
smile.gif
*

Don'tcha just love a cliffhanger smile.gif
grog
QUOTE(Meanie @ May 25 2007, 09:20 PM)
have fun
*

It's always fun! smile.gif

On my C860 I have to change the line in /usr/X11R6/bin/startx from

CODE
defaultserverargs=" -nolisten tcp -screen 480x640@270"

to

CODE
defaultserverargs=" -nolisten tcp

Maybe there could be some code to check the machine:

CODE
if [ $HARDWARE = "Husky" ]; then
   defaultserverargs=" -nolisten tcp
else
  defaultserverargs=" -nolisten tcp -screen 480x640@270"
fi

or something like that.
daniel3000
Attention:
The word "SP1" might be registered or otherwise blocked by MS.
SCNR ph34r.gif


Great news, Meanie.
Maybe I'll try R198 as well some day! Thanks a lot!

daniel
HoloVector
Thanks for the update Meanie.

I tried it on my C1000 and the Matchbox Cards applet was broken for CF slot. It would not eject a CF memory card in the slot. It just said it was empty. Pccardctl recognized the card fine and could eject it just fine. I also tried my Buffalo Wifi card and the MB Cards couldn't see it either. Pcccardctl had no trouble with the Buffalo card either. I tried fixing the problem by reinstalling the old MB cards applet from the feeds you included in SP1 (1.03 I believe) and it seems to have totally killed my CF slot. Pccardctl can't see any card in the slot anymore even after rebooting. I sure hope that this is a software issue or my C1000 is write off. sad.gif

Which brings up another issue that I found after applying SP1. The new reboot menu item doesn't work. Clicking on it does nothing. I have to exit X and then type reboot at the console prompt.
Meanie
QUOTE(HoloVector @ May 27 2007, 08:22 AM)
Thanks for the update Meanie. 

I tried it on my C1000 and the Matchbox Cards applet was broken for CF slot.  It would not eject a CF memory card in the slot.  It just said it was empty.  Pccardctl recognized the card fine and could eject it just fine.  I also tried my Buffalo Wifi card and the MB Cards couldn't see it either.  Pcccardctl had no trouble with the Buffalo card either.  I tried fixing the problem by reinstalling the old MB cards applet from the feeds you included in SP1 (1.03 I believe) and it seems to have totally killed my CF slot.  Pccardctl can't see any card in the slot anymore even after rebooting.  I sure hope that this is a software issue or my C1000 is write off.  sad.gif

Which brings up another issue that I found after applying SP1.  The new reboot menu item doesn't work.  Clicking on it does nothing.  I have to exit X and then type reboot at the console prompt.
*


sigh. the mb-applet-cards fix works for C3x00 models. looks like it broke the c1000. just install the old applet from the r198 feed, or use the fbpanel cards applet instead which will work on the c1000 but not the c3x00.

i will need to write a better detection routine, but ultimately, this problem will be properly fixed by the new kernel. my workaround is a hack for the current kernel bug in detecting the pccard devices properly. it assumes slot 0 is the external cf card for all models which is fine for c1000 but breaks all the c3x00. so my hack was to eject slot 1 instead which is where the external cf is for c3x00. once the kernel is fixed, slot 0 will be the external cf for all models...
i almost forgot, for c1000, you can try changing r198 to r200 in /etc/issue



grog: thanks for that feedback. i had such a detection thing in pdaXii13, so i will add that to svn for the new releases as well. i thought this was already fixed but seems like it isnt. are the keymappings ok? i tried to fix a few issues with keymappings but without having such a model i cant test them. this is a sp for r198 so it is aimed at fixing problems with c3x00 and c1000 models specificly, but there are also many fixes that are model independant. if there are things broken on c7x0/c8x0 please report those problems like you did for startx and i will fix them. anything else broken? if the keymap is broke, send me one that works smile.gif
HoloVector
QUOTE(Meanie @ May 26 2007, 05:01 PM)
QUOTE(HoloVector @ May 27 2007, 08:22 AM)
Thanks for the update Meanie. 

I tried it on my C1000 and the Matchbox Cards applet was broken for CF slot.  It would not eject a CF memory card in the slot.  It just said it was empty.  Pccardctl recognized the card fine and could eject it just fine.  I also tried my Buffalo Wifi card and the MB Cards couldn't see it either.  Pcccardctl had no trouble with the Buffalo card either.  I tried fixing the problem by reinstalling the old MB cards applet from the feeds you included in SP1 (1.03 I believe) and it seems to have totally killed my CF slot.  Pccardctl can't see any card in the slot anymore even after rebooting.  I sure hope that this is a software issue or my C1000 is write off.   sad.gif

Which brings up another issue that I found after applying SP1.  The new reboot menu item doesn't work.  Clicking on it does nothing.  I have to exit X and then type reboot at the console prompt.
*


sigh. the mb-applet-cards fix works for C3x00 models. looks like it broke the c1000. just install the old applet from the r198 feed, or use the fbpanel cards applet instead which will work on the c1000 but not the c3x00.

i will need to write a better detection routine, but ultimately, this problem will be properly fixed by the new kernel. my workaround is a hack for the current kernel bug in detecting the pccard devices properly. it assumes slot 0 is the external cf card for all models which is fine for c1000 but breaks all the c3x00. so my hack was to eject slot 1 instead which is where the external cf is for c3x00. once the kernel is fixed, slot 0 will be the external cf for all models...
i almost forgot, for c1000, you can try changing r198 to r200 in /etc/issue

.....

*


Thanks Meanie.

The mb cards applet in the feed loads on X startup but when I tap on it, it disappears. sad.gif

I reloaded SP1 and the your 3x00 fixed cards applet runs so at least I can control my SD and USB devices with it. How do I get back to the original cards applet that works with the 1000? I looked through the feeds but the only fb stuff I can find is the fbpanel. There are no fb applets listed. Maybe I am looking for the wrong name?

Edit: I just changed the release number from R198 to R200 like you suggested and restarted. I'm not sure what that did for me aside from telling me I am now running R200 when I login. Was that supposed to help with the reboot menu item? I just tried the menu reboot and it is still not working. sad.gif
Meanie
QUOTE(HoloVector @ May 27 2007, 12:39 PM)
QUOTE(Meanie @ May 26 2007, 05:01 PM)
QUOTE(HoloVector @ May 27 2007, 08:22 AM)
Thanks for the update Meanie. 

I tried it on my C1000 and the Matchbox Cards applet was broken for CF slot.  It would not eject a CF memory card in the slot.  It just said it was empty.  Pccardctl recognized the card fine and could eject it just fine.  I also tried my Buffalo Wifi card and the MB Cards couldn't see it either.  Pcccardctl had no trouble with the Buffalo card either.  I tried fixing the problem by reinstalling the old MB cards applet from the feeds you included in SP1 (1.03 I believe) and it seems to have totally killed my CF slot.  Pccardctl can't see any card in the slot anymore even after rebooting.  I sure hope that this is a software issue or my C1000 is write off.  sad.gif

Which brings up another issue that I found after applying SP1.  The new reboot menu item doesn't work.  Clicking on it does nothing.  I have to exit X and then type reboot at the console prompt.
*


sigh. the mb-applet-cards fix works for C3x00 models. looks like it broke the c1000. just install the old applet from the r198 feed, or use the fbpanel cards applet instead which will work on the c1000 but not the c3x00.

i will need to write a better detection routine, but ultimately, this problem will be properly fixed by the new kernel. my workaround is a hack for the current kernel bug in detecting the pccard devices properly. it assumes slot 0 is the external cf card for all models which is fine for c1000 but breaks all the c3x00. so my hack was to eject slot 1 instead which is where the external cf is for c3x00. once the kernel is fixed, slot 0 will be the external cf for all models...
i almost forgot, for c1000, you can try changing r198 to r200 in /etc/issue

.....

*


Thanks Meanie.

The mb cards applet in the feed loads on X startup but when I tap on it, it disappears. sad.gif

I reloaded SP1 and the your 3x00 fixed cards applet runs so at least I can control my SD and USB devices with it. How do I get back to the original cards applet that works with the 1000? I looked through the feeds but the only fb stuff I can find is the fbpanel. There are no fb applets listed. Maybe I am looking for the wrong name?

Edit: I just changed the release number from R198 to R200 like you suggested and restarted. I'm not sure what that did for me aside from telling me I am now running R200 when I login. Was that supposed to help with the reboot menu item? I just tried the menu reboot and it is still not working. sad.gif
*



no, changing the release is supposed to trick the applet into thinking that its a newer version of pdaXrom that doesn't have the kernel bug and thus will use device 0...
HoloVector
QUOTE(Meanie @ May 26 2007, 09:27 PM)
QUOTE(HoloVector @ May 27 2007, 12:39 PM)
QUOTE(Meanie @ May 26 2007, 05:01 PM)
QUOTE(HoloVector @ May 27 2007, 08:22 AM)
Thanks for the update Meanie. 

I tried it on my C1000 and the Matchbox Cards applet was broken for CF slot.  It would not eject a CF memory card in the slot.  It just said it was empty.  Pccardctl recognized the card fine and could eject it just fine.  I also tried my Buffalo Wifi card and the MB Cards couldn't see it either.  Pcccardctl had no trouble with the Buffalo card either.  I tried fixing the problem by reinstalling the old MB cards applet from the feeds you included in SP1 (1.03 I believe) and it seems to have totally killed my CF slot.  Pccardctl can't see any card in the slot anymore even after rebooting.  I sure hope that this is a software issue or my C1000 is write off.   sad.gif

Which brings up another issue that I found after applying SP1.  The new reboot menu item doesn't work.  Clicking on it does nothing.  I have to exit X and then type reboot at the console prompt.
*


sigh. the mb-applet-cards fix works for C3x00 models. looks like it broke the c1000. just install the old applet from the r198 feed, or use the fbpanel cards applet instead which will work on the c1000 but not the c3x00.

i will need to write a better detection routine, but ultimately, this problem will be properly fixed by the new kernel. my workaround is a hack for the current kernel bug in detecting the pccard devices properly. it assumes slot 0 is the external cf card for all models which is fine for c1000 but breaks all the c3x00. so my hack was to eject slot 1 instead which is where the external cf is for c3x00. once the kernel is fixed, slot 0 will be the external cf for all models...
i almost forgot, for c1000, you can try changing r198 to r200 in /etc/issue

.....

*


Thanks Meanie.

The mb cards applet in the feed loads on X startup but when I tap on it, it disappears. sad.gif

I reloaded SP1 and the your 3x00 fixed cards applet runs so at least I can control my SD and USB devices with it. How do I get back to the original cards applet that works with the 1000? I looked through the feeds but the only fb stuff I can find is the fbpanel. There are no fb applets listed. Maybe I am looking for the wrong name?

Edit: I just changed the release number from R198 to R200 like you suggested and restarted. I'm not sure what that did for me aside from telling me I am now running R200 when I login. Was that supposed to help with the reboot menu item? I just tried the menu reboot and it is still not working. sad.gif
*



no, changing the release is supposed to trick the applet into thinking that its a newer version of pdaXrom that doesn't have the kernel bug and thus will use device 0...
*



Thanks again, Meanie.

I see. Unfortunately, it didn't work. I still can't manage my CF slot with the applet. sad.gif
Meanie
made a few more fixes so here is sp2. sp2 includes all fixes that are in sp1 plus some extra ones:

- included missing Reboot
- fixed mb-applet-cards for C1000 also
- some updates to keymappings
Meanie
arg! found a bug in the cards applet. it only detects memory cards, so here is the fix...
scoutme
hi Meanie, are your patches good for sl-c860?
Meanie
QUOTE(scoutme @ Jun 1 2007, 09:15 AM)
hi Meanie, are your patches good for sl-c860?
*


it should work, but untested due to lack of said device...
grog
QUOTE(Meanie @ May 31 2007, 06:49 PM)
QUOTE(scoutme @ Jun 1 2007, 09:15 AM)
hi Meanie, are your patches good for sl-c860?
*
it should work, but untested due to lack of said device...
*

They've worked ok for me so far, except for the issues that Meanie's fixed already. Back up first & the n see how it goes. That's waht I've done.
dsteuer
QUOTE(grog @ Jun 1 2007, 05:10 PM)
QUOTE(Meanie @ May 31 2007, 06:49 PM)
QUOTE(scoutme @ Jun 1 2007, 09:15 AM)
hi Meanie, are your patches good for sl-c860?
*
it should work, but untested due to lack of said device...
*

They've worked ok for me so far, except for the issues that Meanie's fixed already. Back up first & the n see how it goes. That's waht I've done.
*



So you have R197 + sp3 running? Just to be sure before flashing ...
grog
QUOTE(dsteuer @ Jun 2 2007, 03:02 AM)
So you have R197 + sp3 running? Just to be sure before flashing ...
*

Correct. The only issues for me right now is restoring my custom fstab & .Xdefaults after installing. So unless you've touched any of the config files in the package, you should be ok.

Here's a listing without the binary's that are updated:

CODE
grog@grond$ ipkg files pdaXrom-fixes | grep -v "bin|lib|usr"
//etc/
//etc/ipkg.conf
//etc/hotplug/
//etc/hotplug/pci.rc
//etc/motd
//etc/rc.d/
//etc/rc.d/rc.sysinit
//etc/rc.d/init.d/
//etc/rc.d/init.d/bluetooth
//etc/xdg/
//etc/xdg/openbox/
//etc/xdg/openbox/rc.xml
//etc/X11/
//etc/X11/kb/
//etc/X11/kb/Akita/
//etc/X11/kb/Akita/xmodmap_us
//etc/X11/kb/Corgi/
//etc/X11/kb/Corgi/xmodmap_us
//etc/inputrc
//etc/ppp/
//etc/ppp/peers/
//etc/ppp/peers/default
//etc/ppp/peers/gprs
//etc/wifi-radar.conf
//etc/sysconfig/
//etc/sysconfig/keyboard/
//etc/sysconfig/keyboard/Spitz/
//etc/sysconfig/keyboard/Spitz/keymap-sticky.map
//home/
//home/root/
//home/root/.Xdefaults
//home/root/.xmms/
//home/root/.xmms/config
//home/root/.AbiSuite/
//home/root/.AbiSuite/AbiWord.Profile
//home/root/.sylpheed-2.0/
//home/root/.sylpheed-2.0/sylpheedrc
//home/root/Choices/
//home/root/Choices/common/
//home/root/Choices/common/Network-PPP-GPRS.conf
//home/root/Choices/common/Network-PPP-default.conf
//home/root/.fbpanel/
//home/root/.fbpanel/default


Oh, and Meanie. Could I ask a favour & get you to correct the permissions of the directories in the package, specifically /etc, /etc/rc.d, /etc/rc.d/init.d & /etc/X11 (just the ones I can remember off the top of my head). 99% of my work on the Z is in a terminal as a non-root user using sudo & I keep having to reset these dirs back from 700 to 755 after I install the sp. thks
Meanie
QUOTE(grog @ Jun 3 2007, 02:18 AM)
QUOTE(dsteuer @ Jun 2 2007, 03:02 AM)
So you have R197 + sp3 running? Just to be sure before flashing ...
*

Correct. The only issues for me right now is restoring my custom fstab & .Xdefaults after installing. So unless you've touched any of the config files in the package, you should be ok.

Here's a listing without the binary's that are updated:

CODE
grog@grond$ ipkg files pdaXrom-fixes | grep -v "bin|lib|usr"
//etc/
//etc/ipkg.conf
//etc/hotplug/
//etc/hotplug/pci.rc
//etc/motd
//etc/rc.d/
//etc/rc.d/rc.sysinit
//etc/rc.d/init.d/
//etc/rc.d/init.d/bluetooth
//etc/xdg/
//etc/xdg/openbox/
//etc/xdg/openbox/rc.xml
//etc/X11/
//etc/X11/kb/
//etc/X11/kb/Akita/
//etc/X11/kb/Akita/xmodmap_us
//etc/X11/kb/Corgi/
//etc/X11/kb/Corgi/xmodmap_us
//etc/inputrc
//etc/ppp/
//etc/ppp/peers/
//etc/ppp/peers/default
//etc/ppp/peers/gprs
//etc/wifi-radar.conf
//etc/sysconfig/
//etc/sysconfig/keyboard/
//etc/sysconfig/keyboard/Spitz/
//etc/sysconfig/keyboard/Spitz/keymap-sticky.map
//home/
//home/root/
//home/root/.Xdefaults
//home/root/.xmms/
//home/root/.xmms/config
//home/root/.AbiSuite/
//home/root/.AbiSuite/AbiWord.Profile
//home/root/.sylpheed-2.0/
//home/root/.sylpheed-2.0/sylpheedrc
//home/root/Choices/
//home/root/Choices/common/
//home/root/Choices/common/Network-PPP-GPRS.conf
//home/root/Choices/common/Network-PPP-default.conf
//home/root/.fbpanel/
//home/root/.fbpanel/default


Oh, and Meanie. Could I ask a favour & get you to correct the permissions of the directories in the package, specifically /etc, /etc/rc.d, /etc/rc.d/init.d & /etc/X11 (just the ones I can remember off the top of my head). 99% of my work on the Z is in a terminal as a non-root user using sudo & I keep having to reset these dirs back from 700 to 755 after I install the sp. thks
*



done. file permissions fixed. also added sltime...
zeigerpuppy
When I tried R189, bluetooth PPP was not working (did not scan for peer) and my socket CF Wifi was also not recognised.
Are these issues fixed or am I missing something in the configuration. I would like to flash back to R198 as the suspend functions are much zippier that pdaxii13 on my 3100 but can't do without networking!
louigi600
QUOTE(InSearchOf @ May 25 2007, 10:13 PM)
QUOTE(scoutme @ May 25 2007, 04:09 PM)
any improvement for 860?
*


that will come with kernel 2.6.21

:-)

Late
*


How is the work on 2.6.21 coming on ?
HoloVector
QUOTE(Meanie @ Jun 3 2007, 08:32 PM)
.....
done. file permissions fixed. also added sltime...
*


The fourth time is the charm for me. The cards applet is now working properly on my 1000. Thanks Meanie.
InSearchOf
QUOTE(louigi600 @ Jun 6 2007, 02:49 AM)
QUOTE(InSearchOf @ May 25 2007, 10:13 PM)
QUOTE(scoutme @ May 25 2007, 04:09 PM)
any improvement for 860?
*


that will come with kernel 2.6.21

:-)

Late
*


How is the work on 2.6.21 coming on ?
*



Still applying patches... waiting to reach a point where I can atleast boot to the kernel...

Late
grog
QUOTE(Meanie @ Jun 3 2007, 08:32 PM)
QUOTE(grog @ Jun 3 2007, 02:18 AM)
Oh, and Meanie. Could I ask a favour & get you to correct the permissions of the directories in the package, specifically /etc, /etc/rc.d, /etc/rc.d/init.d & /etc/X11 (just the ones I can remember off the top of my head). 99% of my work on the Z is in a terminal as a non-root user using sudo & I keep having to reset these dirs back from 700 to 755 after I install the sp. thks
*

done. file permissions fixed. also added sltime...
*

Not quite. The directories need execute permissions as well. Currently:

CODE
drwxr--r-- root/root         0 2007-05-24 16:34:42 ./etc/hotplug/
drwxr--r-- root/root         0 2007-05-28 07:26:37 ./etc/rc.d/
drwxr--r-- root/root         0 2007-05-24 16:34:42 ./etc/X11/
drwxr--r-- root/root         0 2007-05-24 20:36:33 ./etc/X11/kb/
drwxr--r-- root/root         0 2007-05-25 14:26:46 ./etc/X11/kb/Akita/

As well, 'fraid I have to report a problem with the sp's for corgi's. The xpdf binary isn't compatible, crashing with an 'Illegal instruction' error. It took me a while to notice this 'cause I don't use it that often. I checked out most of the other binary's that are included in the sp & haven't found any issues with any of those.
Meanie
QUOTE(grog @ Jun 7 2007, 03:05 AM)
QUOTE(Meanie @ Jun 3 2007, 08:32 PM)
QUOTE(grog @ Jun 3 2007, 02:18 AM)
Oh, and Meanie. Could I ask a favour & get you to correct the permissions of the directories in the package, specifically /etc, /etc/rc.d, /etc/rc.d/init.d & /etc/X11 (just the ones I can remember off the top of my head). 99% of my work on the Z is in a terminal as a non-root user using sudo & I keep having to reset these dirs back from 700 to 755 after I install the sp. thks
*

done. file permissions fixed. also added sltime...
*

Not quite. The directories need execute permissions as well. Currently:

CODE
drwxr--r-- root/root         0 2007-05-24 16:34:42 ./etc/hotplug/
drwxr--r-- root/root         0 2007-05-28 07:26:37 ./etc/rc.d/
drwxr--r-- root/root         0 2007-05-24 16:34:42 ./etc/X11/
drwxr--r-- root/root         0 2007-05-24 20:36:33 ./etc/X11/kb/
drwxr--r-- root/root         0 2007-05-25 14:26:46 ./etc/X11/kb/Akita/

As well, 'fraid I have to report a problem with the sp's for corgi's. The xpdf binary isn't compatible, crashing with an 'Illegal instruction' error. It took me a while to notice this 'cause I don't use it that often. I checked out most of the other binary's that are included in the sp & haven't found any issues with any of those.
*



thanks for letting me know. seems like umask is set too restrictively in the new release.
i will need to recompile xpdf since it was compiled with optimizations for the newer clamshell devices..

the choice now is to have a separete sp pack for 7x0/8x0 , or have an unoptimised (no xscale or iwmmxt) binary for all.
HoloVector
QUOTE(Meanie @ Jun 6 2007, 06:52 PM)
....
the choice now is to have a separete sp pack for 7x0/8x0 , or have an unoptimised (no xscale or iwmmxt) binary for all.
*

If I had my choice, I would go with a seperate service pack for the 7x0/860 since I'd hate to loose any CXXXX optimizations. cool.gif
adf
QUOTE(HoloVector @ Jun 7 2007, 01:18 AM)
QUOTE(Meanie @ Jun 6 2007, 06:52 PM)
....
the choice now is to have a separete sp pack for 7x0/8x0 , or have an unoptimised (no xscale or iwmmxt) binary for all.
*

If I had my choice, I would go with a seperate service pack for the 7x0/860 since I'd hate to loose any CXXXX optimizations. cool.gif
*


I'm using pdaXii13, but for what its worth it seems to me that one of the advantages of pdaX generally is optimization.
HoloVector
QUOTE(adf @ Jun 6 2007, 07:25 PM)
QUOTE(HoloVector @ Jun 7 2007, 01:18 AM)
QUOTE(Meanie @ Jun 6 2007, 06:52 PM)
....
the choice now is to have a separete sp pack for 7x0/8x0 , or have an unoptimised (no xscale or iwmmxt) binary for all.
*

If I had my choice, I would go with a seperate service pack for the 7x0/860 since I'd hate to loose any CXXXX optimizations. cool.gif
*


I'm using pdaXii13, but for what its worth it seems to me that one of the advantages of pdaX generally is optimization.
*


Amen!
Meanie
QUOTE(HoloVector @ Jun 7 2007, 02:51 PM)
QUOTE(adf @ Jun 6 2007, 07:25 PM)
QUOTE(HoloVector @ Jun 7 2007, 01:18 AM)
QUOTE(Meanie @ Jun 6 2007, 06:52 PM)
....
the choice now is to have a separete sp pack for 7x0/8x0 , or have an unoptimised (no xscale or iwmmxt) binary for all.
*

If I had my choice, I would go with a seperate service pack for the 7x0/860 since I'd hate to loose any CXXXX optimizations. cool.gif
*


I'm using pdaXii13, but for what its worth it seems to me that one of the advantages of pdaX generally is optimization.
*


Amen!
*



in that case, wait for a separate sp for 7x0/8x0 devices...
Fushnchupsh
I like to second an afformentioned bug. I have sp3 and my socket card is not working. I have the firmware in all the right place.

I really appreciate all the work you do. Thanks, meanie.

--Fish
ScottYelich
grog -- could you tell me/us a little about the latest (198+sp4?) on 860?

I still can't see a clear message if it's still too early to change to this or if
it's stable... etc.

Thanks!

Scott
grog
QUOTE(ScottYelich @ Jun 7 2007, 08:57 PM)
grog -- could you tell me/us a little about the latest (198+sp4?) on 860?

I still can't see a clear message if it's still too early to change to this or if
it's stable... etc.
*

Well, AFAIK the only thing that it currently breaks is the xpdf binary, which I've made Meanie aware of. Just reinstall xpdf after. On the upside, updates to wifi-radar are nice to have (i.e. it actually works now). But I don't use all of the applications that are touched, so your mileage may vary.

Bottom line is, I'd recommend going for it, but don't kill the messenger if something does break smile.gif. We're still using a beta product, after all ph34r.gif
HTH
Meanie
another small update smile.gif
louigi600
QUOTE(InSearchOf @ Jun 6 2007, 02:08 PM)
QUOTE(louigi600 @ Jun 6 2007, 02:49 AM)

How is the work on 2.6.21 coming on ?

Still applying patches... waiting to reach a point where I can atleast boot to the kernel...


At the time of 2.6.21.1 most patches for 2.6.20.6 could be applied and kernel did boot but with a few important things braking:
the power button no longer suspended but "apm --suspend" worked and power button resumend,
some nand flash utils broke (but this is also true for 2.6.20.6),
zaurushw thing broke (but this is also true for 2.6.20.6),
wierd behaviour in X with the touchscreen (but this is also true for 2.6.20.6)

Kernel is now at 2.6.21.4 but I've been watching the changelog and found nothing addressing these specific issues (especially the power button one) although there were some other ARM fixes.

I extracted a patch sequence from OZ for the 2.6.20.6 (that with very little work could also be applied to 2.6.21 kernels) along with the actual patches ... gis can build a bootable kernel with some broken things. If anyone likes to try PM me (Adrian .... I already sent you that work).

I'm a feeble programmer ... if anyone has kernel experience and is willing to write patches for the proken things I can try them out ;-)
ScottYelich
(sorry for the last quote at the bottom)

Ok, I may give it a try. I've been waiting a long time for the next non-beta stable release... seems like it's just never gonna happen.

With any rom -- I just need a good gcc/g++ and Qt 4.2.3 (or later).

I may hunt down where the rom is and give it a try.

thanks!

Scott




QUOTE(grog @ Jun 8 2007, 10:05 AM)
QUOTE(ScottYelich @ Jun 7 2007, 08:57 PM)
grog -- could you tell me/us a little about the latest (198+sp4?) on 860?

I still can't see a clear message if it's still too early to change to this or if
it's stable... etc.
*

Well, AFAIK the only thing that it currently breaks is the xpdf binary, which I've made Meanie aware of. Just reinstall xpdf after. On the upside, updates to wifi-radar are nice to have (i.e. it actually works now). But I don't use all of the applications that are touched, so your mileage may vary.

Bottom line is, I'd recommend going for it, but don't kill the messenger if something does break smile.gif. We're still using a beta product, after all ph34r.gif
HTH
*

ScottYelich
one question -- for these SPs.... the ones for 198 are the ones for 700/860, correct?

Also, do I have to apply sp1, then sp2, then 3... or just sp5?

It seems like I just do "sp5" ... right? no others before?

Scott
dsteuer
QUOTE(ScottYelich @ Jun 10 2007, 09:46 PM)
one question -- for these SPs.... the ones for 198 are the ones for 700/860, correct?

Also, do I have to apply sp1, then sp2, then 3... or just sp5?

It seems like I just do "sp5" ... right? no others before?

Scott
*


197 seems for 700/860 and you do just SP5
Meanie
fixed some more keymappings, the menu (so you can see the whole menu now without it going off screen), and also sudo.
you can now create new users and run everything as that user instead of root.
scoutme
any comment about r197 stability/usability after this patch?
grog
QUOTE(Meanie @ Jun 11 2007, 06:13 PM)
[...snip...] and also sudo. you can now create new users and run everything as that user instead of root.
*

I notice that you implemented that by specifying the allowable programs. I just use NOPASSWD:ALL. Other than security (not a big issue on the Z, especially since most of us run as root anyway), do you see a need to be specific?

Is there plan to have sudo specified in the exec line of the desktop files, so this would be seamless in the gui, or is there some other method you had in mind?
donquixote
QUOTE(scoutme @ Jun 12 2007, 05:35 AM)
any comment about r197 stability/usability after this patch?
*


Sure. First of all I have a 760. There are some neat additions to this I recommend upgrading if you already have r197 installed.

However, the debilitating issues are still present:

- shutting off randomly for no reason
- apm issues
- screen not refreshing after exiting X
- audio doesn't shut off when headphones are plugged-in
- screen fading doesn't work with Fn+3 and 4 keys

There are more, these are just off the top of my head.

All I ask for is stability (the first issue). I can live with the rest of the issues.

dq
grog
QUOTE(scoutme @ Jun 12 2007, 04:35 AM)
any comment about r197 stability/usability after this patch?
*

IMHO these sp's are baby steps towards the next 'official' release (right Meanie?). Now whether that release will be labelled as stable, I can't say.

But to answer the question direclty, no, I still wouldn't consider this release + sp6 is stable, I have a few issues that I haven't reported, mainly 'cause I haven't had the time to really troubleshoot them myself yet. The ext2 partition on my sd card seems to need a frequent fsck'ing (which I've automated on reboot) & my hostap drivers seem to go south once in a while requiring a reboot. It would be nice to have it more dependable so I can store my contacts & calendar on it & have it automatically wake up for alarms & such, but that hasn't been a high enough priority for me (yet) to drive me away smile.gif. Oh, and the loss of the NAND flash & restore is a loss that also prevents me from depepnding on my Z. It's too hard to get it back to my working state.

Otherwise, I'm quite happy smile.gif. But for me my Z is a luxury not a requirement.
grog
QUOTE(donquixote @ Jun 12 2007, 11:14 AM)
- shutting off randomly for no reason
- apm issues
I haven't experienced these on my 860.

QUOTE
- screen not refreshing after exiting X
Ah, right. I'm used to suspending & resuming right after exiting X. A pain though, I agree.

QUOTE
- audio doesn't shut off when headphones are plugged-in
True. It's a another pain having to run alsamixer all the time. Then again, at least for me, it's not a biggy 'cause I don't use the speaker very often.

QUOTE
- screen fading doesn't work with Fn+3 and 4 keys
It's been so long I had forgotten about that. And the Fn+1 & Fn+2 to shrink & enlarge the terminal fonts was a kewl thing I remember from Cacko too smile.gif.
Meanie
These SPs are fixes to make live a bit easier until the next major release (which is still being worked on) and hopefully, I will be able to merge all of these fixes into the next release as well.

I am still using pdaXii13 as my stable system, but have sacrificed one of my Zauri for testing and as I find bugs, I create fixes for them in the SPs. Bugs that are in the kernel will not be fixed by me and have to wait until the next release of the kernel. however, i may make a workaround for the bugs if possible like in the cards applet.

well, sudo is implemented in such a way as to not compromise security too much. Of course, NOPASSWD:ALL could be used instead which you are free to do yourself if you so desire, but I am reluctant to do it as the default for a general distro (although this is what I do in pdaXii13)

adding sudo to the exec line in all desktop files would not really be required, but only for the system tools which will probably will be replaced in the future (see pdaXcfg)...

also, note that I do not have a 7x0 or 8x0 so all the fixes are primarily for C3x00/C1000 models because when I find bugs on them, I can fix and test them, but for 7x0/8x0, I cannot so I just package the same bug fixes for r197. The only main difference for the r197 sp package is that the xpdf binary is compiled without specific optimisations and the ipkg.conf file has a different feed entry. although, i try to adjust the xmodmap file for 7x0/8x0, i cannot test whether my fixes actually work.
please report problems/bugs for 7x0/8x0 with as much details as possible (and solutions as well if you have any) and i will try to incorporate them into the SPs. however, there is no guarantee that the fixes will work until you test and verify them...


- shutting off randomly for no reason

this is actually a power saving feature. just change the timeout to be longer.

- apm issues

more details please....

- screen not refreshing after exiting X

not a problem for c3x00/c1000 but this can be fixed

- audio doesn't shut off when headphones are plugged-in

need to see and check, but probably won't be fixed until the next kernel release...

- screen fading doesn't work with Fn+3 and 4 keys

this has been fixed in sp7 (at least it works for C3x00/C1000)


The halt script needs some work to unmount everything cleanly (I had to do a lot of work with it on pdaXii13 which I have not done yet in pdaXrom)

The next release of pdaXrom will have a GUI installer with system backup and restore feature to replace the nand backup/restore feature. I may also implement zbackup on pdaXrom (if time permits) so you can create system snapshots that you can use to flash back your system.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.