Help - Search - Members - Calendar
Full Version: Installing Xserver On Console Image
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
dolcex
After installing the Angstrom console image, how does one go about installing packages to enable xserver? I got to a point where X would try to start and then it says no screen found. I've searched everywhere and found no answer.

Thank you.

p.s. I know it's easier to install the X image, but I have a reason for wanting to install the base.
koen
QUOTE(dolcex @ Jul 9 2007, 04:26 PM)
After installing the Angstrom console image, how does one go about installing packages to enable xserver?  I got to a point where X would try to start and then it says no screen found.  I've searched everywhere and found no answer.

Thank you.

p.s. I know it's easier to install the X image, but I have a reason for wanting to install the base.
*


This was been answered a few times on the mailinglist, please follow http://www.angstrom-distribution.org/contact in the future
dolcex
The only relevant message I found is
http://lists.linuxtogo.org/pipermail/angst...une/000300.html
and it does not answer my question. I don't want to reflash with the x11 fs - I want to manually install required packages to get x11 up and running.

p.s. as pointed out before, there is no search function for the archives (I suppose I could have googled the domain).


QUOTE(koen @ Jul 9 2007, 10:03 AM)
QUOTE(dolcex @ Jul 9 2007, 04:26 PM)
After installing the Angstrom console image, how does one go about installing packages to enable xserver?  I got to a point where X would try to start and then it says no screen found.  I've searched everywhere and found no answer.

Thank you.

p.s. I know it's easier to install the X image, but I have a reason for wanting to install the base.
*


This was been answered a few times on the mailinglist, please follow http://www.angstrom-distribution.org/contact in the future
*

koen
My points remain, it was discussed and answered a few times on the mailinglist, most recently *yesterday*, and if you had checked the news on the frontpage....
dolcex
Sorry to beat the dead horse, but I still don't see an answer. I'm an intelligent person, yet I am struggling to find this...

Anyway, forget it. I'll try and figure it out.

QUOTE(koen @ Jul 9 2007, 10:44 AM)
My points remain, it was discussed and answered a few times on the mailinglist, most recently *yesterday*, and if you had checked the news on the frontpage....
*
koen
http://www.angstrom-distribution.org/contact has 2 links in the bodytext, so you have 50% chance (practically even more, since the first link is the one you want).

The first news post on the frontpage links to the gmane version of the mailinglists which has...

*drumroll*

a search function

To summarize: you want to consult the mailinglists (archives) for any questions, not any forum, as the contact page makes clear.
nodens
QUOTE(koen @ Jul 9 2007, 10:56 PM)
The first news post on the frontpage links to the gmane version of the mailinglists which has...

*drumroll*

a search function

To summarize: you want to consult the mailinglists (archives) for any questions, not any forum, as the contact page makes clear.
*


A lot of people seems to have trouble to get this right.

Maybe a link to the search function in the contact page would help ? Also, "support" could me more appropriate than "contact", even if it's not the main purpose of the mailing lists.
dolcex
For anyone that cares, the message that I have finally come to is here:
http://lists.linuxtogo.org/pipermail/angst...uly/000466.html

The meat is:

QUOTE
# ipkg update

Install the X server (specific to the C760 - See
http://www.openembedded.org/repo/org.opene...chine/c7x0.conf
)
# ipkg install xserver-kdrive-w100

From
http://www.openembedded.org/filebrowser/or...kages/angstromI
found out which are the packages needed for the X11 image
# ipkg install  task-base-extended angstrom-x11-base-depends
angstrom-gpe-task-base angstrom-gpe-task-settings

This will give you a fully working GPE environment.


I'm about to try it before the gf gets home... then it's Resident Evil 4 time smile.gif


QUOTE(koen @ Jul 9 2007, 12:56 PM)
http://www.angstrom-distribution.org/contact has 2 links in the bodytext, so you have 50% chance (practically even more, since the first link is the one you want).

The first news post on the frontpage links to the gmane version of the mailinglists which has...

*drumroll*

a search function

To summarize: you want to consult the mailinglists (archives) for any questions, not any forum, as the contact page makes clear.
*
dolcex
Result: Angstrom splash screen displays, then gpe-dm tries to start (or maybe it does), and them I'm dumped to the shell where it says "can't open display :0"

I installed xserver-kdrive
There are other kdrive packages... maybe that wasn't the right one.


QUOTE(dolcex @ Jul 9 2007, 02:44 PM)
For anyone that cares, the message that I have finally come to is here:
http://lists.linuxtogo.org/pipermail/angst...uly/000466.html

The meat is:

QUOTE
# ipkg update

Install the X server (specific to the C760 - See
http://www.openembedded.org/repo/org.opene...chine/c7x0.conf
)
# ipkg install xserver-kdrive-w100

From
http://www.openembedded.org/filebrowser/or...kages/angstromI
found out which are the packages needed for the X11 image
# ipkg install  task-base-extended angstrom-x11-base-depends
angstrom-gpe-task-base angstrom-gpe-task-settings

This will give you a fully working GPE environment.


I'm about to try it before the gf gets home... then it's Resident Evil 4 time smile.gif


QUOTE(koen @ Jul 9 2007, 12:56 PM)
http://www.angstrom-distribution.org/contact has 2 links in the bodytext, so you have 50% chance (practically even more, since the first link is the one you want).

The first news post on the frontpage links to the gmane version of the mailinglists which has...

*drumroll*

a search function

To summarize: you want to consult the mailinglists (archives) for any questions, not any forum, as the contact page makes clear.
*

*

dolcex
The solution for Akita is:

# ipkg update
# ipkg upgrade
# ipkg install xserver-kdrive-fbdev
# ipkg install task-base-extended angstrom-x11-base-depends angstrom-gpe-task-base angstrom-gpe-task-settings esd
grog
QUOTE(dolcex @ Jul 10 2007, 10:42 AM)
The solution for Akita is:

# ipkg update
# ipkg upgrade
# ipkg install xserver-kdrive-fbdev
# ipkg install  task-base-extended angstrom-x11-base-depends angstrom-gpe-task-base angstrom-gpe-task-settings esd
*

Thanks for letting us know. I'll update the Angstrom wiki entry. I notice that you added esd from what was originally recommended. What was the reason? thks
dolcex
I don't know why esd was required - but gpe-dm wouldn't start without it.

Seems that Angstrom sites are down at the moment....

QUOTE(grog @ Jul 10 2007, 11:42 AM)
QUOTE(dolcex @ Jul 10 2007, 10:42 AM)
The solution for Akita is:

# ipkg update
# ipkg upgrade
# ipkg install xserver-kdrive-fbdev
# ipkg install  task-base-extended angstrom-x11-base-depends angstrom-gpe-task-base angstrom-gpe-task-settings esd
*

Thanks for letting us know. I'll update the Angstrom wiki entry. I notice that you added esd from what was originally recommended. What was the reason? thks
*

grog
QUOTE(dolcex @ Jul 10 2007, 02:05 PM)
I don't know why esd was required - but gpe-dm wouldn't start without it.

Interesting. I don't have that intalled & it works fine for me.

QUOTE
Seems that Angstrom sites are down at the moment....
*

I noticed that too huh.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.