Help - Search - Members - Calendar
Full Version: New Poky Image, How To Use A Standard Mouse ?
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > Angstrom & OpenZaurus
amrein
I run Qemu like this :

# /usr/bin/qemu -kernel '/home/camrein/rpm/bzImage-2.6.21-qemux86-blinky-3.0.bin' -append 'root=/dev/hda' -boot c -m 512 -hda '/home/camrein/rpm/poky-image-sdk-qemux86-blinky-3.0.rootfs.ext2' -net nic,vlan=0 -net user,vlan=0 -localtime -soundhw sb16

After kernel, X11 start, then the calibration process begin. No way to have my ps2 mouse recognized. I can't click nor move any pointer. Any solution other than removing /etc/X11/Xsession.d/30xTs_Calibrate ?

Without 30xTs_Calibrate the mouse won't work, just the keyboard sad.gif

Some help is welcome. smile.gif
malik
@amrein> not sure, maybe this link helps you out: http://wiki.clug.org.za/wiki/QEMU_mouse_not_working

there is no option using the newer versions of qemu without the accelerator kqemu as before, right?
qemu asks for it. i hate to do all the steps as i dont find an rpm for my distribution, compiling gcc
3.3.6 ...

can someone post his experiences with poky 3.0?

malik
amrein
I tried " export SDL_VIDEO_X11_DGAMOUSE=0" but it doesn't work.

I'm using Mandriva Spring (2007.1), the best Mandrivalinux release ever.
malik
QUOTE(amrein @ Aug 6 2007, 08:40 PM)
I tried " export SDL_VIDEO_X11_DGAMOUSE=0" but it doesn't work.

I'm using Mandriva Spring (2007.1), the best Mandrivalinux release ever.
*


I was wrong: One may start qemu without kqemu, option '-no-kqemu'.

I also tried the poky and also an angstrom image yesterday, copied their ext2 rootfs into an
image and started qemu as you described above. You are right, the mouse does not work
with my hint. Does no one have a solution for this? Which feed i may use for poky, is there
any? Maybe some more questions in another thread...

malik
Hrw
To run Poky in qemu you need recent CVS or qemu binary from OpenedHand. It is written on Poky Linux website.
malik
@hrw> thanx for the hint, but some problems arised, when
i tried to run the poky-qemux86-blinky images:

* the patched qemu version of opened-hand does not contain the
different bios types (i used the unstable feed). I copied them
from another qemu version and repackaged everything using alien.

* the poky script refuses to start with the message:
"Error, unsupported machine type qemux"
(adding "-std-vga -usb -usbdevice wacom-tablet" to the above command line
gives the desired mouse)

Some comments:

* i like it, no schnick-schnack, i.e. very plain design, just the right
thing i would see on mobile devices, also reminds me of the openmoko
approach.

* the patched qemu version seems to be an optimised one for the official
blinky images, it does not work with the daily builds (no mouse).

*the opened-hand logo looks like fatimas hand, no doubt:-)

malik
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.