Help - Search - Members - Calendar
Full Version: Openvpn In Pdaxrom- Help Setting It Up
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
aeazocar
Hi to all,

I am trying to set OpenVpn now in pdaXrom and variant (weeXpc).
With JPMATRIX's help I was able to set it up in Cacko 1.23. In other words config files work.

I have installed from one of the feeds:
OpenVpn 2.0.5
lzo 2.0.2

Created a directory to contain the configuration files:
~/hotspotvpn2

Change to that directory and execute "openvpn hotsoptvpn2.ovpn", tried sudo.

and I get back:
openvpn: error while loading shared libraries: liblzo2.so.2 cannot open shared object file: No such file or directory

Regards.
Alejandro.
kkazakov13
Can you try with my packages?

http://z.drun.net/packages/lzo_2.0.2_armv5tel.ipk
http://z.drun.net/packages/openvpn_2.0.9_armv5tel.ipk


I used in a weekly basis without a problem.
aeazocar
kkazakov13

Thank you very much for the files.
The initial problem is gone, but a new one has appeared:

Console message "Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)"

I check in the conf file and made use of tun.
After checking JPMATRIX instructions there was a tun package that I supposed defined the tun device.

Any idea in how to solve / work around this.

Again thank you very much, for your help.

Regards.
Alejandro.
kkazakov13
That's my script for starting the tunnel, maybe you can use parts of it smile.gif

CODE
#!/bin/bash

modprobe tun

if [ ! -c /dev/net/tun ]; then
   mkdir -p /dev/net
   mknod /dev/net/tun c 10 200
fi

openvpn --config ./openvpn.conf --daemon
aeazocar
kkazakov13

Thank you again for the replay; but I have not been able to complete the connection.

I follow the sequence of command that you use in your script:
.- Connect to the internet.
.- Open console
.- Type "modprobe tun" get Can't locate module tun
.- Type "mkdir -p /dev/net"
.- Type "mknod /dev/net/tun c 10 200"

Notes:
Reading with in the forums I found that most people put the configuration files on
/etc/openvpn
I move the openvpn conf files there.

Now I need to tell you that I am not clear about the meaning of the following line:
openvpn --config ./openvpn.conf --daemon

.- cd /etc/openvpn
.- Type openvpn hotspotvpn2.ovpn

Unfortunately with the same result with TUN/TAP
Console message
"Note: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)"
"Note: Attempting fallback to kernel 2.2 TUN/TAP interface"
"Note: Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)"

Any further help will be appreciated, really... really appreciated.
kkazakov13
QUOTE(aeazocar @ Aug 9 2007, 07:08 AM)
.- Type "modprobe tun" get Can't locate module tun

...

"Note: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19)"


That's your problem.

I uploaded the tun module package for 2.4.20 kernel, that I use on my setup.

http://z.drun.net/packages/tun-module_2.4.20-1_arm.ipk
aeazocar
kkazakov13
smile.gif tongue.gif smile.gif

Thank you again.....
I now have a working OpenVPN! in manual mode but it works laugh.gif
This is very important to me, because I spent a lot of time traveling and I am force to use either hotspots or someone else network.

My goal is not to use / store any personal data in the company computer!
Now instead of traveling with:
Zaurus 3200 > goes every where with me rolleyes.gif
IBM Z61 > company
Powerbook G4 > personal

I will take only the first 2; only need to figure out what to do about skype wink.gif

My next challenge is to automate the process based on the connection profile.
If you can point me in the right direction it will be grate, in the mean time I am starting to look in to shell scripting.

Any way thank you very much.

Regards
Alejandro.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.