Help - Search - Members - Calendar
Full Version: Pdaxii13 5.4.8 Hostap And Wpa
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
Lemuus
I was testing the new 5.4.8 release, and wpa is not working with the new modules, i am not sure what is the problem... but if i use the hostap modules from 5.4.7 works perfect.
I also tested the new spca module, works with my camera with a lot of interference, but works!!!!
well that's for the moment...
Daniel.
danboid
Anybody else having problems with wpa under 5.4.8?
Meanie
QUOTE(Lemuus @ Aug 10 2007, 11:28 AM)
I was testing the new 5.4.8 release, and wpa is not working with the new modules, i am not  sure what is the problem... but if i use the hostap modules from 5.4.7 works perfect.
I also tested the new spca module, works with my camera with a lot of interference, but works!!!!
well that's for the moment...
Daniel.
*


did you copy an old set of hostap modules from a 5.4.7 build on top of 5.4.8 in order to get it to work?
i don't have wpa so cannot test any wpa functionality, but the new hostap modules allow me to scan for wifi networks using iwlist and hence wifi-radar which the old ones did not let me do.

did you also upgrade the kernel? the kernel is included in the tools.tar file for 1000/3100/3200 whereas for the c3000, it needs to be downloaded separately as zImage-2.4.20.bin

the spca module works perfectly with some of my cameras whereas works not so good or not at all with some of my other cameras.
Lemuus
QUOTE(Meanie @ Aug 11 2007, 05:27 AM)
did you copy an old set of hostap modules from a 5.4.7 build on top of 5.4.8 in order to get it to work?
i don't have wpa so cannot test any wpa functionality, but the new hostap modules allow me to scan for wifi networks using iwlist and hence wifi-radar which the old ones did not let me do.

did you also upgrade the kernel? the kernel is included in the tools.tar file for 1000/3100/3200 whereas for the c3000, it needs to be downloaded separately as zImage-2.4.20.bin

the spca module works perfectly with some of my cameras whereas works not so good or not at all with some of my other cameras.
*


yes and yes, i copy the old hostap modules from 5.4.7 on top of 5.4.8, and used the updated tools.tar.
Meanie
QUOTE(Lemuus @ Aug 12 2007, 10:37 AM)
QUOTE(Meanie @ Aug 11 2007, 05:27 AM)

did you copy an old set of hostap modules from a 5.4.7 build on top of 5.4.8 in order to get it to work?
i don't have wpa so cannot test any wpa functionality, but the new hostap modules allow me to scan for wifi networks using iwlist and hence wifi-radar which the old ones did not let me do.

did you also upgrade the kernel? the kernel is included in the tools.tar file for 1000/3100/3200 whereas for the c3000, it needs to be downloaded separately as zImage-2.4.20.bin

the spca module works perfectly with some of my cameras whereas works not so good or not at all with some of my other cameras.
*


yes and yes, i copy the old hostap modules from 5.4.7 on top of 5.4.8, and used the updated tools.tar.
*



hmm, I will test again with the older hostap modules to see if they work too and if so, will make them default instead.
Meanie
QUOTE(Meanie @ Aug 12 2007, 12:26 PM)
QUOTE(Lemuus @ Aug 12 2007, 10:37 AM)
QUOTE(Meanie @ Aug 11 2007, 05:27 AM)

did you copy an old set of hostap modules from a 5.4.7 build on top of 5.4.8 in order to get it to work?
i don't have wpa so cannot test any wpa functionality, but the new hostap modules allow me to scan for wifi networks using iwlist and hence wifi-radar which the old ones did not let me do.

did you also upgrade the kernel? the kernel is included in the tools.tar file for 1000/3100/3200 whereas for the c3000, it needs to be downloaded separately as zImage-2.4.20.bin

the spca module works perfectly with some of my cameras whereas works not so good or not at all with some of my other cameras.
*


yes and yes, i copy the old hostap modules from 5.4.7 on top of 5.4.8, and used the updated tools.tar.
*



hmm, I will test again with the older hostap modules to see if they work too and if so, will make them default instead.
*



I confirm that the hostap modules from 5.4.7 work perfectly for scanning and cards like the netgear are assigned to wlan0 instead of eth0 even with the older modules, hence the fixes must have come from the new kernel and the updated wireless tools.

Use this ipk to downgrade your hostap modules so that everything will work.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.