Help - Search - Members - Calendar
Full Version: Unusual Wpa Problems With Cacko 1.23, Ambicom Wl11
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Model Specific Forums > Sharp Zaurus > C1000/3x00 General discussions
Hi all,

I just recently got my sl-c1000 and am loving it so far. I've used several PDAs in the past and think this is by far my favorite. The only issue I can't resolve is getting WPA to work under cacko 1.23 with an ambicom wl1100c-cf. I've followed the helpful instructions here on this site and keep hitting roadblocks. Here's what I'm getting so far.

The card is recognized when inserted.

I followed the instructions on and modified the necessary files in Qkonsole.

The following is what I get with cardctl status
Socket 0;
3.3v 16bit PC Card [suspended]
Socket 1;
no card

The following is what I get with cardctl info
PRODID_2="WL1100C-CF 802.11b CF-Card"

I did run hostap_diag wlan0 and got the following:

ioct1[PRISM_IOCTL_HOSTAPD]: Connection timed out. Could not communicate with the kernel driver.

When I try to connect to my WPA protected network, the card flashes several times and then stops. The connection dialog says "network offline".

I've tried changing passphrases on my router and on the zaurus to no avail.

I have been able to connect to my network under WEP. After disconnecting from the WEP network I have to eject the card and re-insert it to get it working again. This didn't happen under the original sharp rom.

I've searched all over the web trying to find a solution to this but have come up empty handed. Any help would be appreciated. I posted this original, before I was validated here, at
I'm not really sure why but, it works now.
You say you modified "all the files" - I'm not sure what that means!

I have been fighting with WPA/PSK on the C1000 and C3200 using an AmbiCom WL1100C card and every OS I can find for weeks, so I can share what I have done, but I don't have a sure recepie for success :-(

I have modified hermes.conf and hostap_cs.conf to add the card specifications and driver info:
device "hostap_cs"
class "hermes"
module "hostap", "hostap_cs"

card "AmbiCom", "WL1100C 802.11b CF-Card", "2.2"
  manfid 0xd601, 0x0002
  bind "hostap_cs"

Then I set up wpa_supplicant.conf with my ssid and psk information, and give the command,
wpa_supplicant -c /etc/wpa_supplicant.conf -D hostap_cs -i wlan0 -B

IIRC that was enough to get it going in Cacko I may have had to install hostap_driver and wpa_supplicant also, I don't remember. They DO seem to be necessary in pdaXii13 however.

I'm still trying to achieve the following:
- connect to a WPA enabled lan
- have either Kismet or Wellenreiter available to audit for rogue APs
- Have ethereal avilable for packet analysis

(Not at teh same time! Wellenreiter and kismet don't run while connected tot he lan!)

It seems I can get two out of three most of the time, but somehow the programs are conflicting with each other inwasys I haven't been able to discern, and my Linux expertise is somewhat wanting...


Sorry the files I was refereing to are the ones listed here on I originally posted this on Tyrannozaurus and forgot to change parts of the post. However, I did finally connect to my wpa network. I simply ran through the tutorial again (for the nith time) and it worked.

Have you noticed the battery running low allot quicker with your wifi card enabled?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.