Help - Search - Members - Calendar
Full Version: Cacko Flash Problem (3200)
OESF Portables Forum > Everything Else > Archived Forums > Distros, Development, and Model Specific Forums > Zaurus Distro Support and Discussion > Sharp ROMs
I took a detour down the side road called pdaXrom and spent a few frustrating days trying to get WPA networking to work, and I finally gave up and decided to come back to Cacko.

First, I re-partitioned the hard drive to its factory settings using the partitioning utility on the pdaXii13 installer, then I restored the files to those partitions from Trisoft's site, and finally did a NAND restore using Trisoft's ROM.

Then having a working Sharp rom, I flashed Cacko 1.23 in the usual manner. I set the root partition to 64MB and flashed the new ROM. Everything went as expected except that when I try to boot after flashing the ROM, I get the following message in an endless loop:

grep: /var/lib/pcmcia/stab No such file or directory

I've tried flashing twice, with a freshly downloaded copy of the files the second time, but the same result.

Any help or suggestions would be welcome!

did you reformat after patritioning?
Good point.... I'll give that a try. Thanks smile.gif

One Hour Later....

No joy here sad.gif

I went to the Zaurus shell (D + B reset) and did the following, following Trisoft's instructions:
Fdisked the 3 partitions
Formatted the 3 partitions
mkdir .sys on the two jffs2 partitions
Restored the files to the two .sys directories from the Trisoft download
Rebooted into maintenance menu (D + M reset)
NAND restore of Trisoft ROM
booted OK
Flashed Cakco - no error messages.
Rebooted - same results as in the original post sad.gif

if you create a dummy file called stab, will it complete?
QUOTE(walts @ Aug 31 2007, 03:19 PM)
  I set the root partition to 64MB and flashed the new ROM.

Look at the pinned thread about cacko being released.
It states to flash "at least 32mb" partition.
Maybe 64mb is too much.
some people use more than 32mb (such as 34 or 36 mb, to eliminate "bad blocks" in memory)
I always set the root partition to 32mb on my SL-C3100 whenever I flash/reflash cacko with no problems. (but thiis machine has never had pdaxrom flashed onto it.)
I didn't try the fake stab file.

I don't think making hte root partition too big would do any harm. there are postings in the forum recommending making it the maximum of 121 MB on the modems with a hard drive.

In any event, I made up my mind to fight my way through pdaXrom since I could not get Cacko going. I managed finally to install pdaXii13 and got it working with WPA. You can read about it here.

Since my Cacko installation would need pdaXQTrom for the software I need, this is really a better solution.


I don't want to start a new post for this and it is related to this installation thing, so I hope you don't mind me asking a couple of questions.

The history is that I have a 3200 which was working with Cacko which would occassionally blank out when not on power (maybe the backlight bug, I don't know). I decided to change ROMs as I seem to recall Cacko going quite well.

The long and the short is that I've been through, Angstrom, Debian and PDAXROM and none of them have actually booted. I've had various hdd Errors (hdd Error, hdd2 error)

I have now followed the restore using Trisoft's files and have that installed, I think, but it's in Japanese (I've added an ipk which adds English to the Japanese on menus, but still not ideal). I presumed their restore would be in English or German as they translate their machines, don't they? What is also not ideal, is that I did this installation and it works fine - until I do a reboot and then I get "hdd not initialised."

So, the questions are:

a)Do these disk symptoms leap out and say to the experts: you haven't done x to the disk you cretin - it's all over the place if you'd only look?
b)Do I have to have this .sys directory with all ROMs taken from the Trisoft site?

Thanks for you time.
hmm, well, it suggests to me that you might want to start from scratch with the hard drive partition and formatting.

use "fdisk" to delete all partitions completely, then create new ones to be certain the disk geometry is set correctly and labels are correct.

then format all the partitions

then, to run sharp or derivative, install the files required to each partition

then try booting cacko or sharp

that's what I would do to be certain
QUOTE(speculatrix @ Jan 8 2008, 03:16 PM) *
then format all the partitions

To be honest, this particular action has been lacking and could very well be the problem. Hopefully I've just been an idiot. Will try it tomorrow night when I have a bit of time and let you know.

Thanks for your time


Don't know that this will be much help. Battled through and it seems that formating was one problem. The reason I hadn't formatted was that the installs claim to format themselves. mk2fs and mkdos. This is for various hdd1 hdd2 error messages (and check the layout too which is in the post linked below).

If you get the message "hdd not initialized" the problem is lacking .sys files (this was the second problem).

Trisoft have all the answers. You can download the .sys files from them.

See this post for link to those and for disk partitioning.

I got my cacko Rom from

as wasn't answering.

I shall return to find out how to get a driver for my wireless card, but I'm going to rest on my slightly tatty laurels for a bit.

Thanks for the help.

glad you're back up and running. I remember when I too "broke" my cacko install when I repartitioned the drive and didn't understand about the special files, I remember feeling tons of relief just to have it booting and working normally!

well done, take a break, and then you can play with wireless, WPA and all that.
Hi, MorayJ

im having the same problem with my sl-c3200 an cacko.. bored of oz and opie (unsolved sound problem) turn to cacko... everything seems to be ok with sound, but i have no working hdd. When its booting get the hdd errors (hdd1, 2 or 3). Pressing CTRL+C cacko ends booting and have everything (less my hdd of course). already play with fdisk and many file formats and nothing.
If i do the trisoft way i assume solve my problem.. but, i have to reflash cacko? Im asking that cause i can see the correct parameters on the fstab file.. My SD card isnt working either (1gb and 2gb). capacity of sd may be the problem?..

Thanks in advance.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.