Help - Search - Members - Calendar
Full Version: Wpa, Hostap And Ambicom Wl1100c Problems
OESF Forums > Distros, Development, and Model Specific Forums > Distro Support and Discussion > pdaXrom
I've tried various suggestions in the "wifi-radar not working" thread, to no avail to get connected to my wireless router in pdaxii13
My ambicom card connects fine to this router with WPA in Cacko on my other Zaurus (C3100).
I have the later firmware
PRI 1.1.1
STA 1.8.0
I read a thread called "WPA help needed" and there was suggested to use hostap_diag to read the firmware version.
hostap_diag is part of hostap_utils (included in pdaxii13 5.4.9)
It was recommended (in that thread) to install hostap_driver_0.4.7 (I already have hostap_driver_0.4.7-3)
I inserted my card and ran hostap_diag wlan0
I get
host AP driver diagnostics information for wlan0

ioctl[PRISM2_IOCTL_HOSTAPD]: Operation not supported.
Could not communicate with the kernel driver
It should read like this:
NICID: id=0x801b v1.0.0 (PRISM III PCMCIA (SST parallel flash))
PRIID: id=0x0015 v1.1.1
STAID: id=0x001f v1.8.0 (station firmware)
Someone else in that thread said he got his Ambicom card working after installing hostap_driver_0.4.7 from the beta3 feed.
The beta3 feed no longer exists.
Is my newer version of hostap_driver_0.4.7-3 somehow buggy and I need an older version from a now non-existent feed?
I installed hostapd_0.4.7-1 (this wasn't included in pdaxii13 sally)
when I issue the command
hostap_diag wlan0
I get
host AP driver diagnostics information for wlan0

ioctl[PRISM2_IOCTL_HOSTAPD]: No such device
Could not communicate with the kernel driver
What about trying wifi0 instead of wlan0? (Or even eth0...but that probably won't work).

Also, the beta 3 feed didn't disappear -- it's still here: Unless you meant some other beta 3 feed, of course...?
In pdaxii13 I had everything working just fine.

I created a wpa_supplicant.conf in /etc with just the bare essential information (after mv-ing the existing one)



Then I installed the hostap 0.4.7 and wpa_supplicant 0.4.7 files. I don't know why this was necessary, but there seems to be something wrong with the installed ones.

I used the LAN & Wifi applet to set up just the SSID for my network and then edited /etc/pcmcia/network.opts to add WPA="y" under my network. (I don't know if this is necessary.)

Then I set up my network in wifi-radar, forcing it to use wlan0, and specifying hostap under WPA and it all worked!


I had some sort of disaster and could not get any programs to work, so I tried restoring the Zaurus from the backup I had made a few days ago. The backup wouldn't install - something wrong with initrd.bin


I did a clean install of pdaXii13 5.4.9 and upgraded it to pdaXiiv2
wifi-radar now does not work. It gives:
Traceback (most recent call last):
    File "/usr/local/bin/wifi-radar", line 1580, in ?
         auto_profile_order = auto_profile_order.split(',')
AttributeError: 'list' object has no attribute 'split'

(I typed that, I hope it's exact :-)

AND NOW......

I can still get connected to my AP with the following commands:
#ifconfig wlan0 up
#wpa_supplicant -Dhostap -iwlan0 -c/etc/wpa_supplicant.conf -B
#dhcpcd wlan0

I hope that helps you get connected.
If anyone can help me with getting wifi-radar to work, I'd be grateful.


What version of wifi-radar did you install?
I had problems with wifi-radar_1.9.8-1 so I uninstalled it and installed wifi-radar_1.9.8-2 (this is on or near page 24 or 25 of the new packages announcements thread).

EDIT, I couldn't find wifi-radar_1.9.8-2 in the new packages announcements thread.
I'll look on meanie's feed.
It's here.

BTW, I got my wifi working, see this post.
" Wifi Probs, No Connection, Hostap Not Loading (fixed) I think I have a stable connection now"
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2016 Invision Power Services, Inc.