Help - Search - Members - Calendar
Full Version: Quasar Media Player Released For Sharprom And Pdaxrom
OESF Forums > General Forums > General Support and Discussion > Software
Pages: 1, 2, 3
enclose789
QUOTE(the_oak @ Nov 7 2007, 02:02 PM) *
The mplayer I have installed is: mplayer-bvdd version 1.1.5-1. It installed links to itself in several places (/home/Qtpalmtop/bin/ being one of them). I think I downloaded it from here:

http://atty.skr.jp/pub/zaurus/mplayer/mpla...1.1.5-1_arm.ipk

Hope this helps.


Thank you the_oak, it works!! Now I could play the mp3 and mpeg files. (I thought that the original "mpegplayer" and "mplayer" are the same file, please forgive me for making such silly mistake.)

But I could not play the mpeg in landscape model (fullscreen). When I played the mpeg files, it shows a small screen (about quarter of the whole screen). I had tried to add "vop=rotate=1" to mplayer.conf on my Z (I refer to this topic "Video playback on the 6000 - OESF Forums"
http://www.oesf.org/forum/index.php?showto...6000&st=30), however, I could not add those words in it because my mplayer.conf shows malformed characters when I open it with Zedit.

Could someone please tell me how to make it play MPEG in landscape model?? Thanks in advance.
the_oak
I don't have time right now, but there is an old thread about this and Gab 74 wrote this:

http://www.oesf.org/forum/index.php?s=&...ost&p=50101

If I remember right, this fb.modes file was necessary. Also you need to check one of my posts in this thread for mplayer options in Configuration settings for Quasar.
enclose789
QUOTE(the_oak @ Nov 8 2007, 04:34 AM) *
I don't have time right now

I’m so sorry for disturbing you, please do me a favor once you are available again.

QUOTE(the_oak @ Nov 8 2007, 04:34 AM) *
but there is an old thread about this and Gab 74 wrote this:
http://www.oesf.org/forum/index.php?s=&...ost&p=50101

Ha, we cited the same thread with different pages.

QUOTE(the_oak @ Nov 8 2007, 04:34 AM) *
If I remember right, this fb.modes file was necessary.

Yes, I had already created this file in /etc/.

QUOTE(the_oak @ Nov 8 2007, 04:34 AM) *
Also you need to check one of my posts in this thread for mplayer options in Configuration settings for Quasar.

Do you mean this?

QUOTE(the_oak @ Oct 28 2007, 09:32 AM) *
For other SL-6000 users information, the mplayer settings I used are:
-vo fbdev -fbmode qvga -vm -vop rotate=1

If yes, I had add this setting in mplayer configuration already. But it doesn't work, I guess it could be that I have not add "vop=rotate=1" in my mplayer.conf successfully.

Due to the mplayer.conf always shows malformed characters when I open it via Zedit, I need someone help me to add "vop=rotate=1" in it and then give it a try. Any suggestions?? Thanks a million!!
the_oak
QUOTE
I’m so sorry for disturbing you, please do me a favor once you are available again.

I didn't mean that you were disturbing me, I just had an appointment to get to. smile.gif
QUOTE
If yes, I had add this setting in mplayer configuration already. But it doesn't work, I guess it could be that I have not add "vop=rotate=1" in my mplayer.conf successfully.

I did not enter those options in mplayer.conf. I entered them in Quasar's Mplayer tab on the Tools >> Configuration menu.

My mplayer.conf (in /home/QtPalmtop/etc/mplayer) only contains the following:

CODE
monitoraspect=4:3
#monitoraspect=16:9
#monitoraspect=3:4


Within the Quasar program, click on "Tools" then "Configuration". On the MPlayer tab, put a check in the box beside "Use additional options:"
and put

-vo fbdev -fbmode qvga -vm -vop rotate=1


in the box

My Mplayer location simply says: mplayer
enclose789
the_oak, thank you very much, now I can play the MPEG file in landscape mode laugh.gif !!

for other 6000L user's reference, below are the steps that I do for my Z (under SharpRom) for playing the musics via Quasar Media Player:

1. Install mplayer-bvdd version 1.1.5-1 (http://atty.skr.jp/pub/zaurus/mplayer/mplayer-bvdd_1.1.5-1_arm.ipk)
2. Install Quasar Media Player.
3. According to gab74's statement, creating fb.modes in /etc/, and it contains the following:
CODE
mode "qvga"
geometry 240 320 240 320 16
timings 1 2 3 4 5 6 7
endmode

4. According to the_oak's statement, creating mplayer.conf in /home/QtPalmtop/etc/mplayer, and it contains the following:
CODE
monitoraspect=4:3
#monitoraspect=16:9
#monitoraspect=3:4

5. According to the_oak's statement, within the Quasar program, click on "Tools" then "Configuration". On the MPlayer tab:
(1)Put a check in the box beside "Use additional options:", and put
"-vo fbdev -fbmode qvga -vm -vop rotate=1"
in the box
(2)Keep the box which below "Mplayer location" simply says "mplayer"

Thanks again, the-oak, you had made my dream come true biggrin.gif
Further thanks to eviLjazz and gab74!!
the_oak
Well stated Enclose789!

And Thanks again to eviLjazz for this best of breed media player!!
eviLjazz
ZDevil, thanks for porting to Debian EABI! I've updated the download page to point to your binary deb package.

ofels, any news on the OpenEmbedded/Ångström package/recipe?

Btw, for those eager to know what's next, you can always check the Trac timeline for the current status or my Twitter page for more recent information.
I was also entertaining the idea of having nightly builds of Quasar. Right now I'm experimenting with some new features, so it's too early for that, but we'll see...
johnla
F*CKIN BEAUTIFUL !!!!!!!!!!!
Amazing work!
ofels
QUOTE(eviLjazz @ Nov 13 2007, 12:43 AM) *
ofels, any news on the OpenEmbedded/Ångström package/recipe?


The recipes are in, now they must be included in the feed build which I forgot to add *sigh*

Oliver

Asterix
Way to go! Excellent player! biggrin.gif

Asterix
Jon_J
This is on my Cacko SL-C3100
This should playback *.flv files, shouldn't it?
I have fullscreen off and "-vo bvdd" set as option for mplayer for all my video formats.
I also disabled double buffering.
I have these settings the same in zplayer, which plays this video without any problems.
I tried the default settings the first time I played this video, and my Z locked up.

I have this youtube video that just causes Quasar to lock up, and go to a white screen (other times the screen is all black)
The audio plays OK.
When I use my "Cancel" button, the screen returns to what is shown in the attached image.
I cannot get past that screen, unless I reboot or use the reset button.
I can get to the "Reboot" button in the shutdown app under settings by navigating with the keyboard.
I was going to attach the offending video, but it is 13MB.
eviLjazz
Okay, thanks for reporting. I experienced the problem once while trying to play a corrupt MPEG1 file. I thought it was a problem in Atty's MPlayer binary. But thanks for the ZPlayer hint. I will try to reproduce the problem here and see what ZPlayer does differently. The MPlayer encapsulation in Quasar has changed quite a lot from the original ZPlayer sources.

QUOTE(Jon_J @ Nov 20 2007, 01:05 PM) *
I was going to attach the offending video, but it is 13MB.


I'll PM you a temporary FTP account, where you can upload the file if you want.
ofels
QUOTE(Jon_J @ Nov 20 2007, 10:05 PM) *
I cannot get past that screen, unless I reboot or use the reset button.
I can get to the "Reboot" button in the shutdown app under settings by navigating with the keyboard.


Try the Ctrl-Alt-Backspace shortcut to enforce a shutdown of the X server and relogon which is faster than doing a straight reboot.
That might help also.

Oliver
xamindar
QUOTE(ofels @ Nov 21 2007, 02:55 AM) *
QUOTE(Jon_J @ Nov 20 2007, 10:05 PM) *
I cannot get past that screen, unless I reboot or use the reset button.
I can get to the "Reboot" button in the shutdown app under settings by navigating with the keyboard.


Try the Ctrl-Alt-Backspace shortcut to enforce a shutdown of the X server and relogon which is faster than doing a straight reboot.
That might help also.

Oliver

Dude, that totally doesn't work on the sharp rom. Don't suggest things that will have no effect. If he was having this problem on pdaxrom then sure, but this doesn't work for cacko.
ofels
QUOTE(xamindar @ Nov 21 2007, 09:16 PM) *
Dude,


I believe that was meant in a friendlier way than it sounded, right ?

QUOTE(xamindar @ Nov 21 2007, 09:16 PM) *
that totally doesn't work on the sharp rom. Don't suggest things that will have no effect. If he was having this problem on pdaxrom then sure, but this doesn't work for cacko.


1.) I simply missed the platform specs he was referring to, so it indeed will not work for him.
2.) It will work under Angstrom and pdaXrom so it might be useful at least for those folks with similar problems. Even if it it is not helpful for the original poster.
3.) Had a bad day ? Get some sleep cool.gif

Oliver
ZDevil
Hi, eviLjazz,
There is a small issue with my debian armel package. I adapted the control file of the pdaxrom package and left the Depends line blank, which is a little hiccup when installing the armel package from the feed. Could you list the dependencies here? Thanks! smile.gif
eviLjazz
QUOTE(ZDevil @ Nov 24 2007, 02:01 AM) *
Could you list the dependencies here?


The only dependencies are Qt3 and mplayer. I didn't list Qt3 on pdaXrom since it's already included. The same goes for mplayer on pdaXii13.
So, the dependencies on Debian would probably be libqt3-mt and mplayer, not sure though.
cptpike
I'm currently using Quasar .9 on my c1000 with cacko 1.23. I'm still having the rotated half screen video playback problem. I've tried using some of the additional options others have stated, with no results. The problem is occurring when I play video over the network from server. If I drag the exact same file on to my sd card, the playback is in the correct orientation and full screen. Any suggestions?
eviLjazz
QUOTE(cptpike @ Nov 27 2007, 08:04 AM) *
The problem is occurring when I play video over the network from server.


Okay, how do you access the file? Via URL, Samba share, NFS export, etc.?
URL access to video files is problematic with the current version of mplayer.
What video codec were your files encoded in? DivX, XviD, H.264... ? What container-format? AVI, Ogg, Matroska, etc.?
I guess Quasar doesn't recognize that the file actually is a video file, so it's using the wrong settings for playback. That would be a bug, but it totally depends on how you feed the file into the player.
cptpike
Thanks for the quick reply. I'm watching mp4 files with an aac audio codec over a samba share. The same files play fine in Kino2 over the network. I would much rather use quasar though.
geeko
thank you for this program. It is very nice. Is there support for FLAC files?
Capn_Fish
I assume it does.
stupkid
QUOTE(geeko @ Nov 28 2007, 06:49 PM) *
thank you for this program. It is very nice. Is there support for FLAC files?

It just uses mplayer to play the files. So, whatever mplayer supports will work. Quasar is just a really fast and nice front end for mplayer.
undrwater
quasar is not recognizing my mplayer binary. it's located at /mnt/card/opt/QtPalmtop/bin/mplayer and linked to /home/QtPalmtop/bin/mplayer

I've set both locations in Configuration | Mplayer section, and the popup asking if I want to specify the location.
This is on a 6000.
the_oak
Earlier in this thread was some info about using Quasar on the 6000. There is a link for the version of Mplayer that works for me. Also look for the info on fb.modes file. Enclose789 summarized this nicely in page 4 of this thread. Hope this helps.
undrwater
QUOTE(the_oak @ Dec 1 2007, 06:30 PM) *
Earlier in this thread was some info about using Quasar on the 6000. There is a link for the version of Mplayer that works for me. Also look for the info on fb.modes file. Enclose789 summarized this nicely in page 4 of this thread. Hope this helps.


I did read those posts, and I have the correct mplayers, however quasar still refuses to accept the mplayer binary. I've got it installed to sd, and linked to /opt/QtPalmtop/bin/; i've tried to point to both locations without success.

I've got the fb.modes, but I don't think that should hinder quasar from finding the binary.

zplayer works fine...i'm scratching my head. huh.gif
the_oak
Maybe a permissions problem with SD card or folder on SD card?
undrwater
QUOTE(the_oak @ Dec 3 2007, 07:18 PM) *
Maybe a permissions problem with SD card or folder on SD card?


I'll try it, but one would assume zplayer wouldn't work if that were the case. I'll also try a reinstall of quasar.
the_oak
QUOTE(undrwater @ Dec 5 2007, 12:26 PM) *
QUOTE(the_oak @ Dec 3 2007, 07:18 PM) *
Maybe a permissions problem with SD card or folder on SD card?


I'll try it, but one would assume zplayer wouldn't work if that were the case. I'll also try a reinstall of quasar.



Probably this is a stupid question, but did you format the SD card ext2?
eviLjazz
QUOTE(geeko @ Nov 28 2007, 04:49 PM) *
thank you for this program. It is very nice. Is there support for FLAC files?


Yes, mplayer will play FLAC files. Quasar is taking care of reading the meta data via taglib, ie. title, artist, album etc. However, reading embedded cover art images from FLAC isn't complete yet.
eviLjazz
QUOTE(cptpike @ Nov 28 2007, 06:15 AM) *
Thanks for the quick reply. I'm watching mp4 files with an aac audio codec over a samba share. The same files play fine in Kino2 over the network. I would much rather use quasar though.


I've added a new ticket so I can keep track of the problem: http://trac.katastrophos.net/quasar/ticket/16
eviLjazz
QUOTE(undrwater @ Nov 29 2007, 04:47 PM) *
quasar is not recognizing my mplayer binary. it's located at /mnt/card/opt/QtPalmtop/bin/mplayer and linked to /home/QtPalmtop/bin/mplayer
I've set both locations in Configuration | Mplayer section, and the popup asking if I want to specify the location.


Could you enable the logging and debugging feature in Configuration -> General and PM me the output? Assuming that there is an output in /tmp/quasar-log.txt after trying to play a file... Thanks.
eviLjazz
QUOTE(eviLjazz @ Nov 20 2007, 01:52 PM) *
QUOTE(Jon_J @ Nov 20 2007, 01:05 PM) *
I was going to attach the offending video, but it is 13MB.

I'll PM you a temporary FTP account, where you can upload the file if you want.

Thanks for uploading the file. I was able to reproduce the problem here. The problem seems to be the auto-cropping and switch-to-QVGA feature in mplayer that's causing problems in conjunction with the BVDD overlay driver. This is happening in ZPlayer, Kino2 and Quasar and seems to be a problem in Atty's mplayer binary. The BVDD driver somehow doesn't initialize correctly and leaves the driver and/or chipset in an improper state.
Perhaps a newer mplayer version fixes the problem. I have to talk to Atty whether he can still give any instructions on how to compile mplayer with his fixes and the Intel IPP stuff.
Antikx
I've searched this thread and the bug tracker, sorry if I missed it, but is anyone else unable to adjust the volume through the Quasar GUI in pdaXrom R198?
If others are having the problem I'll be happy to file a bug report.
eviLjazz
QUOTE(Antikx @ Dec 11 2007, 08:36 AM) *
I've searched this thread and the bug tracker, sorry if I missed it, but is anyone else unable to adjust the volume through the Quasar GUI in pdaXrom R198?
If others are having the problem I'll be happy to file a bug report.


It's a problem. I guess you're using Matchbox on your setup? The default volume applet in pdaXrom seems to hold exclusive access to the mixer device. Once you remove it from the taskbar, Quasar can access the mixer device again. I experienced the same problem when trying to control the volume from within XMMS, so it seems like it's really a bug in the mixer applet. IMO mixer apps should not keep exclusive access to the mixer device.
Quasar should inform the user if it can't gain access to the mixer device -> ticket #17.
FAQ added.
Antikx
I'm using Celestial Environment (EvilWM), so no match/openbox. but I am running the gkrellmd.
Hmmm... I'll try running evilwm without it and I'll report back.
If that's not it, any other ideas?
Asterix
I put in a ticket at Katastrophos, but I thought I'd repeat it here.

If a directory name contains a percent sign, "%", all files in that directory are not read. The file is added to the playlist, but the entry is empty, ie, there's a line for it, but it's blank. As a result, mplayer returns an error when called to play that file.

I had a directory named "100%Dance", because that's the album name. It took me a bit to figure out why the songs (ripped as ogg/vorbis if that matters) didn't show up in the playlist, but took up space. Once I renamed that directory to "100pctDance" everything loaded fine.

It's easy to work around, but I thought I'd post it. It's the 0.9 Cacko version.

Excellent player. Thanks again!

Asterix
eviLjazz
QUOTE(Antikx @ Dec 12 2007, 02:01 PM) *
Hmmm... I'll try running evilwm without it and I'll report back.
If that's not it, any other ideas?


Could you try the volume control in XMMS and see if that works? If it works, perhaps it's because of ALSA in kernel 2.6? I think there is an option in XMMS that controls which output device is used. If I remember correctly you can tell it to use OSS instead. Perhaps this breaks it.
Quasar only uses OSS to control the mixer. But then again I haven't tried Quasar on kernel 2.6.x yet...
Do you have any other mixer applet running in the background?

QUOTE(Asterix @ Dec 12 2007, 02:08 PM) *
I put in a ticket at Katastrophos, but I thought I'd repeat it here.


Thanks for reporting. I think I know what the issue is here. Expect to see a fix in the next version. smile.gif
eviLjazz
Oh, btw, here are two preview videos of a new feature: Cover Phhlow @ 640x480 wink.gif
http://www.katastrophos.net/downloads/imag...izontalDemo.mov
http://www.katastrophos.net/downloads/imag...erticalDemo.mov
(will play fine in VLC)
ToneBlind
QUOTE(eviLjazz @ Dec 12 2007, 04:09 PM) *
Oh, btw, here are two preview videos of a new feature: Cover Phhlow @ 640x480 wink.gif
http://www.katastrophos.net/downloads/imag...izontalDemo.mov
http://www.katastrophos.net/downloads/imag...erticalDemo.mov
(will play fine in VLC)

That...is...amazing!!!!! blink.gif
Frederic Bergeron
Yeah, indeed, the animation is great, very smooth. Cool!
ofels
QUOTE(eviLjazz @ Nov 13 2007, 12:43 AM) *
ofels, any news on the OpenEmbedded/Ångström package/recipe?


BTW, I forgot to tell that quasar is available in the Angstrom feeds for a while now.

Oliver
eviLjazz
Thanks for the good news, Oliver!
I really need to check out Ångström soon.
All right, back to QScrobbler... wink.gif

UPDATE:
I've released QScrobbler: http://www.oesf.org/forum/index.php?showtopic=25280
Asterix
Another idea for you:

When I turn off the LCD with the 3 key while playing music, it'd be nice if the touch screen was also disabled. You could make it an option for those who don't like that idea. I've inadvertently touched the screen in the top right-hand corner, putting the program into input mode, all while the LCD was off. I had to turn my Z off to get the screen back on, since pressing 4 put a 4 in the text box rather than turning the LCD back on.

This happened to me in my car, which is usually where I'm playing music. The Z sits on the passenger seat with the screen open. If I pick it up wrong, say at a stop light to see what's playing, this can happen.

Again, I put in a ticket at Katastrophos as an enhancement, but I thought I'd repeat it here.

Asterix
the_oak
I have been enjoying this media player for a while now, but recently had a problem with some movies that I had watched before not playing. I got a message saying something about a format problem (sorry, I didn't record exact message). I reinstalled Quasar, and Mplayer. This did not fix the problem. I deleted the movie, and re-copied it to the CF card, thinking maybe the movie file was corrupt. This did not fix it either. I finally deleted the playlists and remade them in quasar. That fixed the problem.

I'm guessing that maybe removing CF card with quasar open maybe corrupted the playlist file. Just putting this experience in this thread in case someone else has a similar problem.
speculatrix
you need to port this to Android and claim some of that bonus!
eviLjazz
Thanks for reporting the bugs! I'll try to fix them with the next release.
the_oak, weird problem there. Perhaps the media database got corrupted. In that case you can just delete ~/.quasar/quasar.sqlite3. Quasar will rebuild it then.

speculatrix, Android looks interesting. However, I don't jump on the bandwagon because there is a hype and a large company backing it. Besides, Android means Java(-like programming) and a different toolkit and thus simply porting won't work here. I just don't see any reason to rewrite Quasar for Android now. I'd rather stick with Qt as it has platform independence to start with. I have Quasar running on Sharp Qtopia/pdaXrom Qt/X11, Ubuntu (my laptop) and OS X (my workstation). And it will compile and run on any other Unix-like platform that has a Qt 2 or 3 port, a decent X11 server and mplayer. This is the reason why I ported Quasar to work with Qt and X11 in the first place. Same codebase, more choices!
Anyway, if anybody wants to hire me at a fulltime rate to rewrite Quasar for Android I am in for it! And seriously, I don't think Google would be interested in a media player. I think they are rather looking for new apps to better leverage their services. That's the whole point of the challenge.
matthis
I would like to listen to music that is on my computer's hd, with Quasar on my Z via wireless.
Is there any easy way to do that? Like support for itunes sharing or some other form of playlist sharing?

thanks
speculatrix
QUOTE(matthis @ Feb 27 2008, 11:28 AM) *
I would like to listen to music that is on my computer's hd, with Quasar on my Z via wireless.
Is there any easy way to do that? Like support for itunes sharing or some other form of playlist sharing?


samba share?
ofels
QUOTE(matthis @ Feb 27 2008, 12:28 PM) *
I would like to listen to music that is on my computer's hd, with Quasar on my Z via wireless.
Is there any easy way to do that? Like support for itunes sharing or some other form of playlist sharing?

thanks


*rant on* Did someone say UPnP support for Quasar ? rolleyes.gif

Oliver
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.