Help - Search - Members - Calendar
Full Version: Quasar Media Player Released For Sharprom And Pdaxrom
OESF Forums > General Forums > General Support and Discussion > Software
Pages: 1, 2, 3
eviLjazz


Finally! Almost a year after the first mentioning of my new media player for the Sharp Zaurus, Iím today officially releasing the Quasar Media Player for SharpROM- and pdaXrom-based distributions.
For more details please visit the projectís homepage: http://katastrophos.net/quasar

Click to view attachmentClick to view attachmentClick to view attachment


Please leave a comment, thanks!
adf
Very nice front end!
I'm still paying with it, so this is by no means a definitive review. On pdaxii13 it auto-decides that mplayer is mplayer2--there might be a better option available. Video playback is a bit choppy, as with other mplayer guis. this may be due to my still being new to the setup, though. I wouldn't take this as cause for concern yet.

All in all it seems like a really slick piece of media software, I'm ,looking forward to getting more familiar with it.
Cresho
man, this bitchen piece of software is so awsome. It took me by surprise. Kinda not use to it but after playing with it, it's simple and very sleek. Too bad not many outside of our little universe will enjoy it.

Most of my mp3's have embedded id3 tags with images. The album covers displayed is incredible. it showes my album cover standing up erect and slightly angled towards the right as if it was standing on glass. The bottom has the reflection of the album cover. It looks so fucken cool.......MAN!!!!

added more comments!!!!

More surprises the more you use it. Audio is sounding great.
koan
I'm testing Quasar on my 3200, pdaXii13.

In the menus, there is the entry e.g. "New Playlist", and some strange character on the right. It could be a symbol for a shortcut key but it hasn't rendered properly. Maybe you're expecting some special font ? Or maybe there's a keyboard graphic that hasn't loaded properly ? Most of them look like a box but some of them look like an fi ligature.


matthis
Fantastic software: fast loading of large library, very fast and easy sorting, very nice looking, fullscreen, etc... I use it to play movies too: I have the bvdd version of mplayer so the space to add options allowed me to rotate + double size videos for fullscreen playback.
THANKS!!!!
Antikx
Wow! Excellent job! I'm impressed with how polished it is.
Thanks for taking the time to make this program and share it with us.

FYI: it works on pdaXrom R198 too.
freizugheit
Will it work on SL-5600 with Sharp ROM?
xamindar
Wow, I was excited when I first saw this. But all my songs came up without titles after the scan as you can see in the attached pictures. Oh well. Still nice to see that people are still making amazing software for this device. I'll keep an eye on it and maybe someday it will be useful. Great job on the look though! blink.gif Maybe I need to change the font? I'll see if there is a section for that in the options.
Also, videos play rotated 90 degrees and on only half the screen, and there is no "redraw" when it is closed so my menus are all messed up with the video. I imagine it is a matter of telling mplayer to rotate 90 degrees and I'm trying to find the command right now. Don't take my post to be negative. I post to provide information on problems I have with it in the hope that these issues will get fixed.
Click to view attachmentClick to view attachment

Also, what is that BatteryPlus option? It is disabled on mine. Is it similar to the over clock function of kino2? It would be useful if it worked because I have found that the over clock has significant speed increase for videos.
xamindar
QUOTE(xamindar @ Oct 10 2007, 02:24 AM) *
Also, videos play rotated 90 degrees and on only half the screen, and there is no "redraw" when it is closed so my menus are all messed up with the video. I imagine it is a matter of telling mplayer to rotate 90 degrees and I'm trying to find the command right now.


Ahh, I needed to add "-vo bvdd" to the additional options section in the settings. Now it is using the wonderful bvdd for video and displays fullscreen correctly. Nice.
Antikx
I would recommend adding bug reports here: http://trac.katastrophos.net/quasar/newticket
...if you want to help him out.
eviLjazz
Hey, thanks for the comments! Glad some of you like it.

QUOTE
Will it work on SL-5600 with Sharp ROM?

The SL-5600 isn't supported yet. Somebody would have to adjust the current skin (located in /opt/QtPalmtop/share/quasar/skins/default) for QVGA resolution (320x240) or create a new skin. If anyone feels like doing so, go ahead and please send me the files so I can include them in the next release! smile.gif

QUOTE
Also, what is that BatteryPlus option? It is disabled on mine. Is it similar to the over clock function of kino2?

Yeah, it's an over/underclock function, but you have to install the BatteryPlus applet. To be honest, I never tested it myself. The feature was included in ZPlayer which Quasar is based on. I didn't remove it because I thought it would be useful to someone. Ideally, one would have to add support for freqchange and the extended battery applet which comes included with Cacko. We'll see...

Video playback hasn't been tested much, since I'm mostly using it for audio files. I'll probably iron out some of the issues in the next release.
As for the tag and song title issue, perhaps somebody could provide me with some MP3 files with Japanese or Korean tags, so I can debug the problem. I wasn't able to find free non-western MP3 tracks with ID3 tags yet.
xamindar
QUOTE(eviLjazz @ Oct 10 2007, 01:30 PM) *
Video playback hasn't been tested much, since I'm mostly using it for audio files. I'll probably iron out some of the issues in the next release.
As for the tag and song title issue, perhaps somebody could provide me with some MP3 files with Japanese or Korean tags, so I can debug the problem. I wasn't able to find free non-western MP3 tracks with ID3 tags yet.


Here is what I added to the mplayer options in quazar and it seems to work just fine on my 3100:
CODE
-vo bvdd -nortc -noaspect -dr -autosync 100


I also emailed you a few japanese mp3s to help with the tags.
eviLjazz
xamindar, thanks for the testfiles. I'm going to switch the tagging library for the next release. Hopefully this will fix the tag encoding issues once and for all.
pyrotek
Unreal!
so much better then the sharp player!

Just one question, might be me for that matter. How can I keep it playing when i close the lid on my c3200?
With the sharp rom i can hit play and off it goes when i close the lid it still plays

I can't seem to get Quasar to do that?

Thanks
eviLjazz
QUOTE(pyrotek @ Oct 10 2007, 11:34 PM) *
Just one question, might be me for that matter. How can I keep it playing when i close the lid on my c3200?
With the sharp rom i can hit play and off it goes when i close the lid it still plays
I can't seem to get Quasar to do that?

In Qtopia Quasar doesn't prevent suspending of the device when the lid is closed. However, I think I can add this feature. Just looking at the qcoptest output Sharp's Music Player seems to temporarily disable the suspend function by sending the message 'setEnableSuspendCoverClose(FALSE)' via the system's QCop channel. I'll add the same call to Quasar.
In the meantime you can also disable the suspend function completely via the Light & Power settings. The option for that is on the second tab page in the dialog.
snk4ever
I've sent you a message for getting CJK mp3s
eviLjazz
snk4ever and xamindar, thanks again for the testfiles!

I think most of the character encoding problems should be fixed now that the new tagging library (TagLib) is incorporated. At least all of the test files I received were displayed okay.
Besides, the initial scanning of audio files that are not already in the database should be a lot faster now. According to my quick tests the scanning of 3300 audio files took only 2 minutes - compared to 12 minutes when solely relying on MPlayer for the metadata-scanning. Pretty cool.

A new release should be out soon.
xamindar
QUOTE(eviLjazz @ Oct 12 2007, 03:13 AM) *
A new release should be out soon.


Yay, Can't wait to test it out! I must admit, I am sick of the sharp music player. While it does most of what I need, it is SSLLLOOOOOWWWW. Every time I turn on my Zaurus it tells me "o machi kudasai!" while it does whatever it dos.
ofels
Hehe, soon for Angstrom and OpenEmbedded...

The recipe is almost ready, one or to patch files still pending but that is a matter of minutes (hopefully).

Looks great on Angstrom also...

Any volunteer to check it into the OE repository ?

Oliver
ntw1103
Just downloaded it and gave it a try.
so far I haven't run into any problems, and everything works great.
Great job.
adf
QUOTE(ofels @ Oct 15 2007, 12:12 AM) *
Hehe, soon for Angstrom and OpenEmbedded...

The recipe is almost ready, one or to patch files still pending but that is a matter of minutes (hopefully).

Looks great on Angstrom also...

Any volunteer to check it into the OE repository ?

Oliver

excellent! (I bet it will be a killer on the neo)
ofels
QUOTE(adf @ Oct 17 2007, 05:55 AM) *
QUOTE(ofels @ Oct 15 2007, 12:12 AM) *
Hehe, soon for Angstrom and OpenEmbedded...

The recipe is almost ready, one or to patch files still pending but that is a matter of minutes (hopefully).

Looks great on Angstrom also...

Any volunteer to check it into the OE repository ?

Oliver

excellent! (I bet it will be a killer on the neo)


The recipe and patches are ready to be checked in. However I am looking for someone to check it into OE as I do not have write access to the monotone repository.

Looks great, although one might have to tweak the fonts a bit in the skins.ini file.

Oliver
Fushnchupsh
First off, amazing. I love the player. I have been awaiting this anxiously since antikx announced it on his site neigh one year ago.

I have a feature request for future releases. I would love to see the ability to switch to a gui with big buttons that control the simple functions of the player (ie next, back, volume, fastfwd, fastbkwd) much like the old sharp player. So, theoretically, if I was using it as a car mp3 player I wouldn't really need to look at the screen, searching for a button... had too many accidents to know they aren't fun.

I really hope this doesn't come off as ungreatful, I think this player is awsome and I appreciate the time and work you have put into it.

Thanks!
--Fish
eviLjazz
Thanks a lot for your feedbacks! I really appreciate it.
I hope to have the new release out this weekend if everything goes as planned.
Quite a lot of bugfixes and enhancements. Especially the video playback got some special treatment. smile.gif

Fushnchupsh, good idea. I was toying with the idea of extending the PlayInfo screen quite a bit. Bigger buttons could go there. Perhaps gestures too... However, this is a few releases away.
In the meantime you could either modify the skin for bigger buttons or just use the keyboard instead. I'm using my C3200 for audio playback in my car (in this cradle). Actually it is one of the few reason I'm developing Quasar. And controlling Quasar via keyboard works very well and IMO isn't nearly as distracting as soft-buttons on the display.
Fushnchupsh
actually, after I posted this, I set up my c3200 in the car and quasar works beautifully as is. I mean, bigger buttons would be neat, but I am toying with some other more....integrated ideas wink.gif... Now if I could only bring myself to put the dremel to my beloved pt cruiser's dash haha

Thanks for all of your hard work!

--Fish (using quasar as we speak)
ofels
QUOTE(eviLjazz @ Oct 19 2007, 10:56 PM) *
And controlling Quasar via keyboard works very well and IMO isn't nearly as distracting as soft-buttons on the display.


Most people do not have a fully fledged Z cradle for their cars and PDA cradles are not designed to have the keyboard open.
So the standard setup propably is to use the clamshell devices in PDA mode without keyboard and here a pure touchscreen interaction is extremely helpful.

Oliver
ofels
QUOTE(ofels @ Oct 17 2007, 09:53 PM) *
The recipe and patches are ready to be checked in. However I am looking for someone to check it into OE as I do not have write access to the monotone repository.


Nobody seemed to be interested to check the recipie into OE currently- I did not get any response.
So here is the ipk file, built for aklta and Angstrom, though it should also run on C3xxx devices.
May it be of any use.

Oliver
koen
QUOTE(ofels @ Oct 22 2007, 08:04 PM) *
QUOTE(ofels @ Oct 17 2007, 09:53 PM) *
The recipe and patches are ready to be checked in. However I am looking for someone to check it into OE as I do not have write access to the monotone repository.


Nobody seemed to be interested to check the recipie into OE currently- I did not get any response.
So here is the ipk file, built for aklta and Angstrom, though it should also run on C3xxx devices.
May it be of any use.

Oliver


You didn't attach the recipes to your mail and you didn't attach them to bugzilla. It's very hard for us to check things in we don't have access to.
snk4ever
I installed the latest version available at your website but it doesn't display the Asian nor French caracters...
Is it coming in a later version or should it be available now ?
eviLjazz
No, unfortunately the new version 0.9 isn't out yet. I've been too busy with other stuff. Hopefully tonight or sometime tomorrow...
Version 0.85 uses the old tagging library which has the Unicode quirks.
snk4ever
Ok, no problems, I just thought that you released it since you said you fixed it. I'm not in a hurry, I just wanted to try it.
ofels
QUOTE(koen @ Oct 22 2007, 10:15 PM) *
QUOTE(ofels @ Oct 22 2007, 08:04 PM) *
QUOTE(ofels @ Oct 17 2007, 09:53 PM) *
The recipe and patches are ready to be checked in. However I am looking for someone to check it into OE as I do not have write access to the monotone repository.


Nobody seemed to be interested to check the recipie into OE currently- I did not get any response.
So here is the ipk file, built for aklta and Angstrom, though it should also run on C3xxx devices.
May it be of any use.

Oliver


You didn't attach the recipes to your mail and you didn't attach them to bugzilla. It's very hard for us to check things in we don't have access to.


I had sent mails including attachments to OE people directly, I have asked for volunteers on the angstrom mailing list and here without even getting a reply.
A simple "please send the patches to me or attach them to bugzilla" would have been sufficient instead of silence. Sounds like "leave me alone with that" wink.gif

I will add the files to bugzilla.

Oliver


ofels
QUOTE(ofels @ Oct 24 2007, 08:27 AM) *
I will add the files to bugzilla.


Bug 3224 added with the files required for committing it to OE.

Oliver
the_oak
An SL-6000 user here (default Sharp rom). Quasar is absolutely beautiful!! It is also about 30 seconds faster opening than Zplayer. (Zplayer is really slow opening, about 40 seconds.) It plays music files very nicely and created a playlist for both music and video. Very nice indeed.

For other SL-6000 users information, the mplayer settings I used are:

-vo fbdev -fbmode qvga -vm -vop rotate=1

I have only one issue with this. If I view a video, then close the video, the screen does not redraw properly. Parts of the screen remain blank. Rotating the screen and then rotating it back fixes the problem. Zplayer did not have this problem, so there must be some useful code somewhere in there that affects this.

Kino2 also had this problem and I seem to recall a Qcop call (or lack thereof) being suspected as the cause. However, I am not a programmer, so I don't know. Another contributing factor may be our lack of an updated video driver for the SL-6000.

I have submitted a bug report also to:http://trac.katastrophos.net/quasar/newticket

Keep up the good work, and thanks a million!!
eviLjazz
The new release is finally out. The big changes in this version:
- Better tag reading and Unicode support
- Many improvements and bugfixes for video playback

Please check the website for details:
http://katastrophos.net/quasar
eviLjazz
QUOTE(the_oak @ Oct 28 2007, 09:32 AM) *
I have only one issue with this. If I view a video, then close the video, the screen does not redraw properly. Parts of the screen remain blank.

Thanks for reporting! The bug has been squashed in the new release. wink.gif
xamindar
Yay! Thanks for this release. It works a lot better. My music files do show the tag info now but only if they are in english. Any Japanese characters are square boxes so it seems that quazar is simply using a non-unicode font. Is there a way I can change the font that it uses? Which font IS it using? Thanks again!
the_oak
QUOTE(eviLjazz @ Oct 28 2007, 08:04 PM) *
The bug has been squashed in the new release. wink.gif


Just downloaded 0.9 version. The bug is indeed squashed!!!!!!! Wonderful. This media player has all the features I want, looks great, opens quickly, plays movies or mp3s, and redraws the screen fine. I couldn't ask for more. This has to be the best media player for Zaurus.

Thanks!!
adf
QUOTE(the_oak @ Oct 28 2007, 09:32 AM) *
An SL-6000 user here (default Sharp rom). Quasar is absolutely beautiful!! It is also about 30 seconds faster opening than Zplayer. (Zplayer is really slow opening, about 40 seconds.) It plays music files very nicely and created a playlist for both music and video. Very nice indeed.

For other SL-6000 users information, the mplayer settings I used are:

-vo fbdev -fbmode qvga -vm -vop rotate=1

I have only one issue with this. If I view a video, then close the video, the screen does not redraw properly. Parts of the screen remain blank. Rotating the screen and then rotating it back fixes the problem. Zplayer did not have this problem, so there must be some useful code somewhere in there that affects this.

Kino2 also had this problem and I seem to recall a Qcop call (or lack thereof) being suspected as the cause. However, I am not a programmer, so I don't know. Another contributing factor may be our lack of an updated video driver for the SL-6000.

I have submitted a bug report also to:http://trac.katastrophos.net/quasar/newticket

Keep up the good work, and thanks a million!!

Was there a patched kernel for better audio, as there is with the 3x00 Z's?
eviLjazz
QUOTE(xamindar @ Oct 28 2007, 04:37 PM) *
Yay! Thanks for this release. It works a lot better. My music files do show the tag info now but only if they are in english. Any Japanese characters are square boxes so it seems that quazar is simply using a non-unicode font. Is there a way I can change the font that it uses? Which font IS it using? Thanks again!

By default it is using Helvetica and in most distros it seems to miss some of the necessary Unicode glyphs.
I've just checked against the font "Lcfont" and Quasar displays the Japanese characters just fine then. However, Korean and Chinese characters aren't displayed correctly. So, it's really a matter of having the right font installed. Covering all possible Unicode areas in the bitmap fonts that are used in Qtopia is space-consuming.
I mostly tested on OS X in X11 and it displays everything just fine, but we have True Type fonts and Freetype rendering there instead of bitmap fonts...

The fonts are defined in the skin ini file:
/opt/QtPalmtop/share/quasar/skins/default/skin.ini

You'll have to adjust the sections [bigmode], [normalmode], [smallmode]. Change playlist_font, playlistoverview_font and playinfo_font to use "Lcfont" instead of "helvetica".
But beware, it's a mess!
eviLjazz
QUOTE(adf @ Oct 28 2007, 08:19 PM) *
Was there a patched kernel for better audio, as there is with the 3x00 Z's?

Nopes. The SL-6000 is using a different chip (WM9712). I can tell from the specs it supports "Tone Control", "Bass Boost" and "3D Enhancements": http://www.wolfsonmicro.com/uploads/documents/en/WM9712L.pdf
I'm sure it would be possible to hack the driver. I just don't have a device to test with...
tovarish
do you know which sound chip the c860(7xx) uses and if your audio enhancements could be available on the c860 too.


*UPDATE*
I found out that it is the wm8731 and this one doesnt have digital graphic equaliser so bummer sad.gif

tovarish
xamindar
Thanks so much eviljazz. This is really the best music player for the zaurus now.
enclose789
I'm using 6000L with Sharp ROM, and I had installed Quasar Media Player (0.9) twice on my Z, but so sad that it could not work on my Z.

My situation was:
Installed fine. The first time to startup the program fine, but I could not play any MP3 or MPEG file. Therefore, I closed Quasar Media Player and re-executed it again. However, the program just hangs there and nothing happened. Namely, installing with package manager goes fine, but I can not to actually start it. I don't know how to make it work on my Z.

FYI, I only use the stock Mplayer, without any addition libs. Shall I install another libs on my 6000L?? I hope that someone could help me to use this execellent player on my Z, thanks in advance!

------------------------------------------------------------------------------------
Update:

It's strange that I can "enter" this program's control panel now. When I add the mp3 from a file, I could see this song shows up in the On-The-Go Playlist. However, when I push the "play" botton, it always shows the information that "mplayer could not be executed or was not found on your system. Would you like to specify the location of the mplayer binary on your system?"

So I go to "tools" --> "configuration" --> "mplayer", I specify the location as "/home/Qtpalmtop/bin/mpegplayer" (I cannot file a file called "mplayer"), then re-play the song. But the same information still shows up.

I still could use the original "Media Player" on my 6000L, please tell me how to specify the location of the mplayer binary. Thanks in advance.
adf
QUOTE(enclose789 @ Nov 6 2007, 05:14 AM) *
I'm using 6000L with Sharp ROM, and I had installed Quasar Media Player (0.9) twice on my Z, but so sad that it could not work on my Z.

My situation was:
Installed fine. The first time to startup the program fine, but I could not play any MP3 or MPEG file. Therefore, I closed Quasar Media Player and re-executed it again. However, the program just hangs there and nothing happened. Namely, installing with package manager goes fine, but I can not to actually start it. I don't know how to make it work on my Z.

FYI, I only use the stock Mplayer, without any addition libs. Shall I install another libs on my 6000L?? I hope that someone could help me to use this execellent player on my Z, thanks in advance!

It appears to work on mine, though I didn't try it out very thoroughly. I'll give it a good run and see what it does.
enclose789
QUOTE(adf @ Nov 6 2007, 08:09 PM) *
It appears to work on mine, though I didn't try it out very thoroughly. I'll give it a good run and see what it does.


Thank you adf!!
ZDevil
Hi, eviLjazz,

I am thinking of porting this to Debian EABI. Would that be possible? Thanks.

zdevil
ZDevil
QUOTE(ZDevil @ Nov 7 2007, 08:40 AM) *
Hi, eviLjazz,
I am thinking of porting this to Debian EABI. Would that be possible? Thanks.
zdevil


Hi, zdevil,
Yes, it is possible, because I just got it compiled and running on my 3200@Debian(EABI) (with some small tweaks in the .pro and the Makefile)!
Cheers,
zdevil
ZDevil
Here a screencap of my Debian (armel) build:
Click to view attachment

And the Debian package has been uploaded here: http://www.oesf.org/forum/index.php?showto...st&p=170927

Thanks, eviLjazz for this great app!



the_oak
QUOTE
it always shows the information that "mplayer could not be executed or was not found on your system. Would you like to specify the location of the mplayer binary on your system?"

So I go to "tools" --> "configuration" --> "mplayer", I specify the location as "/home/Qtpalmtop/bin/mpegplayer" (I cannot file a file called "mplayer"), then re-play the song. But the same information still shows up.

I still could use the original "Media Player" on my 6000L, please tell me how to specify the location of the mplayer binary. Thanks in advance.



The mplayer I have installed is: mplayer-bvdd version 1.1.5-1. It installed links to itself in several places (/home/Qtpalmtop/bin/ being one of them). I think I downloaded it from here:

http://atty.skr.jp/pub/zaurus/mplayer/mpla...1.1.5-1_arm.ipk

Hope this helps.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.